printconf scheitert - drucker wird nciht erkannt

RlDdLeR

BENUTZT GOOGLE - VERDAMMT
Beiträge
702
Hallo!
Ich habe einen HP PSC 2110 Drucker! Ich habe Redhat 9. Bei einer früheren Installation hatte ich den Drucker schonmal konfiguriert, aber jetzt klappt es nciht mehr.

Ich bekomme immer diese Fehlermeldung:

[root@localhost riddler]# printconf
Can't locate Foomatic/Defaults.pm in @INC (@INC contains: /usr/local/lib/perl5/5.8.0/i686-linux-thread-multi /usr/local/lib/perl5/5.8.0 /usr/local/lib/perl5/site_perl/5.8.0/i686-linux-thread-multi /usr/local/lib/perl5/site_perl/5.8.0 /usr/local/lib/perl5/site_perl .) at /usr/bin/foomatic-configure line 13.
BEGIN failed--compilation aborted at /usr/bin/foomatic-configure line 13.
Traceback (most recent call last):
File "/usr/share/printconf/util/queueTree.py", line 489, in new_button_clicked
self.use_foomatic ()
File "/usr/share/printconf/util/queueTree.py", line 421, in use_foomatic
self.conf.foomatic_init_overview ()
File "/usr/share/printconf/util/printconf_conf.py", line 1472, in foomatic_init_overview
root = parser.parse (foo)
File "/usr/src/build/219081-i386/install/usr/lib/python2.2/site-packages/_xmlplus/utils/qp_xml.py", line 134, in parse
xml.parsers.expat.ExpatError: no element found: line 1, column 0

Was kann ich tun?

MfG
RlDdLeR
 

Belkira

Routinier
Beiträge
255
[root@localhost riddler]# printconf
Can't locate Foomatic/Defaults.pm in @INC (@INC contains: /usr/local/lib/perl5/5.8.0/i686-linux-thread-multi /usr/local/lib/perl5/5.8.0 /usr/local/lib/perl5/site_perl/5.8.0/i686-linux-thread-multi /usr/local/lib/perl5/site_perl/5.8.0 /usr/local/lib/perl5/site_perl .) at /usr/bin/foomatic-configure line 13.
Warum werden Perl Module bei Dir in /usr/local/lib gesucht, anstatt in /usr/lib, wo sie sich bei Red Hat Linux befinden?

/usr/lib/perl5/vendor_perl/5.8.0/Foomatic/Defaults.pm
 

RlDdLeR

BENUTZT GOOGLE - VERDAMMT
Beiträge
702
keine ahnung warum er dort sucht-...

aber mir scheint auch, es liegt an diesem foomatic.... :( es geht immernoch nciht...
 

RlDdLeR

BENUTZT GOOGLE - VERDAMMT
Beiträge
702
[riddler@localhost riddler]$ which perl
/usr/local/bin/perl

[riddler@localhost riddler]$ which perl
/usr/local/bin/perl
[riddler@localhost riddler]$ perl -v

This is perl, v5.8.0 built for i686-linux-thread-multi

Copyright 1987-2002, Larry Wall

Perl may be copied only under the terms of either the Artistic License or the
GNU General Public License, which may be found in the Perl 5 source kit.

Complete documentation for Perl, including FAQ lists, should be found on
this system using `man perl' or `perldoc perl'. If you have access to the
Internet, point your browser at http://www.perl.com/, the Perl Home Page.

[riddler@localhost riddler]$ perl -V
Summary of my perl5 (revision 5.0 version 8 subversion 0) configuration:
Platform:
osname=linux, osvers=2.4.20-18.9, archname=i686-linux-thread-multi
uname='linux localhost.localdomain 2.4.20-18.9 #1 thu may 29 06:54:41 edt 2003 i686 athlon i386 gnulinux '
config_args='-de -Dusethreads'
hint=recommended, useposix=true, d_sigaction=define
usethreads=define use5005threads=undef useithreads=define usemultiplicity=define
useperlio=define d_sfio=undef uselargefiles=define usesocks=undef
use64bitint=undef use64bitall=undef uselongdouble=undef
usemymalloc=n, bincompat5005=undef
Compiler:
cc='cc', ccflags ='-D_REENTRANT -D_GNU_SOURCE -fno-strict-aliasing -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I/usr/include/gdbm',
[riddler@localhost riddler]$ perl -V
Summary of my perl5 (revision 5.0 version 8 subversion 0) configuration:
Platform:
osname=linux, osvers=2.4.20-18.9, archname=i686-linux-thread-multi
uname='linux localhost.localdomain 2.4.20-18.9 #1 thu may 29 06:54:41 edt 2003 i686 athlon i386 gnulinux '
config_args='-de -Dusethreads'
hint=recommended, useposix=true, d_sigaction=define
usethreads=define use5005threads=undef useithreads=define usemultiplicity=define
useperlio=define d_sfio=undef uselargefiles=define usesocks=undef
use64bitint=undef use64bitall=undef uselongdouble=undef
usemymalloc=n, bincompat5005=undef
Compiler:
cc='cc', ccflags ='-D_REENTRANT -D_GNU_SOURCE -fno-strict-aliasing -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I/usr/include/gdbm',
optimize='-O3',
cppflags='-D_REENTRANT -D_GNU_SOURCE -fno-strict-aliasing -I/usr/include/gdbm'
ccversion='', gccversion='3.2.2 20030222 (Red Hat Linux 3.2.2-5)', gccosandvers=''
intsize=4, longsize=4, ptrsize=4, doublesize=8, byteorder=1234
d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=12
ivtype='long', ivsize=4, nvtype='double', nvsize=8, Off_t='off_t', lseeksize=8
alignbytes=4, prototype=define
Linker and Libraries:
ld='cc', ldflags =' -L/usr/local/lib'
libpth=/usr/local/lib /lib /usr/lib
libs=-lnsl -lgdbm -ldb -ldl -lm -lpthread -lc -lcrypt -lutil
perllibs=-lnsl -ldl -lm -lpthread -lc -lcrypt -lutil
libc=/lib/libc-2.3.2.so, so=so, useshrplib=false, libperl=libperl.a
gnulibc_version='2.3.2'
Dynamic Linking:
dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=undef, ccdlflags='-rdynamic'
cccdlflags='-fpic', lddlflags='-shared -L/usr/local/lib'


Characteristics of this binary (from libperl):
Compile-time options: MULTIPLICITY USE_ITHREADS USE_LARGE_FILES PERL_IMPLICIT_CONTEXT
Built under linux
Compiled at Jun 25 2003 17:41:51
@INC:
/usr/local/lib/perl5/5.8.0/i686-linux-thread-multi
/usr/local/lib/perl5/5.8.0
/usr/local/lib/perl5/site_perl/5.8.0/i686-linux-thread-multi
/usr/local/lib/perl5/site_perl/5.8.0
/usr/local/lib/perl5/site_perl
.
[riddler@localhost riddler]$


bittesehr
 

Belkira

Routinier
Beiträge
255
Und damit wiederhole ich quasi meinen ersten Kommentar:

Wo kommt diese Perl Version in /usr/local her?

Warum läßt Du mich raten, was Du installiert hat, was nicht von Red Hat kommt? Du hast ein Perl selbst compiliert und installiert und unterschlägst diese Information.

Built under linux
Compiled at Jun 25 2003 17:41:51
Huch? Heute sogar... :rolleyes:

Kein lustiges Rätsel, Riddler. :D
 

RlDdLeR

BENUTZT GOOGLE - VERDAMMT
Beiträge
702
Ich habe heute versucht, es neu zu installieren, hat aber auch das Problem nciht behoben!

Ich habe es einfach so kompiliert wie in der INSTALL steht, der hat das selbst da hin gepackt!
 

Belkira

Routinier
Beiträge
255
Perl 5.8.0 ist bei Red Hat Linux 9 dabei. Bräuchtest Du nur als rpm installieren.

Warum Du meinst, es selbst compilieren zu müssen, keine Ahnung. Hast es wahrscheinlich nicht für /usr konfiguriert.
 

Belkira

Routinier
Beiträge
255
Häh? Perl wird von sovielen Komponenten benötigt, das ist bei dir doch sicherlich installiert.

rpm -q perl
rpm -q --whatrequires perl

Wie hast Du denn Red Hat Linux 9 installiert? Perl ist doch auf den CDs.

Lösch einfach Deine vermurkste Installation in /usr/local, dann kommt sicher über den PATH ein /usr/bin/perl zum Vorschein. ;)
 

Ähnliche Themen

Nagios Plugin "check_clamav"

dovecot und postfix Konfiguration Problem

OpenSUSE 12.1: Gnucash startet nicht mehr

Ubuntu 12.04: Installation Drucker / Parallel Port

1& Virtual Server openSUSE 10.3 mit Plesk 9 (64 Bit)

Neueste Themen

Oben