Postfix Verzögerung im Verbindungsaufbau

karloff

Routinier
Beiträge
322
Hallo,
ich hab ein komisches Problem seit ich weiß genau genommen gar nicht seit wann, sagen wir mal seit einiger Zeit. Und zwar dauert der Verbindungsaufbau beim Postfix ungewöhnlich lange. Mittlerweile denke ich das es nicht am Postfix liegt, aber mir fällt auch keine wirkliche Erklärung ein was sonst der Fall sein könnte.
Folgendes Problem wenn ich z.B. eine Verbindung via Telnet aufbaue
Code:
[karloff@Unix ~]$ telnet mail.example.net 25
Trying 2a01:XXXX:XXX::2...
Connected to mail.example.net.
Escape character is '^]'.

<Ziemlich genau 10 Sekunden passiert gar nichts>

220 mail.example.net ESMTP NO UCE
In den Logfiles kommt das event auch erst in dem Moment in dem der 220 Promt erscheint.

Ob ich die Verbindung über IPv4 oder IPv6 aufbaue macht keinen Unterschied.
Nach dem Promt ist dann alles okay, 3 sekunden incl amvisd - also die performace wird es nicht sein - die Anbindung auch eher nicht da die Maschine bei Hetzer im RZ steht.

Soweit zum Problem, hat Jemand eine Idee was hier die Ursache sein könnte?
Oder eine Idee wie oder was man hier debuggen kann?

Grüße
karloff
 

marce

Kaiser
Beiträge
1.297
Spontane Vermutung: würde in Richtung Reverse-DNS-Auflösung des Clients suchen...

(ansonsten - Loglevel hochdrehen, ...)
 

karloff

Routinier
Beiträge
322
Ne leider nicht - weder noch - debug log hochdrehen bringt nichts wenn das erste event erst nach den besagten 10 sec triggert.
 

karloff

Routinier
Beiträge
322
korrektur:
Stimmt nicht ganz
Code:
Oct  9 16:04:24 localhost postfix/smtpd[13067]: connection established
Oct  9 16:04:24 localhost postfix/smtpd[13067]: master_notify: status 0
Oct  9 16:04:24 localhost postfix/smtpd[13067]: name_mask: resource
Oct  9 16:04:24 localhost postfix/smtpd[13067]: name_mask: software
Oct  9 16:04:34 localhost postfix/smtpd[13067]: connect from mout.web.de[212.227.17.12]
Oct  9 16:04:34 localhost postfix/smtpd[13067]: match_list_match: mout.web.de: no match
Mehr gibt der debug aber leider nicht her.
 

Ähnliche Themen

dovecot und postfix Konfiguration Problem

Postfix und kein Ende

Squirrelmail verbindet sich... nicht.

Postfix und Cyrus – Ich kann kein Email senden!

TLS und telnet

Oben