MyODBC ***grrrr****

Ruebenmaster

Ruebenmaster

Edna lebt! mit OpenSuSE
Hallo Leute,
ich hab ein kleines Problem, besser gesagt ein Ausgewachsenes...

Ich habe auf meine SuSE Linux 8.1 die MySQL Datenbank in der Version 3.23.52 am Laufen.

Nun versuche ich von Windoof-Clients per ODBC auf eine von mir erstellte Datenbank zuzugreifen. Der Benutzer, der im ODBC treiber eingetragen ist hat alle Rechte auf die Datenbank und ist auch als User bei Linux angelegt.

Sobald ich versuche übers Netz zuzugreifen bekomme ich folgende Meldung. Sie kommt übrigens auch beim Zugriff auf die "Test" Datenbank von MySQL.

"ODBC Aufruf fehlgeschlagen"
[TCX][MyODBC]Lost connection to MySQL server during query (#2013)

Kann mir jemand nen Tipp geben, wie ich auf meine Datenbanken zugreifen kann.

Ich hab vor Kurzem die gleiche Datenbanksituation in einem anderen Netz konfiguriert, da hat es geklappt... Allerdings mit SuSE 8.0 und MySQL 3.23.48.

Lokal läuft sie einwandfrei. Auch per Webmin kann ich Tabellen anlegen usw. Nur der ODBC (2.50.x und 3.51.x) mag mich nicht!

Viele Grüsse
DER Ruebenmaster

Ich hab inzwischen einen ODBC Trace laufen lassen. Er faselt was von Time Out bei der Anmeldung, doch seht selbst:

MSACCESS 578-5b4 ENTER SQLAllocEnv
HENV * 0012C77C

MSACCESS 578-5b4 EXIT SQLAllocEnv with return code 0 (SQL_SUCCESS)
HENV * 0x0012C77C ( 0x078e14f0)

MSACCESS 578-5b4 ENTER SQLAllocConnect
HENV 078E14F0
HDBC * 0012C88C

MSACCESS 578-5b4 EXIT SQLAllocConnect with return code 0 (SQL_SUCCESS)
HENV 078E14F0
HDBC * 0x0012C88C ( 0x078e1598)

MSACCESS 578-5b4 ENTER SQLSetConnectOption
HDBC 078E1598
UWORD 103 <SQL_LOGIN_TIMEOUT>
SQLLEN 20

MSACCESS 578-5b4 EXIT SQLSetConnectOption with return code 0 (SQL_SUCCESS)
HDBC 078E1598
UWORD 103 <SQL_LOGIN_TIMEOUT>
SQLLEN 20

MSACCESS 578-5b4 ENTER SQLSetConnectAttrW
SQLHDBC 078E1598
SQLINTEGER 30002 <unknown>
SQLPOINTER [Unknown attribute 30002]
SQLINTEGER -3

MSACCESS 578-5b4 EXIT SQLSetConnectAttrW with return code 0 (SQL_SUCCESS)
SQLHDBC 078E1598
SQLINTEGER 30002 <unknown>
SQLPOINTER [Unknown attribute 30002]
SQLINTEGER -3

MSACCESS 578-5b4 ENTER SQLDriverConnectW
HDBC 078E1598
HWND 001101CC
WCHAR * 0x1F7D8BF8 [ -3] "******\ 0"
SWORD -3
WCHAR * 0x1F7D8BF8
SWORD 8
SWORD * 0x00000000
UWORD 1 <SQL_DRIVER_COMPLETE>

MSACCESS 578-5b4 EXIT SQLDriverConnectW with return code -1 (SQL_ERROR)
HDBC 078E1598
HWND 001101CC
WCHAR * 0x1F7D8BF8 [ -3] "******\ 0"
SWORD -3
WCHAR * 0x1F7D8BF8
SWORD 8
SWORD * 0x00000000
UWORD 1 <SQL_DRIVER_COMPLETE>

DIAG [S1000] [TCX][MyODBC]Lost connection to MySQL server during query (2013)

MSACCESS 578-5b4 ENTER SQLErrorW
HENV 078E14F0
HDBC 078E1598
HSTMT 00000000
WCHAR * 0x0012C748 (NYI)
SDWORD * 0x0012C794
WCHAR * 0x02C0D9E0
SWORD 4095
SWORD * 0x0012C784

MSACCESS 578-5b4 EXIT SQLErrorW with return code 0 (SQL_SUCCESS)
HENV 078E14F0
HDBC 078E1598
HSTMT 00000000
WCHAR * 0x0012C748 (NYI)
SDWORD * 0x0012C794 (2013)
WCHAR * 0x02C0D9E0 [ 57] "[TCX][MyODBC]Lost connection"
SWORD 4095
SWORD * 0x0012C784 (57)

MSACCESS 578-5b4 ENTER SQLErrorW
HENV 078E14F0
HDBC 078E1598
HSTMT 00000000
WCHAR * 0x0012C748 (NYI)
SDWORD * 0x0012C794
WCHAR * 0x02C0DA6A
SWORD 4026
SWORD * 0x0012C784

MSACCESS 578-5b4 EXIT SQLErrorW with return code 100 (SQL_NO_DATA_FOUND)
HENV 078E14F0
HDBC 078E1598
HSTMT 00000000
WCHAR * 0x0012C748 (NYI)
SDWORD * 0x0012C794
WCHAR * 0x02C0DA6A
SWORD 4026
SWORD * 0x0012C784

MSACCESS 578-5b4 ENTER SQLFreeConnect
HDBC 078E1598

MSACCESS 578-5b4 EXIT SQLFreeConnect with return code 0 (SQL_SUCCESS)
HDBC 078E1598

MSACCESS 578-5b4 ENTER SQLFreeEnv
HENV 078E14F0

MSACCESS 578-5b4 EXIT SQLFreeEnv with return code 0 (SQL_SUCCESS)
HENV 078E14F0

Vielleicht weiss ja ein wirres Datenbankköpfchen, was ich falsch machen tu... ! *traurigguck*
 
Zuletzt bearbeitet:
Ruebenmaster

Ruebenmaster

Edna lebt! mit OpenSuSE
;)
Hallo Leute,
nachdem niemand eine Idee hatte, wie ich auf MySQL zugreifen konnet hab ich alle Lx Jogis die ich kenne auf das Problem angesetzt. Wir sind zu der Überzeugung gekommen, wenn allerdings nicht ganz beweisbar, das die MySQL Administration über Webmin unter SuSE 8.1 nicht einwandfrei übersetzt wird. Auch das Update auf SuSE 8.2 brachte keine Linderung, sondern das völlig neu konfigurieren der User und Database Permissions am Server lokal.

So jetzt läuft er. ...lief er. Ich hab den Rappel gekriegt und die Nürnberger Würstelsbude heruntergeschmissen. Jetzt ist debian 3.0 drauf und ich richte ihn gerade neu ein...

Viele Grüsse
Ruebenmaster
 

Ähnliche Themen

JBidWatcher: Problem bei loading Auctions in Verbindung mit mySQL

Akonadi startet nicht mehr

Rollei Mini Wifi Camcorder

Samba 4 Gast Zugang unter Ubuntu funktioniert nicht

CentOS 6.3 RADIUS - Keine Verbindung möglich

Oben