isch brauch ma hilfää

AeroSouL

Jungspund
Beiträge
14
ich hab jetzt vor kurzem zwei rpm's gesaugt
ein source von licq und Licq selbst (denke ich) weil ich hier an dem arbeitsplatz keine suse cd's ned bei hab ..

ich hab nu die frage wie krieg ich die dinger zum laufen

ich hab beide rpm's ausgeführt
aber es tat sich nichts großartiges
ich wurd nur im kpackage dazu aufgefordert mein root Pw einzugeben und sonst passierte nix ..

als ich dann in der console den befehl ausführte
hat's ein paar verzeichnisse angelegt . aber als ich das programm selbst starten wollte .. tat sich nix .. ??

wat hab ich'n falsch gemacht ????
 

Dr_Ompaa

Hobbyphilosoph
Beiträge
473
Hm, gute Frage :rolleyes:

Also, eigentlich sollte es so gehen (natürlich als root eingeloggt):

1. rpm-Packet doenloaden
2. cd /Verzeichnis_wos_is
3. rpm -i packetname.rpm
4. schauen, dass keine Fehlermeldungen kommn
5. Programmnamen eingeben

Wenns nicht geht, nach dem Prog suchen:

locate mein_programm_das_net_laufen_will

Wenn du das Verzeichnis gefunden hast (heißer TIP: meistens in /usr/share oder /usr/local) die Programfile finden und

ln -s /pfad/zum/prog /usr/bin/name_des_prog


Wenns immer noch nicht geht, poste zurück, mal sehen was ich dann für dich tun kann :]
 

AeroSouL

Jungspund
Beiträge
14
ich sach ma so .. das hat was bewirkt
doch wenn ich nun die verknüpfung zu dem programm ausführe
wird irgendwas ausgeführt was dann nicht mehr erscheint weil es wahrscheinlich in einen Timeout rennt
oder weiss was ich ..
aufjeden fall funzt es wenn ich als root eingeloggt bin aber ned in meinem standart user mode?

ich muss des glaub ich noch ma üben mit dem rpm's besonders wenn ich auf 'n neueres KDE updaten will :D

Danke für die Hilfe :)
 
Zuletzt bearbeitet:

Dr_Ompaa

Hobbyphilosoph
Beiträge
473
Ach das Porblem is ganz einfach zu beheben:

Einfach als root rein und:

chmod a+rx /usr/bin/dein_prog

Als Erklärung: chmod verändert die Userrechte, also z.B.:

chmod a+rwx datei.foo

gibt allen (a) Leserechte (read), Schreibrechte (write) und Ausführrechte (execute)
+ gibt die Rechte dazu
- nimmt sie logischerweise weg

versuch mal man chmod für mehr infos, denn wenn man mit der Konsole arbeiten will,
kommt man um diesen Befehl kaum rum


Das sollts sein :)
 
Zuletzt bearbeitet:

devilz

Pro*phet
Beiträge
12.245
Originally posted by AeroSouL
ich hab jetzt vor kurzem zwei rpm's gesaugt
ein source von licq und Licq selbst (denke ich) weil ich hier an dem arbeitsplatz keine suse cd's ned bei hab ..

ich hab nu die frage wie krieg ich die dinger zum laufen

ich hab beide rpm's ausgeführt
aber es tat sich nichts großartiges
ich wurd nur im kpackage dazu aufgefordert mein root Pw einzugeben und sonst passierte nix ..

als ich dann in der console den befehl ausführte
hat's ein paar verzeichnisse angelegt . aber als ich das programm selbst starten wollte .. tat sich nix .. ??

wat hab ich'n falsch gemacht ????

BEIDE RPMS ausgeführt ???

Es gibt nur ein SuSE RPM :)
Da scheint schonmal der erste Fehler zu sein :)))

War schon licq installiert ???

Ansonsten zieh dir das source .. entpacke das ... compielere mit ./configure, ./make und ./make install ... dann wechsel ins plugin verzeichnis und compiliere die plugins ....

Dann sollte das rennen ...

Gehts ???
 

Neueste Themen

Oben