installation von Net::SSLeay

Diskutiere installation von Net::SSLeay im SuSE / OpenSuSE Forum im Bereich Linux Distributionen; Hallo, auf dem Server läuft Suse 9.3 . Ich müsste Net::SSLeay installieren. Nur leider bringt es mir folgende Meldung: rpm -i...

  1. float

    float Grünschnabel

    Dabei seit:
    21.02.2008
    Beiträge:
    4
    Zustimmungen:
    0
    Hallo,

    auf dem Server läuft Suse 9.3 .

    Ich müsste Net::SSLeay installieren. Nur leider bringt es mir folgende Meldung:

    Code:
    rpm -i perl-Net_SSLeay-1.25-31.x86_64.rpm
            package perl-Net_SSLeay-1.25-31 is already installed
            file /var/adm/perl-modules/perl-Net_SSLeay from install of perl-Net_SSLeay-1.25-31 conflicts with file from package perl-Net_SSLeay-1.25-31
    Es sagt mir also das es schon installiert wäre.... nur sagt mir das hier doch etwas anderes:

    Code:
    perl -MNet::SSLeay -e 'print "$Net::SSLeay::VERSION\n"'
    Can't locate Net/SSLeay.pm in @INC (@INC contains: /usr/lib/perl5/5.8.6/x86_64-linux-thread-multi /usr/lib/perl5/5.8.6 /usr/lib/perl5/site_perl/5.8.6/x86_64-linux-thread-multi /usr/lib/perl5/site_perl/5.8.6 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.6/x86_64-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.6 /usr/lib/perl5/vendor_perl .).
    BEGIN failed--compilation aborted.
    
    Ich hatte das zuerst das i586 rpm file installieren wollen, da kam aber weder eine Fehlermeldung noch eine Bestätigung.

    Normalerweise nutze ich yast, jedoch zeigt es mir nach der Auswahl "Software installieren oder löschen" nicht die gewohnte Oberfläche. Es stürzt anscheinend ab.

    Hat jemand eine Idee?
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 Aqualung, 21.02.2008
    Aqualung

    Aqualung Routinier

    Dabei seit:
    12.02.2008
    Beiträge:
    404
    Zustimmungen:
    0
    AFAIK ist perl sehr wählerisch was pfade angeht. gibt es vielleicht in

    Code:
    /usr/lib/perl5/
    mehr als ein Unterverzeichnis?

    Du kannst es auch so installieren, kann aber ein bischen komplizierter werden:

    Code:
    perl -MCPAN -e 'install Net::SSLeay'
    Gruß Aqualung
     
  4. float

    float Grünschnabel

    Dabei seit:
    21.02.2008
    Beiträge:
    4
    Zustimmungen:
    0
    Ja, da gibt es mehrere Ordner.

    Code:
     cd /usr/lib/perl5/
    s15210657:/usr/lib/perl5 # ll
    insgesamt 20
    drwxr-xr-x   6 root root   64 2005-09-23 10:16 .
    drwxr-xr-x  30 root root 8192 2008-02-05 17:26 ..
    drwxr-xr-x  46 root root 4096 2005-06-09 15:52 5.8.6
    drwxr-xr-x   3 root root   18 2005-06-09 11:46 site_perl
    drwxr-xr-x   2 root root   21 2007-10-07 23:59 utils
    drwxr-xr-x   3 root root   18 2005-06-09 11:46 vendor_perl
    
    Gruß
    float
     
  5. #4 Aqualung, 21.02.2008
    Aqualung

    Aqualung Routinier

    Dabei seit:
    12.02.2008
    Beiträge:
    404
    Zustimmungen:
    0
    Nein an diesen Ordnern kann das IMHO nicht liegen. Hast Du mehr als eine perl-version installiert?

    poste mal

    Code:
    rpm -qa | grep perl
     
  6. float

    float Grünschnabel

    Dabei seit:
    21.02.2008
    Beiträge:
    4
    Zustimmungen:
    0
    Hier:

     
  7. #6 Aqualung, 21.02.2008
    Aqualung

    Aqualung Routinier

    Dabei seit:
    12.02.2008
    Beiträge:
    404
    Zustimmungen:
    0
    Na, da machen wir erst mal ein

    Code:
    rpm --rebuildb
    dann läuft das hoffentlich ohne Fehler durch.

    Gruß Aqualung
     
  8. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  9. float

    float Grünschnabel

    Dabei seit:
    21.02.2008
    Beiträge:
    4
    Zustimmungen:
    0
    Code:
     rpm --rebuildb
    --rebuildb: unknown option
    
    kennt er wohl nicht?

    Ich hab mal noch ein d zu rebuilddb hinzugefügt :)

     
  10. #8 Aqualung, 21.02.2008
    Aqualung

    Aqualung Routinier

    Dabei seit:
    12.02.2008
    Beiträge:
    404
    Zustimmungen:
    0
Thema:

installation von Net::SSLeay

Die Seite wird geladen...

installation von Net::SSLeay - Ähnliche Themen

  1. Problem bei der installation einer Sun Netzwerkkarte

    Problem bei der installation einer Sun Netzwerkkarte: Guten Morgen zusammen, beim installieren einer zusätzlichen Netzwerkkarte habe ich ein Problem. Die Karte wird nicht automatisch installiert. Es...
  2. "Ein Teil der Installation ist fehlgeschlagen. " bei Debian7 Installation

    "Ein Teil der Installation ist fehlgeschlagen. " bei Debian7 Installation: Hallo zusammen Egal ob ich Debian 7 auf Sparc oder x86 installiere, es komme immer eine Fehlermeldung: "Ein Teil der Installation ist...
  3. Installation, aber wo hin mit dem WLAN Passwort?

    Installation, aber wo hin mit dem WLAN Passwort?: Hallo, ich hab nicht gewußt wohin mit dem Wlan-Passwort (WPA2). Dadurch habe ich MidnightBSD gefunden und da installier ich was, aber es ist...
  4. FFMPEG Installation

    FFMPEG Installation: Hallo, ich bin neu hier und absoluter Linux Beginner. Ich habe einen Root Server in Betrieb der bei 1und1 gehostet wird. Ich muss für meine...
  5. Artikel: LibreOffice 5.0: Installation und kleiner Überblick

    Artikel: LibreOffice 5.0: Installation und kleiner Überblick: Es hat eine Weile gedauert, bis LibreOffice 5.0 schließlich in der finalen Version erschienen ist. Wir stellen Ihnen die neueste Version und auch...