der neueste X.org

Diskutiere der neueste X.org im Grafik / Video Forum im Bereich Hardware; Also ich weiss nich so genau, wie ich es richtig sagen soll, deswegen versuch ich es mal und entschuldige mich für jede Unverständlichkeit....

  1. #1 Onkel Jürgen, 03.02.2009
    Onkel Jürgen

    Onkel Jürgen Doppel-As

    Dabei seit:
    27.11.2007
    Beiträge:
    114
    Zustimmungen:
    0
    Also ich weiss nich so genau, wie ich es richtig sagen soll, deswegen versuch ich es mal und entschuldige mich für jede Unverständlichkeit.

    Also ich habe Ubuntu Intrepid Ibex (8.10) und ich meine mal irgendwann im Internet aufgeschnappt zu haben, dass der neue Xserver mittlerweile ohne /etc/X11/xorg.conf läuft, sondern nur über HAL.

    Wenn ich aber jetzt irgendwelche Einstellungen bezüglich Grafik und Maus und das ganze andere Zeugs machen will, wie geht das denn jetzt, wenn die xorg.conf nicht mehr ausgelesen wird??
    Oder wird sie doch noch ausgelesen oder muss ich irgendwwo festlegen, dass sie noch gelesen wird??
    Wenn das jetzt vermeindlich einfach für alle ist, tut es mir leid es gefragt zu haben, aber ich habe so kleine "Google Defizite", meistens finde ich nicht die richtigen Schlagwörter, die ich eingeben muss. Also auch für jegliche Art von google Verweisen bin ich dankbar.

    Also grüße
     
  2. Anzeige

    Anzeige

    Wenn du mehr über Linux erfahren möchtest, dann solltest du dir mal folgende Shellkommandos anschauen.


    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. daboss

    daboss Kaiser

    Dabei seit:
    05.01.2007
    Beiträge:
    1.297
    Zustimmungen:
    0
    Also "hier" (auch 8.10) wird die xorg.conf sehr wohl noch gelesen und beachtet...
     
  4. #3 Onkel Jürgen, 03.02.2009
    Onkel Jürgen

    Onkel Jürgen Doppel-As

    Dabei seit:
    27.11.2007
    Beiträge:
    114
    Zustimmungen:
    0
    mmhhh okay, gut zu wissen.

    Ich spiele jetzt schon seit ein paar Tagen mit den Einstellungen für meine Nvidia Grafikkarte, und irgendwie hab ich das Gefühl, dass die Veränderungen nix bringen.

    Naja gut, dann ist das wohl so. Danke
     
  5. #4 tuxlover, 03.02.2009
    tuxlover

    tuxlover Der den Tux knuddelt

    Dabei seit:
    26.10.2005
    Beiträge:
    2.106
    Zustimmungen:
    0
    onkel jürgen: das hat zwar nicht mehr mit dem topic zu tun aber hast du schonmal mit:

    Code:
    nvidia-xconfig
    
    probiert.
     
  6. daboss

    daboss Kaiser

    Dabei seit:
    05.01.2007
    Beiträge:
    1.297
    Zustimmungen:
    0
    NVidia liefert doch sogar ne gui mit, um Monitore ein zu stellen. (Das wäre afair aber nvidia-settings. Bin grad nicht zu Hause und kanns net nachschauen. Ich verwechsel die beiden gern :) ). Wenn du das mit root-Rechten startest, kannst du danach die Änderungen sogar in die xorg.conf schreiben lassen. Hat hier wunderbar (für einen Schirm und TwinView mit jeweils nem unterschiedlich großen Zusatzschirm) funktioniert...

    Oder ist dein Problem eher, das der Treiber selbst nicht greift (funktioniert/benutzt wird)?
     
  7. #6 tuxlover, 03.02.2009
    tuxlover

    tuxlover Der den Tux knuddelt

    Dabei seit:
    26.10.2005
    Beiträge:
    2.106
    Zustimmungen:
    0
    daboss: die gui funktioniert aber nur, wenn der treiber richtig installiert ist und die configs stimmen.
     
  8. #7 gropiuskalle, 03.02.2009
    Zuletzt bearbeitet: 03.02.2009
    gropiuskalle

    gropiuskalle terra incognita

    Dabei seit:
    01.07.2006
    Beiträge:
    4.857
    Zustimmungen:
    1
    Korrekt!

    Dennoch kann es sinnvoll sein, das Ding als user zu starten. Bestimmte Einstellungen (Kontrast, Digital Vibrance, Gamma etc.) werden dann userspezifisch nach ~/.nvidia-settings-rc geschrieben.

    Übrigens sind nicht alle Treiberoptionen über die GUI erreichbar. 'nvidia-xconfig' bietet noch wesentlich mehr Möglichkeiten.
     
  9. iway

    iway Mitglied

    Dabei seit:
    12.10.2006
    Beiträge:
    43
    Zustimmungen:
    0
    Hi Onkel Jürgen!
    Schau mal hier vorbei!
    Ist zwar Archlinux aber da steht auch drin wie du statt HAL die xorg.conf nehmen kannst und vill sind da ja noch ein zwei andere Dinge die dich interessieren!

    http://wiki.archlinux.de/title/Xorg

    Einfach mal das pacman -S durch aptitude install etc. ersetzten solltest du da was nach machen wollen :D

    Gruß
    Iway
     
  10. nighT

    nighT Gast

    Wie schon gesagt wurde wird die xorg.conf sehr wohl gelesen.
    Du kannt den X.org mit folgendem Eintrag dazu zwingen, alle Einträge aus der xorg.conf zu verwenden, denn sonst nimmt er nur Teile.
    Link: http://wiki.ubuntuusers.de/XServer
     
  11. #10 Onkel Jürgen, 03.02.2009
    Onkel Jürgen

    Onkel Jürgen Doppel-As

    Dabei seit:
    27.11.2007
    Beiträge:
    114
    Zustimmungen:
    0
    okay danke danke, das schau ich mir mal alles sehr intensiv an.

    Mein Problem ist einfach nur, dass die Nvidia Karte nicht flüssig läuft (also es ruckelt ständig und so ein Zeugs, was mich ziemlich nervt) und ich deshalb die ganze Nvidia Doku unter /usr/share/doc gelesen habe und von dort auch einige Optionen durchprobiert habe. Ich hab allerdings das Gefühl, dass diese Optionen nicht wirklich einen Effekt zeigen. Und HAL komplett ausschalten wollte ich eben nicht.

    Also danke erstmal, ich werde mir mal die Seiten zu Gemüte führen.
     
  12. #11 gropiuskalle, 03.02.2009
    gropiuskalle

    gropiuskalle terra incognita

    Dabei seit:
    01.07.2006
    Beiträge:
    4.857
    Zustimmungen:
    1
    Lies noch mal den von nighT zitierten Beitrag; HAL wird trotz der genannten Option doch weiterhin verwendet, nur steuert es nicht mehr X.
     
  13. doc

    doc Kaffeetrinker

    Dabei seit:
    26.08.2006
    Beiträge:
    586
    Zustimmungen:
    0
    was für eine nvidia ist es denn ?

    für die 8er/9er serie sind die treiber von nvidia nämlich noch nicht so toll, und ich hatte mit ner 8er unter ubuntu intrepid heftige probleme mit 2d ... 3d lief allerdings anstandslos.
     
  14. #13 tuxlover, 03.02.2009
    tuxlover

    tuxlover Der den Tux knuddelt

    Dabei seit:
    26.10.2005
    Beiträge:
    2.106
    Zustimmungen:
    0
    hunsinn:

    die 8er serie funzt hier bei mir ohne probleme: nvidia 8400 gs. allerdings habe ich die treiber von der nvidia-website und opensuse.
     
  15. #14 Onkel Jürgen, 03.02.2009
    Onkel Jürgen

    Onkel Jürgen Doppel-As

    Dabei seit:
    27.11.2007
    Beiträge:
    114
    Zustimmungen:
    0
    meine Graka is ne Nvidia Quadro NVS 140m in einem Lenovo Thinkpad R61 (Intel Chipsatz).
    Das sind auch keine krassen Störungen, aber es hängt manchmal einfach ganz kurz (also weniger als ne Sekunde).
    Man merkt es beim Filme schauen oder Scrollen egal in was, ob Browser oder zum Beispiel langen Texten im Terminal. Es ist wie ein kurzes Hängen, ganz schnell auch wieder vorbei, aber es ist halt so häufig, dass es mit der Zeit echt extrem nervt und voll unschön zum arbeiten ist. Und ich finde einfach keine Lösung.
    Ich bastel bestimmt schon seit 4 Tagen, mit immer wieder unterschiedlichen Einstellungen, alle möglichen Config Programme von Nvidia durch probiert, aber nix hilft.
    Unzählige Foren hab ich auch schon durchforstet, aber bis jetzt konnte ich auch noch kein Problem finden, dass konkret meinem entsprach.

    Also wenn noch jemand Rat weiß, wär ich sehr dankbar.
     
  16. nighT

    nighT Gast

    Schreib doch am besten einfach mal deine xorg.conf rein. Eventuell liegt ja der Hund da begraben.
     
  17. #16 Onkel Jürgen, 03.02.2009
    Onkel Jürgen

    Onkel Jürgen Doppel-As

    Dabei seit:
    27.11.2007
    Beiträge:
    114
    Zustimmungen:
    0
    also hier mal meine aktuelle xorg.conf, ohne jegliche Verbesserung
     

    Anhänge:

  18. nighT

    nighT Gast

    Als erstes Fällt mir auf, dass das "dri" Modul fehlt:

    und dann diese Zeile:
    Code:
    Screen      0  "Screen0" 0 0
    in der Sektion ServerLayout.
    Diese wird zwar weniger mit den Rucklern zu run haben, aber trotzdem würde ich diese anpassen (Wenn sie falsch ist!).
    Laut ubuntuusers.de sollte diese so aussehen:
    Code:
    Screen          "Screen0"
     
  19. #18 doc, 04.02.2009
    Zuletzt bearbeitet: 04.02.2009
    doc

    doc Kaffeetrinker

    Dabei seit:
    26.08.2006
    Beiträge:
    586
    Zustimmungen:
    0
    ist aber nun mal fakt das nividia probleme mit den 8xxx+ treibern für linux hat. das das bei dir "anscheinend" funktioniert heisst gar nix. bei einigen treiberversionen gibt es weniger probleme, und ebenso bei einigen karten.


    die section module ist eigentlich überflüssig somit auch das dri modul, die werden automatisch geladen. und dri is eh nur für 3d wichtig.

    das mit dem screen sollte beides gehen.

    @onkel jürgen

    probier mal:

    Option "PixmapCacheSize" "200000"

    und dann nach dem starten des xservers in die konsole eintippen:

    nvidia-settings -a InitialPixmapPlacement=2 -a GlyphCache=1

    das soll bei 8xxx+ karten ab den 177er treibern die 2d performance erhöhen, weiss nicht ob das auch noch für den 180 gillt und was fürn treiber du hast und ob deine überhaupt ne 8er karte ist ( ich denke aber ja ).

    edit: filme ruckeln bei mir im mplayer wenn ich das xv plugin nutze ... mit vdpau oder opengl ist es flüssig
     
  20. #19 Onkel Jürgen, 04.02.2009
    Zuletzt bearbeitet: 04.02.2009
    Onkel Jürgen

    Onkel Jürgen Doppel-As

    Dabei seit:
    27.11.2007
    Beiträge:
    114
    Zustimmungen:
    0
    in der Nvidia Dokumentation steht auch drin:
    Und ich benutze den 177.82 Treiber, der direkt von Ubuntu zur Verfügung gestellt wurde.

    So ich hab jetzt mal alles, was von Nvidia war runter geschmissen, neugestartet und dann den Beta Treiber von Ubuntu (180er Version) installiert.
    Und siehe da, es läuft wieder alles wunderbar. Ich danke euch vielmals für euer bemühen.
    Es sind halt Computer ;-), manchmal ist es schwer dahinter zu kommen, was sie tun und manchmal findet man einfach einen anderen Weg.

    Also lasst es euch gut gehen
     
Thema:

der neueste X.org

Die Seite wird geladen...

der neueste X.org - Ähnliche Themen

  1. Das neueste Kriegsschiff der US-Navy läuft unter Linux

    Das neueste Kriegsschiff der US-Navy läuft unter Linux: Die USS Zumwalt, die gerade in den Docks unter Aufsicht des Rüstungskonzerns Raytheon gebaut wird, verlässt sich bei der Datenverarbeitung völlig...
  2. Hilfe bei Xorg.confi und modprobe

    Hilfe bei Xorg.confi und modprobe: Hi ! Ich hatte mir vor einiger Zeit eine Roccat kone pure geholt (gamer Maus). Als ich versucht habe die Treiber zu installieren lief irgendwas...
  3. Angepasste Minimal-GUI xserver-xorg fvwm2

    Angepasste Minimal-GUI xserver-xorg fvwm2: Moin, ich habe bisher tiefgreifende Erfahrung auf der Kommandozeile, bin aber ein Dummchen für die Linux GUI, es gab einen anderen Thread,...
  4. UseFBDev-parameter bei der xorg.conf

    UseFBDev-parameter bei der xorg.conf: hallo zusammen ich frage mich gerade, was der parameter "UseFBDev" genau bedeutet? tönt irgendwie selbsterklärend, ist es aber scheinbar nicht......
  5. wie definiert man die primäre grafikkarte in xorg.conf

    wie definiert man die primäre grafikkarte in xorg.conf: hallo zusammmen weiss jemand, wie man die primäre grafikkarte in xorg.conf umstellt, z.b. wenn diese nicht die karte ist ab der der rechner...
  1. Diese Seite verwendet Cookies um Inhalte zu personalisieren. Außerdem werden auch Cookies von Diensten Dritter gesetzt. Mit dem weiteren Aufenthalt akzeptierst du diesen Einsatz von Cookies.
    Information ausblenden