Debian-Pakete aus Unstable in Stable verwenden

stargate

systemengineer[MOD]
Beiträge
845
igentlich wollte der Autor nur ein Dokument über IPv6 lesen... doch daraus erwuchs die Notwendigkeit, LxX zu aktualisieren. Debian Unstable hatte das benötigte Paket, doch der Weg zu dem neuen LyX und wieder zurück erwies sich als steinig.

Von Torsten Scheck

Heute war mal wieder ein fröhlicher Experimentier-Tag, dessen Ergebnis ich euch nicht vorenthalten möchte. Also, alles begann mit entspanntem Slashdot-Lesen, bei dem ich auf einen IPv6-Ideen-Wettbewerb aufmerksam wurde. IPv6? Hm, muss ich mal schauen, ob da - abgesehen vom größeren Adressraum - noch mehr dran war. Aha, klar war da mehr dran! Durch das Wegfallen von NAT-Krücken kommen endlich die ursprünglich vorgesehenen Punkt-zu-Punkt-Verbindungen bis zum Enduser wieder zum Tragen. Mein Traum von Instant Messaging per Consumergerät wäre dann greifbar nahe. Muss mich unbedingt mal ein bisschen einlesen! Also lade ich mir eine Übersicht "Understanding IPv6" als PDF runter und werde auch bei der Suche nach tiefergehenden Infos fündig: die Linux IPv6 HOWTO sollte alle meine Fragen beantworten.

Die HOWTO ist nur als Online-Version und im LyX-Quellformat verfügbar. Ich möchte jedoch eine Textdatei zum Durchsuchen und eine PostScript-Datei fürs Auge. Was soll's, denk' ich, ich habe ja Debian und damit auch apt, das geniale Paketverwaltungssystem. Ein schnell getipptes

apt-get install lyx

bringt mir auch ruckzuck die benötigte Anwendung aufs System. Ich öffne die Datei Linux IPv6-HOWTO.lyx und was passiert? LyX weist mich darauf hin, dass die Datei mit einem neueren LyX (1.2) als meines (1.1.6fix4-2; Debian testing) erstellt wurde und dass es Probleme geben könnte. Und tatsächlich wurde die neue SGML-DocBook_book-Klasse für die HOWTO benutzt (wohl um den Vorgaben des Linux Documentation Projects zu genügen), die erst in einer neueren LyX-Version vorhanden ist. Natürlich kann ich den Inhalt auch so lesen, aber dieses DocBook-mit-LyX-Gefummle und die Aussicht auf ein hübsches, eigenhändig exportiertes PostScript reizt mich dann doch.

Debian-unstable bietet auch genau das, was ich benötige: lyx 1.2.2-1. Uiuiui, mein schönes Debian-testing soll ich jetzt mit unstable verseuchen? Ein kurzer Blick in die Apt-HOWTO... jepp, scheint ja alles kein Problem zu sein:

Mehr Lesen
 

Ähnliche Themen

Debian-Server, neu installiert = keine Grafiken mehr

Neueste Themen

Oben