CentOS 6.4 kein schreibrecht auf gemountete ext4 HDD

W

werkzeugmacher

Grünschnabel
Hallo Zusammen,

ich bin neu hier und hab gleich meine erste Frage.

Bisher habe ich mit Debian, Ubuntu, Suse und Slackware Erfahrung und hab diese auch täglich im Einsatz.

CentOS habe ich erst seit kurzem installiert und habe nun ein Problem mit Rechten.


Ich habe Apache installiert und ein PHP Projekt aufgesetzt, welches auch soweit wunderbar funktioniert.
Der Apache wird mit einem eigenen Benutzer ausgeführt.

Über den Apache werden Dateien in ein anderes Verzeichnis (nicht webroot) abgelegt.
Dies funktioniert auch sehr gut. Das Verzeichnis gehört dem Aapache und seiner Gruppe.

Nun möchte ich das genau auf diesen Ordner eine zweite Festplatte gemountet wird, dies hat den Vorteil
das bei zuviel Daten das System nicht in Mitleidenschaft gezogen wird.
Webanwendung funzt dann zwar nicht mehr, aber das System bleibt in Takt.
Die Festplatte wird mit defaults,acl,user_xattr gemountet

Die zweite Festplatte ist wie die Root-HDD ext4 und nach dem mounten hat laut "ls -al" das Verzeichnis
die selben Rechte wie vor dem mounten.
Ich hab sogar per setfacl dem apache explizit nochmal zugriff gegeben.
auch nach einem chmod 777 konnte apache nicht dort schreiben.

Aber der Apache kann nicht in diesen Ordner schreiben. Woran kann dies liegen ?
Evtl. Selinux problem ? Virtualisierungsproblem ?

sobald ich es wieder unmounte funktioniert es wieder.

in /var/log/messages konnte ich auch nichts entdecken.
ext4 options(acl,user_xattr) wurde gemountet

Weitere Systemspezifische angaben gebe ich perne per pm weiter.

Gruß
Werkzeugmacher
 
G

Gast123

Ich tippe meiner Erfahrung nach auf ein SELinux-Problem.
Was sagen denn
Code:
/var/log/audit/audit.log
und
Code:
dmesg
nachdem apache auf die Platte zugreift?
Und probiere mal ein
Code:
restorecon -R /pfad/zum/ordner
auf den entsprechenden Mountpoint.

MfG

Schard
 
W

werkzeugmacher

Grünschnabel
Hi Schard,

mein Problem ist gelöst :)

Es war ein SELinux Problem, aber

restorecon -R /pfad/zum/ordner

hat es behoben.

Vielen Dank

Der Werkzeugmacher
 
A

ampromt

Hach ihr seit sooo schnell, wollte ich auch sagen... SELinux... joar... :oldman
 
Oben