backticks problem

Diskutiere backticks problem im Ruby, php, Perl, Python ... Forum im Bereich Programmieren unter Linux/Unix; hallo, ich will über eine html seite ein systembefehl in eine variable übernehmen, das geht auch prinzipiell. wenn ich beispielsweise den...

  1. Wolle

    Wolle Mitglied

    Dabei seit:
    17.07.2003
    Beiträge:
    49
    Zustimmungen:
    0
    hallo,

    ich will über eine html seite ein systembefehl in eine variable übernehmen, das geht auch prinzipiell.
    wenn ich beispielsweise den serverstatus abfrage, kann ich über backticks die antwort des system in einer variable speichern und gleich ausgeben. wenn ich aber das internet über den pppd dienst starten will ist der daemon so lange aktiv, wie das internet an ist und somit die systemantwort nicht beendet, wodurch ich die antwort des system ernst in der variable erhalte, wenn das internet wieder aus ist!

    $variable = `rcsquid status`;
    print $variable;

    das geht!
    aber

    $variable = `pppd call isdn/freenet`;
    print $variable;

    geht nicht, da die systemantwort erst beendet ist, wenn der daemon beendet ist und somit kann ich die einwahl nicht ausgeben.

    kann mir jemand sagen, wie ich das systemecho bekomme?

    desweiteren würde ich gerne wissen, wie ich die zeilenümbrüche übernehmen kann, wie wenn man beispielsweise rcnamed status aufrufe. in der konsole sind das mehrere zeilen, in meiner variable sind sie leider nur aneinandergereit.

    danke schon mal.

    in diesem wolle
     
  2. Steve

    Steve 13te

    Dabei seit:
    13.04.2002
    Beiträge:
    381
    Zustimmungen:
    0
    versuch mal über open die Pipe zu dem Programm zu öffnen.

    Steve
     
Thema:

backticks problem

Die Seite wird geladen...

backticks problem - Ähnliche Themen

  1. ip6tables Problem

    ip6tables Problem: Hallo zusammen, ich hab ein Problem kann aber keinen Fehler finden, äußert sich wie folgt, ich habe endlich für ein System in Netz eine IPv6...
  2. VDSL 50 FRITZBOX 7490 PROBLEM?

    VDSL 50 FRITZBOX 7490 PROBLEM?: Hallo ,ich besitze seit letzter Woche VDSL 50 also eine 50000er Leitung. Im Router wird mir allerdings unter "DSL Informationen" 109,34 Mbit/s...
  3. Problem mit SATA

    Problem mit SATA: Hallo zusammen Wo liegt hier das Problem? - Controller defekt? (LSI SAS3041X-L) - Festplatten defekt (Western Digital Green 1.5 TB)...
  4. Probleme mit WinSCP und Rechten

    Probleme mit WinSCP und Rechten: Hallo. Ich habe vor ein paar Tgen meinen ersten Ubuntu 16.04 vServer bei 1&1 bestellt, gemäß dem sicheren Umgang damit, habe ich erstmal den SSH...
  5. Bootproblem

    Bootproblem: Hallo Ein PC (i686 mit Debian unstable, nox) hat Bootprobleme (will heißen ist erfolgt keine Grafikausgabe. was ich bisher gemacht habe: HDD an...
  1. Diese Seite verwendet Cookies um Inhalte zu personalisieren. Außerdem werden auch Cookies von Diensten Dritter gesetzt. Mit dem weiteren Aufenthalt akzeptierst du diesen Einsatz von Cookies.
    Information ausblenden