auto mount unter freeBSD will nicht

Patrick K.

Patrick K.

lBSD_de Test User
hi all,

mein auto mount will nicht so recht...

hier meine konfig file /etc/amd.conf :
Code:
[ global ]
print_pid       = yes
restart_mounts  = yes
auto_dir        = /.amd_mnt
log_file        = /var/log/amd.log
log_options     = all
print_version   = yes
browsable_dirs  = yes
map_type        = file
search_path     = /etc:/usr/local/amd

[ /mnts ]
map_name        = amd.local

und hier meine /etc/amd.map :

Code:
# $FreeBSD: src/etc/amd.map,v 1.8 1999/09/13 17:09:07 peter Exp $
#
/defaults       type:=host;fs:=${autodir}/${rhost}/host;rhost:=${key}
*               opts:=rw,grpid,resvport,vers=2,proto=udp,nosuid,nodev
floppy          type:=pcfs;opts:=utimout=1;dev:=/dev/fd0
cdrom           type:=cdfs;opts:=utimout=1,ro,nosuid;dev:=/dev/acd0c;

oki nun sollte er ja floppy und cdrom nach /mnts mounten. aber wenn ich amd aufrufe gibt es keine fehlermeldung und ein wechsel nach /mnts ist nicht moeglich. denn ich nun cd /mnts eingebe haengt die console. strg+c hilft auch nicht.


ich habe schon die option

Code:
map_name        = amd.local

in

Code:
map_name        = /etc/amd.map

geaendert aber es hilft nichts, kann mir einer helfen ?

danke
 
S

saintjoe

Gast
Original geschrieben von Patrick K.
hi all,

mein auto mount will nicht so recht...

hier meine konfig file /etc/amd.conf :
Code:
[ global ]
print_pid       = yes
restart_mounts  = yes
auto_dir        = /.amd_mnt
log_file        = /var/log/amd.log
log_options     = all
print_version   = yes
browsable_dirs  = yes
map_type        = file
search_path     = /etc:/usr/local/amd

[ /mnts ]
map_name        = amd.local

und hier meine /etc/amd.map :

Code:
# $FreeBSD: src/etc/amd.map,v 1.8 1999/09/13 17:09:07 peter Exp $
#
/defaults       type:=host;fs:=${autodir}/${rhost}/host;rhost:=${key}
*               opts:=rw,grpid,resvport,vers=2,proto=udp,nosuid,nodev
floppy          type:=pcfs;opts:=utimout=1;dev:=/dev/fd0
cdrom           type:=cdfs;opts:=utimout=1,ro,nosuid;dev:=/dev/acd0c;

oki nun sollte er ja floppy und cdrom nach /mnts mounten. aber wenn ich amd aufrufe gibt es keine fehlermeldung und ein wechsel nach /mnts ist nicht moeglich. denn ich nun cd /mnts eingebe haengt die console. strg+c hilft auch nicht.


ich habe schon die option

Code:
map_name        = amd.local

in

Code:
map_name        = /etc/amd.map

geaendert aber es hilft nichts, kann mir einer helfen ?

danke

Schau mal hier rein:
http://sites.inka.de/daemonworld/Unix/bsd/entries/00000079.html
Evtl. hilft dir das ja.
 
bobojacobo

bobojacobo

Jungspund
Hi,

deine beiden configs sind so schon korrekt. Da du amd per hand gestartet hast, läuft denn auch ein portmapper? Ausserdem muss /.amd_mnt vorhanden sein und unter /mnt darf auf keinen Fall eines der Verzeichnisse existieren, die in amd.local stehen.
Wenn dann alles läuft, dann kann man amd automatisch starten, indem man in /etc/rc.conf folgendes einträgt:
Code:
# amd requirements
rpcbind_enable="YES"              # start portmapper
amd_enable="YES"
amd_flags=""
Vor allem den flags-Eintrag sollte man nicht vergessen!
 

Ähnliche Themen

Windows clients können nicht mehr auf lange laufendes System zugreifen

Falsche Rechte gesetzt beim Anlegen von Ordnern via Samba-Client

dovecot und postfix Konfiguration Problem

Debian squeeze, Webmin, Samba Freigaben

Kein standardmässiger Mountpoint für ĆD/DVD Laufwerke unter Ubuntu 10.10 HILFE!

Oben