vixie-cron startet nicht

Dieses Thema im Forum "Gentoo" wurde erstellt von posiputt, 15.07.2007.

  1. #1 posiputt, 15.07.2007
    posiputt

    posiputt zwar!

    Dabei seit:
    10.12.2004
    Beiträge:
    321
    Zustimmungen:
    0
    Ort:
    hamburg
    beim booten meines frisch installierten gentoo (2007.0) startet vixie-cron nicht. es scheint mit den schreibrechten auf /var zu tun zu haben, und weiter oben in den boot messages steht auch
    Code:
    Skipping /var and /tmp initialization (ro root?)
    die schreibrechte auf /var und /tmp sehen aber so aus
    Code:
    drwxrwxrwt  2 root root 4.0K Jul 15 21:33 tmp
    drwxr-xr-x 12 root root 4.0K Jul 15 21:51 var
    leider habe ich googelnderweise nur ein eventuell hilfreiches ergebnis gefunden ... auf russisch.

    da ich des russischen nicht maechtig bin, bitte ich daher hier um hilfe :)
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 sym, 16.07.2007
    Zuletzt bearbeitet: 16.07.2007
    sym

    sym Funktionalist

    Dabei seit:
    30.10.2006
    Beiträge:
    43
    Zustimmungen:
    0
    Der entsprechende Codeblock in /sbin/runscript sieht so aus:
    Code:
    if ! touch -c /var/run 2> /dev/null ; then
    	ewarn "Skipping /var and /tmp initialization (ro root?)"
    	return 0
    fi
    D.h. er meint beim Booten keine Schreibrechte auf /var/run/ zu haben.

    Wenn dem so ist sollte bei dir eigentlich einiges nicht funktionieren... :think:

    EDIT:
    Was mir gerade noch eingefallen ist, dein root-fs ist nicht zufällig read-only gemounted? ;)
     
  4. #3 posiputt, 16.07.2007
    posiputt

    posiputt zwar!

    Dabei seit:
    10.12.2004
    Beiträge:
    321
    Zustimmungen:
    0
    Ort:
    hamburg
    ich konnte das problem jetzt fuers erste beheben. was ich vielleicht noch haette erwaehnen sollen ist, dass /var auf einer eigenen partition (hda7) liegen sollte. jetzt, wo /var ein ganz normales verzeichnis im root-fs ist, taucht die warnung nicht mehr auf, vixie-cron startet und alles ist bombe.

    trotzdem doof. also hda7 war nicht ro gemountet und auch das root-fs nicht. beim googlen fand ich uebrigens auch diesen codeblock, aber dass das heiszt, dass es angeblich keine schreibrechte auf /var gibt, war mir auch so klar.
     
  5. sym

    sym Funktionalist

    Dabei seit:
    30.10.2006
    Beiträge:
    43
    Zustimmungen:
    0
    Ah, das hilft schon weiter :)

    runscript wird beim booten sehr früh ausgeführt, d.h. vor dem mounten von Partitionen. Zu dem Zeitpunkt ist dein hda7 noch gar nicht gemountet und /var/run existiert nicht.
     
  6. #5 posiputt, 16.07.2007
    posiputt

    posiputt zwar!

    Dabei seit:
    10.12.2004
    Beiträge:
    321
    Zustimmungen:
    0
    Ort:
    hamburg
    ah gut aber wie macht man das denn dann, dass /var auf einer eigenen partition liegt, ohne solche probleme zu machen?
     
  7. sym

    sym Funktionalist

    Dabei seit:
    30.10.2006
    Beiträge:
    43
    Zustimmungen:
    0
    Ich hab grad nochmal etwas genauer nachgeschaut, vergiss den Unsinn den ich da oben geschrieben habe :)

    Der betreffende Codeblock steht in /etc/init.d/bootmisc, das Script dürfte eigentlich erst nach /etc/init.d/localmount ausgeführt werden.
    Ich frag jetzt mal ganz banal, steht hda7 in deiner fstab? :)
     
  8. #7 posiputt, 16.07.2007
    posiputt

    posiputt zwar!

    Dabei seit:
    10.12.2004
    Beiträge:
    321
    Zustimmungen:
    0
    Ort:
    hamburg
    ja das steht da :)
     
  9. sym

    sym Funktionalist

    Dabei seit:
    30.10.2006
    Beiträge:
    43
    Zustimmungen:
    0
    Und die Verzeichnisstruktur von /var existiert auf der Partition auch? Das neuere bootmisc Script versucht dort /var/run/.keep anzulegen.
     
  10. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  11. #9 posiputt, 16.07.2007
    posiputt

    posiputt zwar!

    Dabei seit:
    10.12.2004
    Beiträge:
    321
    Zustimmungen:
    0
    Ort:
    hamburg
    jap. also nein, existierte, ich hab die partition mittlerweile abgeschossen. interessanterweise scheint das in diesem fruehen stadium der postinstallation noch nix auszumachen. die verzeichnisstruktur scheint automatisch neu erstellt zu werden (ich hab sie naemlich nicht gerettet vor dem loeschen der partition, oha)
     
  12. nikaya

    nikaya Guest

    Vielleicht hat es hiermit was zu tun:
    Quelle:
    http://www.gentoo.org/doc/de/handbook/handbook-x86.xml?part=1&chap=4#doc_chap5
     
Thema:

vixie-cron startet nicht

Die Seite wird geladen...

vixie-cron startet nicht - Ähnliche Themen

  1. LEDE: Fork von OpenWRT gestartet

    LEDE: Fork von OpenWRT gestartet: Unter dem Namen LEDE haben einzelne OpenWRT-Entwickler ein neues Projekt gestartet. Ziel des neuen Projektes ist es, eine gemeinschaftszentrierte...
  2. X startet nichtmehr

    X startet nichtmehr: Hallo, ich habe versucht CUDA und OPENCL mit meiner Graka zum laufen zu bekommen ... nun hängt er aber schon beim Booten bei "started Update UTMP...
  3. Humble Devolver Bundle gestartet

    Humble Devolver Bundle gestartet: Mit dem »Humble Devolver Bundle« sind nun ein weiteres Mal zahlreiche Independent-Spiele zu einem selbst wählbaren Preis für Linux, Mac OS X und...
  4. Linux Foundation startet Projekt für zivile Infrastruktur

    Linux Foundation startet Projekt für zivile Infrastruktur: Strom, Öl, Gas, Wasser, Gesundheitswesen, Kommunikationsverbindungen, Verkehrswege und anderes mehr benötigen immer komplexere...
  5. Jolla startet Entschädigung für die Unterstützer des Jolla-Tablet

    Jolla startet Entschädigung für die Unterstützer des Jolla-Tablet: Der finnische Softwarehersteller Jolla hat die Gemeinschaft informiert, dass das Unternehmen mit der Entschädigung der Unterstützer des...