Tastatur-Probleme bei lilo-Menüauswahl

Dieses Thema im Forum "Installation & Basiskonfiguration" wurde erstellt von Staffeldt, 16.08.2007.

  1. #1 Staffeldt, 16.08.2007
    Staffeldt

    Staffeldt Grünschnabel

    Dabei seit:
    16.08.2007
    Beiträge:
    3
    Zustimmungen:
    0
    Hallo allerseits,

    Es wird ein Linux-Kernel 2.4.18 auf einem x86-kompatiblen Industrie-PC benutzt.

    Ich halte den lilo Version 22.8 im Anlauf an und bekomme den prompt: "boot:". Soweit noch alles in Ordnung
    Jetzt möchte ich zum Beispiel eingeben:

    linux root=/dev/hda1.

    Die Ausgabe über den Bildschirm lautet bei "linux" zum Beispiel "ninwz".
    Die Eingabe von "qwertz" bringt mir auf dem Bildschirm "swgrv{".
    Die Ähnlichkeit ist also nicht so groß.
    Ich habe schon den Parameter "keytable" in der lilo.conf benutzt, was mir auch nicht weiterhilft.

    Vielleicht hat hier noch jemand eine Idee zu diesem Thema.
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. buli

    buli Debianator

    Dabei seit:
    16.09.2006
    Beiträge:
    789
    Zustimmungen:
    0
    Ort:
    Essen/Ruhrgebiet
    Und welche Distri?
    Oder selbst gebaut?

    (bei 2.4.x denke ich mal letzteres ;) )
     
  4. #3 Staffeldt, 16.08.2007
    Staffeldt

    Staffeldt Grünschnabel

    Dabei seit:
    16.08.2007
    Beiträge:
    3
    Zustimmungen:
    0
    Der Kernel wurde selbst zusammengebaut.
     
  5. buli

    buli Debianator

    Dabei seit:
    16.09.2006
    Beiträge:
    789
    Zustimmungen:
    0
    Ort:
    Essen/Ruhrgebiet
    Ja, aber nicht die komplette Distri, oder?

    Code:
    $EDITOR /etc/locale.gen 
    locale-gen 
    Ist zumindest bei Debian so.
    Ein pendant sollte sich mit
    Code:
    locale<TAB><TAB> 
    finden lassen.

    Oder du konfigurierst den Xserver komplett neu.

    Code:
    man xorg.conf
     
  6. #5 Staffeldt, 16.08.2007
    Staffeldt

    Staffeldt Grünschnabel

    Dabei seit:
    16.08.2007
    Beiträge:
    3
    Zustimmungen:
    0
    So etwas edles wie Xserver habe ich überhaupt nicht. Es ist eine Konfiguration auf einer CompactFlash mit minimalem Verbrauch an Ressource von Speicher.

    Nach dem der Kernel angelaufen ist kann die Tastatur ja auch ganz normal bedient werden. Der Knackpunkt ist nur, dass ich im Anlauf, also noch im lilo, die Tastatur nicht sinnvoll bedienen kann. An dieser Stelle ist ja noch nicht viel vom Kernel usw. angelaufen.

    Ich dachte, dass lilo höchstens mit der angegebenen keytable arbeitet? Oder greift lilo schon auf irgendetwas aus dem Kernel zurück? Dem würde vielleicht jedoch widersprechen, dass sich die Tastatur bei angelaufenem Kernel problemlos bedienen läßt.
    Woher bekommt denn Lilo die Weisheit über die Tastaturbelegung? Ich habe auch schon eine andere Tastatur über USB angeschlossen und habe den gleichen Effekt.
    :(
     
  7. buli

    buli Debianator

    Dabei seit:
    16.09.2006
    Beiträge:
    789
    Zustimmungen:
    0
    Ort:
    Essen/Ruhrgebiet
    LILO kenn ich leider überhaupt nicht. Vielleicht installierst du dir lieber GRUB?
    Ich weiss aber auch nicht, in wie weit ein 2.4.x Kernel damit klarkommt.
    Kompilier dir doch nen 2.6`er und mach in GRUB.

    Da hätte ich auch gerne gewusst ;)
     
  8. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
Thema:

Tastatur-Probleme bei lilo-Menüauswahl