Systemschriften verrück und leicht unscharf

Dieses Thema im Forum "SuSE / OpenSuSE" wurde erstellt von Zico, 21.08.2005.

  1. #1 Zico, 21.08.2005
    Zuletzt bearbeitet: 30.01.2010
    Zico

    Zico Lebende Foren Legende

    Dabei seit:
    16.04.2004
    Beiträge:
    1.559
    Zustimmungen:
    0
    Hi

    Hab grad eben SuSE 9.3 auf mein Laptop gebügelt, Bildschirm soweit korrekt konfiguriert.
    Nun aber seh ich in den Systemschriften in X ... allgemein X, nicht KDE spezifisch, dass diese leicht verschwommen. Ich kanns mir auch einbilden, aber in Browsern wie Firefox und Mozilla sind die Schriften arg verrückt. Die Buchstaben sitzen fast direkt nebeneinander. Udn das obwohl ich auf dem Laptop im KDE Kontrollzentrum, so wie auch im Mozilla/Firefox exakt die selben Schriften und größen verwnde.

    Ich hab langsam keine Idee mehr woran das liegt.
    Der einzige Unterschied zwischen den beiden Systemen ist, dass der Laptop mit 1024x768 und die Workstation mit 1152x864... aber vorher hatte ich diese Probleme auf dem Laptop auch nicht.. daher muss ich bei der SuSE Konfiguration was falsch gemacht haben
    Siehe anhang....
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    Welchen Grafikktreiber verwendest im X ? NVidia/ATI Treiber installiert ?

    Alle YOU Updates gezogen ?
     
  4. #3 Zico, 21.08.2005
    Zuletzt bearbeitet: 21.08.2005
    Zico

    Zico Lebende Foren Legende

    Dabei seit:
    16.04.2004
    Beiträge:
    1.559
    Zustimmungen:
    0
    Also ich nutz den NVIDIA Treiber. Aber es war auch schon vor der Driverinstall so und meine Worksation verziehts auch nicht so derbe ohne das NVIDIA Modul. YOU is noch nicht gemacht. Wird aber in ein paar minuten gemacht.

    EDIT://
    Btw. soweit ich das sehe, wenn ich mit XMag die Schriften so vergleiche "scheint" es im KDE in ordnung zu sein. Den Unscharf effekt habe ich nun weg bekommen.
    Nur Mozilla/Firefox lediglich scheinen Probleme zu haben. Aber dort kann ich Schriften einstellen wie ich will.... bringt herzlich wenig...
     
  5. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    Naja, aber mit dem NVidia Treiber sollte das eventl. besser werden.

    Außerdem gibts in den YOU-Updates nen Update das auch helfen könnte ...
     
  6. Zico

    Zico Lebende Foren Legende

    Dabei seit:
    16.04.2004
    Beiträge:
    1.559
    Zustimmungen:
    0
    So, YOU is gemacht, hat aber auch nicht wirklich eine Veränderung gebracht.

    Das Problem habe ich nun eingegrenzt:
    Die einzigen Schriften die so zerhauen werden sind
    * Nimbus Sans
    und
    * FreeSans
    ab einer Schriftgröße von unter 11

    Dass das auf meiner Workstation nicht auftritt, ist mir auch klar, da ich dort diese Schriften garnicht installiert habe. Würde sie auch gerne auf dem Laptop deinstallieren. Leider scheint es bestandteil von X11 Paketen zu sein...
    Ansonsten würde mich sehr interessieren warum das auftritt und wie ich es unterbinden kann bzw X sagen, dass es diese Schriften nicht benutzen soll (leider liegen im selben Verzeichnis auch noch einige gute Schriften)
     
  7. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    Stell dir doch andere Schriftarten ein?
    Ich meine mußt ja nicht gleich löschen, aber ignorieren sollte ausreichen *g*
     
  8. Zico

    Zico Lebende Foren Legende

    Dabei seit:
    16.04.2004
    Beiträge:
    1.559
    Zustimmungen:
    0
    Ja, im KDE hab ich das mittlerweile so gemacht. Ich verwende BITSTREAM Schriftarten. Funktioniert wundebar. Konnte ich nun auch im Superkaramba so lösen. Mozilla/Firefox halten sich leider lediglich dran, wenn ich "Allow Sites to use other Fonts" abklicke.
    Im Grunde macht mir das ja nix aus. Ich kann auch normal Schriftarten von 12 nutzen, nur bei 1024x768 aufm Notebook is dasn bissl groß. Daher.. mal sehen.
    Bleibts halt vorerst beim Workaround :D
     
  9. #8 Zico, 31.08.2005
    Zuletzt bearbeitet: 31.08.2005
    Zico

    Zico Lebende Foren Legende

    Dabei seit:
    16.04.2004
    Beiträge:
    1.559
    Zustimmungen:
    0
    So hab das ganze jetz mal länger beobachtet.

    Es handelt sich hierbei um wirklich ZWEI komplett eigenständige Probleme.
    Die "krakelige" und verrutschte Schrift (siehe Screenshots) ist gelöst: Schriften Nimbus gelöscht.

    Das zweite Problem besteht jedoch noch:
    Es ist schwer zu erklären. Es sieht aus als sei die Schrift leicht verpixelt und dann mit Antialaaisung wieder ausgebessert. Ich versuche die Tage mal einen richtig guten Screenshot zu machen.

    Diesen Effekt beobachte ich lediglich NUR auf meinem Laptop auf dem TFT Bildschirm. Meine Worksation mit CRT Monitor, aber die Schriften im Grunde gleich sind hat dies nicht.

    Also vermute ich, dass SuSE (nicht KDE-spezifisch) leichte Probleme mit meinem TFT hat.
    Es ist ein 15 Zoll TFT und das is leider das einzige was im Handbuch darüber steht.... Keine Infos über Horizontale und Vertikale Refresh Rates, sowie keine Info zur Herz Zahl...

    Ich vermute das Problem dort, da die Systeme ansonsten die selbe Konfiguration haben.

    Andere Schriftarten helfen leider auch nicht, da sie das selbe Problem haben.. von Bitstream bis zu den SuSE Sans.... lediglich eine größere Schriftart machts ein wenig besser... aber 12 oder 14 (wo mans auch noch bissl sieht) is für nen Laptop zu groß...
     
  10. #9 illtiss, 01.09.2005
    illtiss

    illtiss Routinier

    Dabei seit:
    19.01.2005
    Beiträge:
    449
    Zustimmungen:
    0
    mmmmhh, das mit den Schriften ist seltsam, habe ich auch bei meinem TFT. Mit einer Röhre funktioniert alles super, aber mit dem Flatscreen stimmt das mit den Schriften auch nicht wirklich. Würde mich also auch mal interessieren warum das so ist.
     
  11. Zico

    Zico Lebende Foren Legende

    Dabei seit:
    16.04.2004
    Beiträge:
    1.559
    Zustimmungen:
    0
    Dieses Problem hatte ich noch in Slackware, jedoch wieder mal nicht bei SuSE...

    Das witzige is, dass ich denke, dass das "unscharf"-Problem bei Slackware auch nicht vorhanden war....
     
  12. #11 ChrisMD, 01.09.2005
    ChrisMD

    ChrisMD Haudegen

    Dabei seit:
    30.06.2005
    Beiträge:
    619
    Zustimmungen:
    0
    Man muss auf 96dpi umstellen sonst verschluckts Zeilen. Also nicht auf Systemvorgabe. Hat zumindest bei mir geholfen.
    Ich stells aber absichtlich auf 72. Dann is das Problem wieder da, aber die Schrift ist erträglich. Wie kann man denn die Schrift im Firefox so einstellen wie die für den GTK2 Theme festgelegte Schrift? Ich stell die absichtlich immer auf 8er Sans, denn 12 is viel zu groß. Hat nur leider keine Auswirkung auf den Fox.
     
  13. Zico

    Zico Lebende Foren Legende

    Dabei seit:
    16.04.2004
    Beiträge:
    1.559
    Zustimmungen:
    0
    Ich habe nun auch mal mit den DPI Werten rumexperimentiert. Stelle ich es auf 72 habe ich das Problem...
    Setze ich X auf 96DPI, so ist es weg. Verkleiner ich jedoch dann wieder die Schriften auf ca die selbe Größe wie aber mals bei 72, so besteht das Problem wieder.
    Viele meinen, es helfe, wenn man Antialaising der Schriften abstellt. Nur dann verpixelt es wirklich dermaßen...
    im KDE habe ich das Problem bereits gelöst, indem ich die schrift um einen Punkt höher gesetzt habe. Das sieht gut und schön aus. Leider krieg ich das im Firefox/Mozilla und anderen nicht-KDE anwendungen nicht gebacken...
     
  14. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  15. #13 ChrisMD, 02.09.2005
    ChrisMD

    ChrisMD Haudegen

    Dabei seit:
    30.06.2005
    Beiträge:
    619
    Zustimmungen:
    0
    Ich hab das Problem auch ohne AA Fonts. Dann vorallem bei Bildern.
    Nomma zu meiner Frage. Weiß niemand wie man die Firefox Fonts ändert? Also nich die im Browser selbst sondern die in den Menüs von Firefox *äh*.
     
  16. #14 Zico, 02.09.2005
    Zuletzt bearbeitet: 30.01.2010
    Zico

    Zico Lebende Foren Legende

    Dabei seit:
    16.04.2004
    Beiträge:
    1.559
    Zustimmungen:
    0
    Hier mal ein Shot von meinem Desktop.
    Man beachte Die Bookmaks im Mozilla - vor allem bei den Buchstaben a, o, m und dem www in der Webadresse erkennt man die Unschärfe gut.
    Die Auflösung wurde nicht verändert und exakt so sieht es bei mir aus... nicht, dass ihr meint, es läge an der Kompression.

    EDIT: // Ich nehme alles zurück.
    Ich hab mir das Bild hier (auf meinem CRT) nochmal angesehn und festgestellt, dass hier alles in Ordnung ist.
    Irgendwie hab ich dann nochmal an der "Sub-Pixel Hinting" Option im KDE Kontrollzentrum rumgestellt und mal ganz auf Nummer sicher gemacht und X komplett neugestartet. Kontrollzentrum verweist immer daruf, dass schon neu gestartete Anwendungen den Effekt haben sollen. War aber nicht der Fall und die Option hats dann auch gebracht.
     
Thema:

Systemschriften verrück und leicht unscharf

Die Seite wird geladen...

Systemschriften verrück und leicht unscharf - Ähnliche Themen

  1. Netzwerkkarte spielt verrückt

    Netzwerkkarte spielt verrückt: Moin, sorry erstmal für den "ausdruckstarken" Titel, aber mir fiel echt kein besserer ein ... Problem 1: Wenn ich Wixdos herunterfahre und...
  2. Sind wir nicht alle ein wenig verrückt?

    Sind wir nicht alle ein wenig verrückt?: Hallo Leute Ich wollte Mal fragen wieviele von euch als ersten und letzten Schritt des Tages, der Weg an den PC ist. Also morgens aufstehen,...
  3. Meine Distri spielt verrückt !

    Meine Distri spielt verrückt !: Hallo Ihr Wissenden ! Ich bin eine blutige Anfängerin in Punkto Linux und bitte desshalb hier um eure Hilfe. Ich habe eine Festplatte auf der...
  4. fglrx, ich werde verrückt

    fglrx, ich werde verrückt: Hallo, ich habe ein Problem, wo ich jetzt schon lange dran bin, ich habe mir eine Debian System installiert. Ich habe diese Netzwerk ISO benutz,...
  5. Ich werde noch verrückt mit meiner Netzwerkkarte VIA VT6105

    Ich werde noch verrückt mit meiner Netzwerkkarte VIA VT6105: Hallo, Ich wollte mit meinem zweiten Rechner (SuSE 10.0) ins Internet gehen. Da LAN am Modem schon belegt war, wollte ich USB nehmen, was nicht...