Susi und die nicht horizontal scrollende Maus

Dieses Thema im Forum "Eingabegeräte" wurde erstellt von layne, 01.08.2006.

  1. layne

    layne Grünschnabel

    Dabei seit:
    01.08.2006
    Beiträge:
    5
    Zustimmungen:
    0
    Liebe Mausbesitzer,

    ich weiß, ich bin bei weitem nicht der Erste, der Euch mit diesem Thema kommt. Doch leider konnte mir bislang kein entsprechender Beitrag wirklich weiterhelfen.
    Ich habe kürzlich eine Maus erstanden, die (zu meinem Unglück?) mal nicht von Microsoft oder Logitech ist. Die ?Firma? nennt sich 'Bazoo' und ist irgendein ?Tochterunternehmen? von Vivanco. Es handelt sich um eine optische USB-Maus, mit 6 Knöpfen und einem Rad, dass horizontal und vertikal scrollen können sollte.
    Ich kann machen, was ich will, das Ding scrollt einfach nicht nach links und rechts.

    Informationen:

    BS: Suse Linux 10.1
    Kernel: 2.6.16.13-4-smp
    Xorg: 6.9.0


    'cat /proc/bus/input/devices' liefert mir folgendes über die Maus:

    I: Bus=0003 Vendor=04b4 Product=6370 Version=0100
    N: Name="Dexin Corp. Optical Mouse "
    P: Phys=usb-0000:00:10.1-1/input0
    S: Sysfs=/class/input/input4
    H: Handlers=mouse0 event3
    B: EV=7
    B: KEY=1f0000 0 0 0 0 0 0 0 0
    B: REL=103


    Dann gibt es da ein kleines C-Skript, das ich auf einer Tutoriumsseite gefunden habe (http://www.linux-gamers.net/modules/wiwimod/index.php?page=HOWTO+Mouse+Buttons), auf der erklärt wird, wie man seine Maus erfolgreich mittels 'evdev' konfiguriert. Das Skript untersucht in irgendeiner Form das angegebene Eingabegerät und führt bei mir zu folgendem Ergebnis:

    Befehl: ./evdev-key-btn-test /dev/input/event3

    Ausgabe:
    Supported Keys:
    Key 0x110 (Left Button)
    Key 0x111 (Right Button)
    Key 0x112 (Middle Button)
    Key 0x113 (Side Button)
    Key 0x114 (Extra Button)
    Buttons/Keys: 5

    Supported Relative axes:
    Relative axis 0x00 (X Axis)
    Relative axis 0x01 (Y Axis)
    Relative axis 0x08 (Vertical Wheel)


    Mit 'evdev' ist das so eine Sache. Dazu verliere ich gleich noch ein Wort. Zuvor jedoch, um die Sache zu vervollständigen, noch die Ergebnisse von 'xev'.
    Die drei vorderen Knöpfe werden als 1, 2, 3 identifiziert. Das vertikale Scrollen entspricht 4 und 5. Versuche ich, nach links oder rechts zu scrollen, kommt keine Reaktion. Das gleiche betrifft den Knopf oben auf der Maus. Es bleiben die beiden Knöpfe an der Seite und die werden (ich find's unglaublich) als 8 und 9 identifiziert.
    Ich bin absolut ratlos.

    Zu 'evdev':
    Ich habe sowohl gelesen, dass bereits Xorg 6.9 mit dem Treiber ausgestattet sein soll, als auch, dass es erst in Version 7.0 integriert sein wird. Jedenfalls finden sich hier Dateien, die so heißen wie 'evdev_drv.so', 'evdev_drv.o' oder 'evdev.c'. Enthalten sein soll der Treiber in x11-input-evdev (bin mir nicht mehr ganz sicher). Das hab' ich nachinstalliert. Aber es hat nichts gebracht. Solange ich evdev als Protokoll für meine Maus angebe in der xorg.conf, bekomme ich in der Xorg.0.log die Meldung, dass das Protokoll unbekannt sei und der X-Server startet nicht, weil keine ordentlich definierte Maus vorhanden ist.

    Ich habe gelesen, dass die anderen Protokolle höchstens 7 Knöpfe (inkl. Rad?) unterstützen. Ist das so? Was kann ich denn da machen mit meinen als 8 und 9 identifizierten Knöpfen?
    Und wie ist das denn genau mit 'xev'? Kann ich davon ausgehen, dass ich die Knöpfe (bzw. das Kippen des Rades), die da nicht erkannt werden, auch niemals nutzen kann?

    Mein Mauseintrag in der xorg.conf:
    Section "InputDevice"
    Driver "mouse"
    Identifier "Mouse[1]"
    Option "ButtonNumber" "9" #eigentlich sind's 10
    Option "Buttons" "9" #eigentlich sind's 10
    Option "Device" "/dev/input/mice"
    Option "Name" "Dexin Corp. Optical Mouse"
    Option "Protocol" "explorerps/2"
    Option "Dev Phys" "usb-0000:00:10.1-1/input0
    Option "Vendor" "Sysp"
    Option "ZAxisMapping" "4 5 6 7"
    EndSection

    So sieht es im Moment aus und es funktionieren die fünf genannten Knöpfe und das Scrollen nach oben und unten. Ich hab' das Ding bereits in verschiedenen Variationen, teils mit Modifikationen in der Xmodmap, gestartet. Hat alles nix gebracht.


    Weiß vielleicht irgendwer, ob wenigstens theoretisch die Möglichkeit besteht, dass mir das Rad eines Tages in alle vier Richtungen scrollt?

    Vielen Dank für Eure Mühe!
    Gruß, Lars
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. hehejo

    hehejo blöder Purist

    Dabei seit:
    12.10.2003
    Beiträge:
    1.280
    Zustimmungen:
    0
    Ort:
    Stein (Mittelfranken)
    *push*

    Ich habe hier das gleiche Problem.
    Weiß inzwischen jemand mehr?
     
  4. worker

    worker König

    Dabei seit:
    29.03.2007
    Beiträge:
    848
    Zustimmungen:
    0
    Ja, Sie müssen erst den Nippel durch die Lasche zieh´n ... :D

    Schon mal versucht das "Ding" unter einer aktuellen Live-Vers. (z.B. Knoppix) zu bewegen ?
     
Thema:

Susi und die nicht horizontal scrollende Maus

Die Seite wird geladen...

Susi und die nicht horizontal scrollende Maus - Ähnliche Themen

  1. SUESSI-Portal - Die Süßigkeiten Community

    SUESSI-Portal - Die Süßigkeiten Community: Hallo Liebe Member.. Huh mein erster Beitrag und schon gleich Werbung..:D :D ..ich weiß das soll man nicht machen..aber ich will euch unbedingt...
  2. Ich bin ganz verliebt in Susi! :-)

    Ich bin ganz verliebt in Susi! :-): Weil: Es ist das einzige Linux, was ich ohne Probs installieren konnte und wo vor allem Internet gleich geht! :)) Jetzt hab ich aber ein...
  3. susi Office von Tecchannel

    susi Office von Tecchannel: Moin! Ich habe mir vor einiger Zeit mal diese schicke susi Zusammenstellung von Tecchannel zugelegt und bin was den Betrieb für/unter DSL angeht...
  4. Telnet Verbindung von W2K zu Susi 8.1 über ISDN

    Telnet Verbindung von W2K zu Susi 8.1 über ISDN: Moin! Ich müßte eine telnet Verbindung über Telefonleitung herstellen. Ich habe grob im Kopf, dass man unter W2K mit Hyperterminal was basteln...
  5. PATH wird nicht richtig durchsucht

    PATH wird nicht richtig durchsucht: Hi zusammen, ich nutze das Forum schon seit längerem , allerdings hat mir bis jetzt immer die Suchfunktion weitergeholfen. Bei meinem aktuellen...