SMB-Server nicht korrekt im Netz erreichbar.

Dieses Thema im Forum "Samba" wurde erstellt von noiz, 07.03.2008.

  1. noiz

    noiz Pinguin-Pfleger

    Dabei seit:
    27.02.2008
    Beiträge:
    7
    Zustimmungen:
    0
    Hallo!

    Folgende Situation:

    Auf einem Rootserver im Internet läuft eine Samba-Dienst. Dieser ist von den Clients aus nur über ein verschlüsseltes openVPN zu erreichen. (Siehe mein letzter Thread, Problem ist mitlerweile gelöst)

    Wenn ich nun auf einem der VPN-Clients (WinXP SP2) in der Netzwerkumgebung die Computer der Arbeitsgruppe anzeigen lasse habe ich alle VPN-Clients (Da dieses sich über das VPN broadcasten) sowie den SMB-Server.

    Der Sambaserver wird mit dem Hostname angezeigt, den ich in meiner smb.conf eingetragen habe, in Klammern dahiner erscheint jedoch der Unix-Hostname des Servers der in der /etc/hosts eingetragen ist.

    Hier meine smb.conf zur Begutachtung:

    Code:
    
    [global]
    
    # Allgemeine Einstellungen 
      workgroup = Arbeitsgruppe
      server string = Server 
      dns proxy = no
      wins support = no
    
    # Netzwerkeinstellungen (Nur an das VPN gebunden)
      interfaces = 10.0.0.1
      bind interfaces only = yes
      socket address = 10.0.0.1
    
    # Logging und Debugging
      log file = /var/log/samba/samba.log
      max log size = 1000
      syslog = 0
    
    # Authentifizierung
      security = user
      encrypt passwords = true
      smb passwd file = /etc/samba/smbpasswd-db
    
    
    [homes]
    # Home-Verzeichnisse werden nicht geshared
      browsable = no
    
    
    [intern]
    # Standard-Freigabe für alle VPN-Clients
      comment = Freigabe fuer alle Clients
      path = /home/samba/intern
      browsable = yes
      writable = yes
      valid users = $Liste_der_Benutzer
      write list = $Liste_der_Benutzer
      guest ok = no
    
    
    (Anmerkung: Aus sicherheitsgrunden verzichte ich hier die Liste der tatsächlichen Benutzer anzuzeigen, ist natürlich nicht $Liste_der_Benutzer ;-) )

    Das Problem ist jetz folgendes: Wenn ich den Samba-Server in der Netzwerkumgebung doppelt anklicke kommt nach einem kurzen Timeout die Meldung, dass der Server unter dem Hostname nicht erreichbar ist. (Die Fehlermeldung bezieht sich dabei auf den Unix-Hostname also \\hostname_meines_unixservers)

    Die [intern]-Freigabe funktioniert jedoch tadellos. (Im Arbeitsplatz per \\10.0.0.1\intern kann ich ohne Probleme drauf zugreifen. Die Freigabeliste des Servers ist auch ohne Probleme direkt unter \\10.0.0.1\ einsehbar.)

    Wie kann ich der Netzwerkumgebung unter WinXP beibringen dass der Servername nicht der Unix-Hostname sondern der SMB-Hostname ist?

    Wo ist hier das Problem?

    Grüße

    Nico
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. worker

    worker König

    Dabei seit:
    29.03.2007
    Beiträge:
    848
    Zustimmungen:
    0
    Ich weis nicht, ob man das Serverseitig lösen kann, aber falls nicht, dann bist Du in einem Unix-Forum nicht ganz richtig ;) ...
    Dennoch: Kann es sein, dass Du bei den Clients in der C:/Windows/system32/drivers/etc/lmhosts.sam Datei (oder wo auch immer das abgelegt ist) den Server eintragen musst ?
    Ein Versuch wäre es wohl wert.

    Gruß
    W.
     
  4. #3 noiz, 07.03.2008
    Zuletzt bearbeitet: 07.03.2008
    noiz

    noiz Pinguin-Pfleger

    Dabei seit:
    27.02.2008
    Beiträge:
    7
    Zustimmungen:
    0
    Serverseitig wäre natürlich mein Wunsch, aber ich kann mich auch damit anfreunden, dass ich auf den Clients eine lmhosts-Datei eonpflege, da die Anzahl der Clients im Netz mit 7 Rechnern noch überschaubar erscheint und sich der Aufwand in Grenzen hält. Aber danke für den Tip, war schon eine Vermutung von mir dass das nur mit einer (lm)hosts-Datei zu läsen wäre.

    Grüße

    Nico

    [EDIT]: Eben ausprobiert, klappt nicht! ;-) Ein Doppelklick auf den Server in der Netzwerkumgebung endet immer noch in der Fehlermeldung, dass der Unix-Host-Name nicht gefunden werden kann.
     
  5. worker

    worker König

    Dabei seit:
    29.03.2007
    Beiträge:
    848
    Zustimmungen:
    0
    Hm, da fällt mir ein, dass es auch sein kann, dass die Clients natürlich einen bestimmten Gateway benutzen, und so nicht zu Deinem Samba-Server "durchkommen". In den VPN einstellungen (Clientseitig) kann man doch auch noch mal einen Gateway einstellen. Vielleicht liegt da das Problem.
     
  6. noiz

    noiz Pinguin-Pfleger

    Dabei seit:
    27.02.2008
    Beiträge:
    7
    Zustimmungen:
    0
    Halte ich für unwarscheinlich auch wenn ich es mal probieren werde.
    Das Problem ist eher, dass Samba beim broadcasten den falschen Hostname veröffentlicht. Daher glaube ich ja auch, dass es eine Samba/Unix-Problem ist und ich in diesem Forum richtig bin! *gg*

    Habe mal ein Screenshot davon gemacht (Siehe Anlage) vielleicht wird es dann ein bischen deutlicher!
     

    Anhänge:

  7. noiz

    noiz Pinguin-Pfleger

    Dabei seit:
    27.02.2008
    Beiträge:
    7
    Zustimmungen:
    0
    UPDATE!

    Noch ein Versuch: Habe die VPN-Verbindung mal "getuned" (Siehe Anlage) (WINS-Support im Samba vorübergehend aktiviert!)

    Hat auch keine Besserung gebracht!
     

    Anhänge:

  8. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  9. #7 gonschior, 11.03.2008
    gonschior

    gonschior Mitglied

    Dabei seit:
    11.03.2008
    Beiträge:
    48
    Zustimmungen:
    0
    Samba soweit weiß

    Beschäftige mich auch mit smb.
    Kann das Problem bisher auch nicht ganz lösen.

    Soweit bin ich aber:

    a) Samba läuft mit windows nur unter NT und XP prof. richtig.
    normal XP nur Leserecht. Die meisten Distributionen können aber NUR NT.
    b) man muß in windows/Arbeitsplatz/eigenschaften/computername dann auf Ändern und domänenname anmelden. Dann wird der Name und das passwort verlangt. dieses bezieht sich auf einen angelegten root-Benutzer mit der Option ../false(nur Netzwerkbenutzer).
    c) dann klickt man auf die im windows-netzwerk erscheinenden Linuxordner und wenn man dann den gemeinten O. anklickt erscheint wieder die login-Maske und man muß dann Name und passwort des angelegten Samba-Zusatzbenutzers eingeben.
    Schön und gut.

    Nur leider:
    auch bei mir klappt's nicht. Ist nur soweit richtig.
    (habe noch einen Trick gefunden, ist aber nicht richtig so:
    aber falls es interessiert: man kann im Konquerer die IP-Adresse vom Xamp-Server des windows-PC's angeben und in htdocs eine Kopiermappe anlegen.
    Aber ist natürlich nur ein doofer Behelf).

    gonschior
     
  10. #8 supersucker, 11.03.2008
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    Das ist schlicht und ergreifend falsch.
     
Thema:

SMB-Server nicht korrekt im Netz erreichbar.

Die Seite wird geladen...

SMB-Server nicht korrekt im Netz erreichbar. - Ähnliche Themen

  1. Wie spielt man ein Video von smb-Server ab

    Wie spielt man ein Video von smb-Server ab: Hallo, ich bins mal wieder... mit etwas, das unter Windows problemlos geht und ich unter Linux leider verzweifel :/ Ich habe Video- und...
  2. PATH wird nicht richtig durchsucht

    PATH wird nicht richtig durchsucht: Hi zusammen, ich nutze das Forum schon seit längerem , allerdings hat mir bis jetzt immer die Suchfunktion weitergeholfen. Bei meinem aktuellen...
  3. SRV Records nicht erstellt nach dcpromo

    SRV Records nicht erstellt nach dcpromo: Hallo zusammen, leider sind beim Join meines 2. DC in eine Samba 4 Domäne die SRV-DNS Records nicht erstellt worden... Hatte jemand schonmal das...
  4. Port generieren, wenn nicht dann

    Port generieren, wenn nicht dann: Hey Leute, ich hänge ein wenig an einem Problem. Der User kann einen port frei wählen. Also SSH_USERPORT="" Nun habe ich aber eine.hand voll...
  5. Kabel I-net geht auf Arbeit aber nicht Zuhause

    Kabel I-net geht auf Arbeit aber nicht Zuhause: Hallo liebe Liebenden & Haters dieser Welt, ich komme bei mir zuhause nicht ins Internet via Ethernet-Kabel. Es handelt sich um einen Laptop, der...