Samba Problem bei Verbindung zu Share

Dieses Thema im Forum "Samba" wurde erstellt von domi55, 22.06.2008.

  1. domi55

    domi55 Grünschnabel

    Dabei seit:
    12.01.2007
    Beiträge:
    9
    Zustimmungen:
    0
    Hallo zusammen.

    Ich möchte mit Samba einen einfachen Sahre auf meinem Solaris 10 Server einrichten. Leider erscheint immer wieder das Windows Anmeldefenster, wenn ich versuche mich zu Verbinden.

    Hier meine smb.conf:

    Code:
     # more smb.conf
    [global]
       workgroup = workgroup
       server string = Samba Server
       security = user
    ;  encrypt passwords = yes
       log file = /var/samba/log/log.%m
       max log size = 1000
       passdb backend = smbpasswd
       invalid users = root
       map to guest = Bad User
       guest account = nobody
    ;  socket options = TCP_NODELAY
    ;  smb ports = 445 139
    ;  time server = yes
    
    
    #============================ Share Definitions ==============================
    
    
    [data]
       comment = Share @ Server
       path = /data/samba/
    ;  writable = yes
       create mask = 0755
       force user = domi
       write list = domi, simi
       browseable = Yes
       guest ok = No
       admin users = domi
       read only = Yes
    
    Den user domi habe ich mit smbpasswd -a erstellt und mit smbpasswd -e aktiviert.

    Auch der smbclient Output scheint mir ok:

    Code:
     # smbclient -L localhost -U domi -W WORKGROUP
    Password:
    Domain=[THUMP3R] OS=[Unix] Server=[Samba 3.0.25a]
    
            Sharename       Type      Comment
            ---------       ----      -------
            data            Disk      Share @ Server
            IPC$            IPC       IPC Service (Samba Server)
    Domain=[THUMP3R] OS=[Unix] Server=[Samba 3.0.25a]
    
            Server               Comment
            ---------            -------
    
            Workgroup            Master
            ---------            -------
            WORKGROUP
    
    Die Rechte von /data/samba sehen folgendermassen aus:

    Code:
     # ls -lahr
    total 8
    drwxrwxrwx   2 domi     other          2 Jun 22 16:45 samba
    
    Was zum Teufel mache ich noch falsch? Kann mir jemand von Euch weiterhelfen? Besten Dank.

    Domi
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 uzumakinaruto, 22.06.2008
    uzumakinaruto

    uzumakinaruto Tripel-As

    Dabei seit:
    23.05.2008
    Beiträge:
    246
    Zustimmungen:
    0
    Ort:
    Gifhorn
    smbpasswd -a USERNAME

    hast du das schonmal ausgeführt???
     
  4. domi55

    domi55 Grünschnabel

    Dabei seit:
    12.01.2007
    Beiträge:
    9
    Zustimmungen:
    0
    Ähm... Habe ich auch geschrieben:

     
  5. domi55

    domi55 Grünschnabel

    Dabei seit:
    12.01.2007
    Beiträge:
    9
    Zustimmungen:
    0
    Kann mir hier wirklich niemand weiterhelfen? Ich kann weiterhin nich auf den Share zugreifen und habe nun wirklich schon alles probiert.

    Für Eure Hilfe wäre ich sehr dankbar.
     
  6. #5 schwedenmann, 03.08.2008
    schwedenmann

    schwedenmann Foren Gott

    Dabei seit:
    18.11.2003
    Beiträge:
    2.635
    Zustimmungen:
    2
    Ort:
    Wegberg
    samba

    Hallo



    Ist der user domi auf Solaris und auf Windows vorhanden ?

    mfg
    schwedenmann
     
  7. domi55

    domi55 Grünschnabel

    Dabei seit:
    12.01.2007
    Beiträge:
    9
    Zustimmungen:
    0
    Hallo schwedenmann,

    Danke für Deine Antwort.


    Code:
    # more /etc/passwd
    ...
    domi:x:101:1::/export/home/domi:/bin/bash
    simi:x:102:1::/export/home/simi:/bin/bash
    
    Ich selber melde mich bei meinem Win XP SP3 PC mit dem User "Domi" an.
     
  8. #7 schwedenmann, 03.08.2008
    schwedenmann

    schwedenmann Foren Gott

    Dabei seit:
    18.11.2003
    Beiträge:
    2.635
    Zustimmungen:
    2
    Ort:
    Wegberg
    Samba

    Hallo

    erstell mal testweise einen neuen winuser domi, also nicht Domi !! und versuchs nochmal

    mfg
    schwedenmann

    P.S.
    ev. sogar dieselben PW wie auf Linux/Solaris benutzen
     
  9. domi55

    domi55 Grünschnabel

    Dabei seit:
    12.01.2007
    Beiträge:
    9
    Zustimmungen:
    0
    Gut...

    Ich habe die smb.conf angepasst:

    Code:
    [global]
       workgroup = workgroup
       server string = Samba Server
       security = user
    ;  encrypt passwords = yes
       log file = /var/samba/log/log.%m
       max log size = 1000
       passdb backend = smbpasswd
       invalid users = root
       map to guest = Bad User
       guest account = nobody
    ;  socket options = TCP_NODELAY
    ;  smb ports = 445 139
    ;  time server = yes
    
    
    #============================ Share Definitions ==============================
    
    
    [data]
       comment = Share @ Server
       path = /data/samba/
    ;  writable = yes
       create mask = 0755
       force user = Domi
       write list = Domi
       browseable = Yes
       guest ok = No
       admin users = Domi
       read only = Yes
    
    Code:
    # more /etc/passwd
    domi:x:101:1::/export/home/domi:/bin/bash
    simi:x:102:1::/export/home/simi:/bin/bash
    Domi:x:103:1::/home/Domi:/bin/sh
    
    Rechte des Shares:
    Code:
     # ls -lahr
    total 8
    drwxrwxrwx   8 Domi     other         10 Aug  3 18:30 samba
    
    smbpasswd -a vom user Domi habe ich gemacht. Es funktioniert aber weiterhin nicht.

    Stimmt die smb.conf überhaupt?

    Danke für Deine Hilfe.
     
  10. #9 schwedenmann, 03.08.2008
    schwedenmann

    schwedenmann Foren Gott

    Dabei seit:
    18.11.2003
    Beiträge:
    2.635
    Zustimmungen:
    2
    Ort:
    Wegberg
    Samba

    Hallo

    Du hast jetzt auf allen 3 System (win, Solaris,Samba) jeweils einen user Domi erstellt?

    mfg
    schwedenmann
     
  11. domi55

    domi55 Grünschnabel

    Dabei seit:
    12.01.2007
    Beiträge:
    9
    Zustimmungen:
    0
    Genau das habe ich gemacht.
     
  12. #11 schwedenmann, 03.08.2008
    schwedenmann

    schwedenmann Foren Gott

    Dabei seit:
    18.11.2003
    Beiträge:
    2.635
    Zustimmungen:
    2
    Ort:
    Wegberg
    Samba

    Hallo

    Die 2. letzen Screenshots zeieegn aber domi + Domi !

    mfg
    schwedenmann

    P.S.
    Ich wüßte sonst nicht wo es dran liegen könnte.

    Win ist Xp oder Vista ?
     
  13. domi55

    domi55 Grünschnabel

    Dabei seit:
    12.01.2007
    Beiträge:
    9
    Zustimmungen:
    0
    Ja ich habe uf meinem Solaris Server halt den User Domi und domi. Auf meinem Win XP Rechner habe ich den User Domi. Bei allen Systemen (Samba / Solaris Server / Win XP Rechner) habe ich das gleich Passwort. Ich weiss einfach nicht mehr weiter.
     
  14. #13 saeckereier, 03.08.2008
    saeckereier

    saeckereier Graue Eminenz

    Dabei seit:
    08.05.2005
    Beiträge:
    1.920
    Zustimmungen:
    0
    Ort:
    Im schönen Norden
    Stell den Loglevel hoch und schau mal in die Logdatei
     
  15. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  16. domi55

    domi55 Grünschnabel

    Dabei seit:
    12.01.2007
    Beiträge:
    9
    Zustimmungen:
    0
    Danke für den Tipp.

    Ich habe den Loglevel auf "3" gestellt. Anschliessend habe ich eine Verbindung versucht von meinem Win XP Rechner aus (\\server\share). Es kommt nach der Eingabe des Users und des Passworts immer wieder das Anmeldefenster. Zugriff auf den Share habe ich nicht.

    Ich wäre Euch sehr dankbar, wenn Ihr einmal einen Blick auf das Logfile werfen könntet.

    BTW: Am Passwort liegt es nicht! Habe dies jetzt wirklich ein paar mal neu gesetzt. Es ist auf allen Systemen exakt identisch.
     

    Anhänge:

  17. #15 drfreak2004, 03.08.2008
    drfreak2004

    drfreak2004 Guest

    Dein passwort ist falsch ! Hast du auch das selbe passwort für den User genommen wie unter Solaris ?

    Steht im Log passwort failed !

    Gruss
     
Thema:

Samba Problem bei Verbindung zu Share

Die Seite wird geladen...

Samba Problem bei Verbindung zu Share - Ähnliche Themen

  1. Problem mit Win-Zugriff auf SAMBA

    Problem mit Win-Zugriff auf SAMBA: Hallo rundherum, vielleicht hat jemand eine Idee... Habe jetzt schon 1 1/2 Tage damit verbraten und den Fehler nicht gefunden. Problem:...
  2. Samba 3.6 on Centos probleme mit OSX 10.10

    Samba 3.6 on Centos probleme mit OSX 10.10: Hallo Zusammen Ich habe einen smb server der läuft auf einer linux Kiste und habe ein sehr großes problem. Wenn man viele files verschiebt...
  3. Samba Freigabe Windows Problem

    Samba Freigabe Windows Problem: Ich habe ein Problem mit einer Samba Freigabe (Debian) unter Windows. Meine config http://pastebin.com/18ncwngr Mit smbclient -U ftp...
  4. skuriles Samba Problem

    skuriles Samba Problem: Hi, ich habe hier folgene Konstallation: - Fileserver - Debian Squeeze - hat Shares via Samba für die Windows-Benutzer - Samba...
  5. Problem mit A1-Mobile Broadband und Samba sharing

    Problem mit A1-Mobile Broadband und Samba sharing: Ich betreibe einen Linux/Debian-Squeeze (LAMP) Server mit Samba 3.5.6. Ich kann auf definierte shares über Telecom-Austria-Festnetz von einem...