Reinstallation von cupsys nicht möglich (hängt ab von libldap2)

Dieses Thema im Forum "Debian/Ubuntu/Knoppix" wurde erstellt von Dizzy, 09.07.2008.

  1. Dizzy

    Dizzy Brain Damage

    Dabei seit:
    02.05.2007
    Beiträge:
    857
    Zustimmungen:
    0
    Ort:
    Graz
    Hi,

    ich habe das Problem, dass mein Drucker mal funktionierte, mal nicht, jetzt wollte ich alles neu installieren (nach der Installation funktionierte alles, und die Logs sagten nichts aus), da der angeschlossene Drucker korrekt erkannt wurde, aber einen falschen Treiber verlangt hat (laut Fehlermeldung in den Eigenschaften) habe ich cups sammt allen zugehörogen Paketen (lildap2 war nicht dabei!) deinstalliert.

    Jetzt wollte ich den Reinstall einleiten, und alle Pakete ließen sich auch wieder installieren, nur das so unwichtige Paket cupsys erfordert eine lib, die auch vorher nicht installiert war. Nämlich libldap2. Nun gut - wird sich jetzt jeder denken - dann installier halt das Paket.

    Gut, wenn ich das machen will, möchte er gleich mal 170 Pakete deinstallieren.

    Einer eine Idee, was da schief gegangen ist, bzw wie ich das System austricksen kann?
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. foexle

    foexle Kaiser

    Dabei seit:
    02.05.2007
    Beiträge:
    1.104
    Zustimmungen:
    0
    Ort:
    Saarbrücken
    das issn netzwerk drucker der in nem ldap netzwerk hängt ?

    weil anders hast du die falschen treiber
     
  4. Dizzy

    Dizzy Brain Damage

    Dabei seit:
    02.05.2007
    Beiträge:
    857
    Zustimmungen:
    0
    Ort:
    Graz
    Öhm,

    der Drucker hängt an einem Server ... und am Server habe ich auch das Problem.
     
  5. #4 Goodspeed, 09.07.2008
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    Du hast in Deiner sources.list irgendwas vermurkst ...
    Code:
    apt-cache policy cupsys libldap2
    
     
  6. #5 Dizzy, 09.07.2008
    Zuletzt bearbeitet: 09.07.2008
    Dizzy

    Dizzy Brain Damage

    Dabei seit:
    02.05.2007
    Beiträge:
    857
    Zustimmungen:
    0
    Ort:
    Graz
    Hm, ich seh kein Problem:

    Code:
    epicur:~# apt-cache policy cupsys libldap2
    cupsys:
      Installiert: (keine)
      Kandidat: 1.2.7-4etch3
      Versions-Tabelle:
         1.2.7-4etch3 0
            500 http://security.debian.org etch/updates/main Packages
         1.2.7-4etch2 0
            500 http://ftp.at.debian.org etch/main Packages
    libldap2:
      Installiert: (keine)
      Kandidat: 2.1.30-13.3
      Versions-Tabelle:
         2.1.30.dfsg-13.5 0
            100 /var/lib/dpkg/status
         2.1.30-13.3 0
            500 http://ftp.at.debian.org etch/main Packages
    Und ... hm ... was sollte in der sources.list falsch sein?

    Code:
    #deb cdrom:[Debian GNU/Linux 4.0 r0 _Etch_ - Official i386 DVD Binary-1 20070407-11:40]/ etch contrib main
    
    deb http://ftp.at.debian.org/debian/ etch main
    deb-src http://ftp.at.debian.org/debian/ etch main
    
    deb http://security.debian.org/ etch/updates main contrib
    deb-src http://security.debian.org/ etch/updates main contrib
    
    #deb http://dotdeb.netmirror.org/ stable all
    #deb-src http://dotdeb.netmirror.org/ stable all

    ---

    Edit:

    So, das Problem ist, dass libldap--2.4-2 installiert ist, ich aber eine neuere Version brauche (die bekäme ich per libldap2), um libldap-2.4-2 zu deinstallieren, müsste ich aber auch zig andere deinstallieren. (apache2, alle php-pakete, mysql, alles für gnome (player und tools) und samba).

    Ich versuchs jetzt einfach mal so, dass ich alles deinstalliere, und die Pakete nachher wieder installiere, und die alte Config wieder reinkloppe. - Hat einer eine bessere Idee?
     
  7. #6 Goodspeed, 09.07.2008
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    Wenn der "plötzlich" hunderte von Paketen deinstallieren will, ist das meist ein Anzeichen von irgendwelchen Konflikten aufgrund "schiefer" Paketquellen ...
    Hier sieht allerdings alles korrekt aus ... und bei mir ist das Zeugs auch in der gleichen Version installiert ...

    Kannst Du mal posten, was er beim installieren von cupsys so alles ausspuckt?
     
  8. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  9. #7 Dizzy, 09.07.2008
    Zuletzt bearbeitet: 09.07.2008
    Dizzy

    Dizzy Brain Damage

    Dabei seit:
    02.05.2007
    Beiträge:
    857
    Zustimmungen:
    0
    Ort:
    Graz
    Hey,

    Code:
    epicur:~# apt-get install cupsys
    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut
    Lese Status-Informationen ein... Fertig
    Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
    Sie eine unmögliche Situation angefordert haben oder dass, wenn Sie die
    Unstable-Distribution verwenden, einige erforderliche Pakete noch nicht
    erstellt oder aus Incoming herausbewegt wurden.
    
    Da Sie nur eine einzige Operation angefordert haben, ist es sehr wahrscheinlich,
    dass das Paket einfach nicht installierbar ist und eine Fehlermeldung über
    dieses Paket erfolgen sollte.
    Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:
    
    Die folgenden Pakete haben nicht erfüllte Abhängigkeiten:
      cupsys: Hängt ab: libldap2 (>= 2.1.17-1) soll aber nicht installiert werden
    E: Kaputte Pakete
    Das Problem ist, dass cupsys libldap2 braucht, alle anderen Pakete wollen aber libldap-2.4-2. Die beiden vertragen sich aber gar nicht :(


    Edit:
    Ich probiers jetzt gerade nach meiner Methode (hoffentlich geht danach noch irgendwas ^^). Lustig finde ich, dass sich meine Etch-Installation seit neuestem lenny/sid nennt. :-?

    Edit2:
    Na ja, jetzt habe ich wenigstens eine Beschäftigung, mit dem Neu-Aufsetzen meines Servers ...
     
  10. #8 Goodspeed, 09.07.2008
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    Da hast Du "früher" wirklich was verbockt:

    libldap-2.4-2 gibt es nur in Lenny bzw. Sid ...
     
Thema:

Reinstallation von cupsys nicht möglich (hängt ab von libldap2)

Die Seite wird geladen...

Reinstallation von cupsys nicht möglich (hängt ab von libldap2) - Ähnliche Themen

  1. OpenSuse 12.2 Reinstallation nach Formatierung / Übernahme von Home-Verzeichnissen

    OpenSuse 12.2 Reinstallation nach Formatierung / Übernahme von Home-Verzeichnissen: Hallo Community, bei meinem Rechner muss ich die Partitionen anpassen und daher nicht nur eine Neuinstallation, sondern auch eine Formatierung...
  2. Unix-Anfänger und die Softwareinstallation

    Unix-Anfänger und die Softwareinstallation: Hallo Leute, ich bin in Sachen Unix / Linux ein absoluter Anfänger und ziemlich verzweifelt - daher brauche ich eure Hilfe. Es fängt schon...
  3. Suse leggt bei softwareinstallation über Yast

    Suse leggt bei softwareinstallation über Yast: Guten morgen. Ich hab gestern Abend festgestellt, das mein Yast2 auf meiner SuSE 10.1 ganz schönt bei dem start und beim ausführen leggt. Der...
  4. suse linux 10.1 installiert - probleme bei softwareinstallation

    suse linux 10.1 installiert - probleme bei softwareinstallation: hallo leute, ich bin hier ganz neu, hab auch erst heute suse linux 10.1 bei mir auf dem pc installiert. hab das OS noch nie benutzt, möchte mich...
  5. reinstallation von glibc

    reinstallation von glibc: hi, ich habe meinen kernel von 2.4.22 auf 2.6.8 geupdated. wäre es jetzt sinnvoll die glibc neu zu installieren oder lohnt sich das nicht?...