probleme mit Jack

Dieses Thema im Forum "Debian/Ubuntu/Knoppix" wurde erstellt von bladie, 27.05.2008.

  1. bladie

    bladie Grünschnabel

    Dabei seit:
    27.05.2008
    Beiträge:
    5
    Zustimmungen:
    0
    Hi,

    ich habe zurzeit das Problem das ich einen NSV video stream auf einen MP3Stream encodieren will. Die dazu nötige Lösung habe ich auch gefunden aber leider will Jack nicht so wie ich da gerne hätte::hilfe2:

    Script:

    Code:
    #!/bin/sh
    
    NSVSTREAM="http://localhost:8000;stream.nsv"
    
    JACK_NO_START_SERVER=1
    jackd -T -p 8 -d dummy -r 44100 -P /dev/jack &
    sleep 1
    darkice -c nsvtranscode.cfg &
    DARKICEPID=$!
    sleep 1
    mplayer "$NSVSTREAM" -quiet -vc null -vo null -ao jack:port=darkice-$DARKICEPID
    
    Ausgabe und Fehler
    Code:
    Copyright 2001-2005 Paul Davis and others.
    jackd comes with ABSOLUTELY NO WARRANTY
    This is free software, and you are welcome to redistribute it
    under certain conditions; see the file COPYING for details
    
    JACK compiled with System V SHM support.
    `default' server already active
    DarkIce 0.18 live audio streamer, http://darkice.tyrell.hu/
    Copyright (c) 2000-2007, Tyrell Hungary, http://tyrell.hu/
    
    Using config file: nsvtranscode.cfg
    Using JACK audio server as input device.
    Registering as JACK client darkice-11713
    MPlayer 1.0rc1-4.1.2-DFSG-free (C) 2000-2006 MPlayer Team
    CPU: Intel(R) Pentium(R) 4 CPU 3.06GHz (Family: 15, Model: 2, Stepping: 9)
    CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
    Compiled with runtime CPU detection.
    mplayer: could not connect to socket
    mplayer: No such file or directory
    Failed to open LIRC support. You will not be able to use your remote control.
    
    Playing http://localhost:8000;stream.nsv.
    Resolving localhost for AF_INET...
    Connecting to server localhost[127.0.0.1]: 8000...
    Name   : www.radio-phoenix.de
    Genre  : Dance, Trance, Pop, Rock, Wave, Charts
    Website: www.radio-phoenix.de
    Public : yes
    Bitrate: 500kbit/s
    Cache size set to 320 KBytes
    Cache fill:  5.00% (16384 bytes)
    ICY Info: StreamTitle='';StreamUrl='';
    
    Nullsoft Streaming Video file format detected.
    VIDEO:  [VP62]  320x240  24bpp  20.000 fps    0.0 kbps ( 0.0 kbyte/s)
    ==========================================================================
    Forced video codec: null
    Opening video decoder: [null] Null video decoder
    VDec: vo config request - 320 x 240 (preferred colorspace: BGR 24-bit)
    VDec: using Planar YV12 as output csp (no 0)
    Movie-Aspect is undefined - no prescaling applied.
    VO: [null] 320x240 => 320x240 Planar YV12
    Selected video codec: [null] vfm: null (NULL codec (no decoding!))
    ==========================================================================
    ==========================================================================
    Opening audio decoder: [faad] AAC (MPEG2/4 Advanced Audio Coding)
    FAAD: compressed input bitrate missing, assuming 128kbit/s!
    AUDIO: 44100 Hz, 2 ch, s16le, 128.0 kbit/9.07% (ratio: 16000->176400)
    Selected audio codec: [faad] afm: faad (FAAD AAC (MPEG-2/MPEG-4 Audio) decoder)
    ==========================================================================
    Could not open/initialize audio device -> no sound.
    Audio: no sound
    Starting playback...
    failed to write to ring ruffer
    zombified - calling shutdown handler
    JackDspSource :: shutdown_callback
    subgraph starting at darkice-11713 timed out (subgraph_wait_fd=6, status = 0, state = Triggered)
    **** dummy: xrun of 479335 usec
    544764 bytes transfered to the encoders
    Client 2 is not allowed to remove port darkice-11713:left
    Client 2 is not allowed to remove port darkice-11713:right
    DarkIce: TcpSocket.cpp:383: send error [32]
    
    Danke im voraus für Hilfe

    MfG
    bladie
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 -loop-, 27.05.2008
    Zuletzt bearbeitet: 27.05.2008
    -loop-

    -loop- Installer

    Dabei seit:
    27.12.2005
    Beiträge:
    117
    Zustimmungen:
    0
    Hallo,

    Installier doch mal qjackctl.
    Qjackctl ist ein tool für die X-Oberfläche
    zur Konfiguration des JACK-Audio-Servers.

    -Klingt auch verdächtig
    -> schau doch mal ob mplayer richtig installiert ist / wo der speicherort ist /
    ob der Pfad richtig gesetzt ist.

    Gruß

    -loop-
     
  4. bladie

    bladie Grünschnabel

    Dabei seit:
    27.05.2008
    Beiträge:
    5
    Zustimmungen:
    0
    Problem dabei das ist ein Server. Da sind X tools immer bescheiden
     
  5. #4 -loop-, 27.05.2008
    Zuletzt bearbeitet: 27.05.2008
    -loop-

    -loop- Installer

    Dabei seit:
    27.12.2005
    Beiträge:
    117
    Zustimmungen:
    0
    Audio-Device richtig konfiguriert ?

    - Wenn Du keine soundkarte hast / sound_on_board_chip,
    dann verwende das dummy-kernel-modul dafür



    Gruß

    -loop-
     
  6. bladie

    bladie Grünschnabel

    Dabei seit:
    27.05.2008
    Beiträge:
    5
    Zustimmungen:
    0
    ich hatte für die Lösung die beschreibung und habe der gefolgt von Jack hab ich an sich sogut wie null plan deswegen habe ich das ja hier reingeschrieben
     
  7. #6 -loop-, 27.05.2008
    Zuletzt bearbeitet: 27.05.2008
    -loop-

    -loop- Installer

    Dabei seit:
    27.12.2005
    Beiträge:
    117
    Zustimmungen:
    0
    jack ist an sich gar nicht kompliziert.

    Jedoch was jack benötigt um zu funktionieren ist ein sound-device
    das er ansprechen kann.

    Was du demnach
    ja nicht hast.


    Gruß

    -loop-
    .
    .
    .
    EDIT (autom. Beitragszusammenführung) :
    .

    Was sagt
    Code:
    cat /dev/dsp
    ?

    Ist ein entsprechendes Kernelmodul geladen ?
    Code:
    lsmod

    Gruß

    -loop-
     
  8. bladie

    bladie Grünschnabel

    Dabei seit:
    27.05.2008
    Beiträge:
    5
    Zustimmungen:
    0
    das geht ja über das backend dummy das heisst es wird eigentlich kein sound device benötigt oder irre ich mich da?
     
  9. -loop-

    -loop- Installer

    Dabei seit:
    27.12.2005
    Beiträge:
    117
    Zustimmungen:
    0
    sorry das hatte ich übersehen in der eile ;)

    ok also next step -> überprüfen ob der dummy von jack funktioniert.

    - schauen ob mplayer so ausführbar ist

    Immer weiter die Fehlermeldungen einkreisen!

    Gruß

    -loop-
     
  10. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  11. bladie

    bladie Grünschnabel

    Dabei seit:
    27.05.2008
    Beiträge:
    5
    Zustimmungen:
    0
    mplayer läuft an sich darkice auch also liegt der fehler bei Jack. Ist im standardkernel von debian dummy einkompiliert? Hab den standard drin sonnst muss ich selber einen bauen
     
  12. #10 -loop-, 28.05.2008
    Zuletzt bearbeitet: 28.05.2008
    -loop-

    -loop- Installer

    Dabei seit:
    27.12.2005
    Beiträge:
    117
    Zustimmungen:
    0
    Hallo,

    ja im Debian Standardkernel ist ein alsa-dummy oder oss-dummy Modul integriert.

    Einfach mal
    Code:
    modconf
    als root ausführen.

    Falls es nicht installiert ist, einfach per
    nachinstallieren.

    Mit modconf hast du dann die Möglichkeit
    dich grafisch durch die verfügbaren Module
    zu scrollen und bei Bedarf dann auch gleich das passende Modul zu laden.

    Gruß

    -loop-
     
Thema:

probleme mit Jack

Die Seite wird geladen...

probleme mit Jack - Ähnliche Themen

  1. Suse 10.1 Probleme mit Cyberjack e-com

    Suse 10.1 Probleme mit Cyberjack e-com: Hallo, der obige Kartenleser funtioniert nicht unter Moneyplex 2004, obwohl dieser bei der Vorversion Suse 10.0 einwandfrei ging. Ich habe von...
  2. grub-pc Probleme bei upgrade

    grub-pc Probleme bei upgrade: Hallo, ich habe beim dist-upgrade folgendes Problem: ---------- Nach dieser Operation werden 0 B Plattenplatz zusätzlich benutzt. Trigger für...
  3. Probleme mit YUM

    Probleme mit YUM: Hallo, ich habe CentOs 7 als Dualboot mit Windows 7 auf einen Dell Latitude E5510 installiert. Dies hat soweit auch alles geklappt. Leider habe...
  4. Forscher analysieren Durchsatzprobleme im Linux-Scheduler

    Forscher analysieren Durchsatzprobleme im Linux-Scheduler: Eine Gruppe von Forschern hat Fälle identifiziert, in denen der Scheduler im Linux-Kernel falsche Entscheidungen trifft und die CPUs nicht so gut...
  5. München: LiMux als Sündenbock für IT-Probleme?

    München: LiMux als Sündenbock für IT-Probleme?: Im Münchner Stadtrat soll später in diesem Jahr erneut über den Einsatz von Linux in der Stadtverwaltung diskutiert werden. Die Grünen vermuten,...