Postfix Probleme

Dieses Thema im Forum "SuSE / OpenSuSE" wurde erstellt von jgrieb, 16.03.2009.

  1. #1 jgrieb, 16.03.2009
    Zuletzt bearbeitet: 16.03.2009
    jgrieb

    jgrieb Jungspund

    Dabei seit:
    17.02.2009
    Beiträge:
    17
    Zustimmungen:
    0
    Hallo,
    ich habe Postfix auf SUSE 10.3 installiert und habe Probleme mit der Konfiguration.
    Dabei soll der Postfix folgendes machen:
    - versenden aller Mails über einen Smarthost (wegen dynamischer IP)
    - Mailbenutzer sollen sich am Postfix mit SMTP_AUTH anmelden müssen, bevor ihre Mails veschickt werden
    - Mailbenutzer sollen Zugriff auf Postfix und ihre Postfächer (courier) von local und von remote haben.
    Mit der folgenden Konfiguration habe ich folgendes erreicht:
    - ich kann Mails von local und remote mit Postfix über den smarthost versenden mit SMTP_AUTH.
    - Ich kann keine Mails empfangen. Es werden keine Mails in den lokalen Postfächern abgelegt.
    Wenn ich versuche von außen eine Mail an meinen Server zu schicken dann kommt nichts an. An den Absender wird auch keine Fehlermeldung geschickt.
    in der /var/log/mail.info steht dann folgendes:
    PHP:
    Mar 16 21:01:34 linux1 postfix/smtpd[21933]: connect from mail.gmx.net[213.165.64.20]
    Mar 16 21:01:39 linux1 postfix/smtpd[21933]: 8E63B524694client=mail.gmx.net[213.165.64.20]
    Mar 16 21:01:40 linux1 postfix/cleanup[22133]: 8E63B524694message-id=<20090316200054.54670@gmx.net>
    Mar 16 21:01:40 linux1 postfix/qmgr[21466]: 8E63B524694from=<jgrieb@gmx.de>, size=1070nrcpt=(queue active)
    Mar 16 21:01:40 linux1 postfix/local[22135]: 8E63B524694to=<info@griebsch-online.de>, relay=localdelay=1.6delays=1.5/0.01/0/0.06dsn=2.0.0status=sent (delivered to mailbox)
    Mar 16 21:01:40 linux1 postfix/qmgr[21466]: 8E63B524694removed
    Mar 16 21
    :01:40 linux1 postfix/smtpd[21933]: disconnect from mail.gmx.net[213.165.64.20]
    Mar 16 21:01:54 linux1 pop3dLOGINuser=web15_infoip=[::1], port=[46673]
    Mar 16 21:01:54 linux1 pop3dLOGOUTuser=web15_infoip=[::1], port=[46673], top=0retr=0rcvd=18sent=96time=0
    Mar 16 21
    :01:56 linux1 pop3dLOGINuser=web15_infoip=[::1], port=[46674]
    Mar 16 21:01:56 linux1 pop3dLOGOUTuser=web15_infoip=[::1], port=[46674], top=0retr=0rcvd=18sent=96time=0
    Und hier noch meine postconf -n
    PHP:
    alias_maps hash:/etc/aliases
    broken_sasl_auth_clients 
    yes
    command_directory 
    = /usr/sbin
    config_directory 
    = /etc/postfix
    daemon_directory 
    = /usr/lib/postfix
    debug_peer_level 
    2
    html_directory 
    = /usr/share/doc/packages/postfix/html
    inet_interfaces 
    all
    inet_protocols 
    all
    mailq_path 
    = /usr/bin/mailq
    manpage_directory 
    = /usr/share/man
    mydestination 
    = /etc/postfix/local-host-names
    mydomain 
    griebsch-online.de
    myhostname 
    www.$mydomain
    mynetworks 
    127.0.0.0/8
    newaliases_path 
    = /usr/bin/newaliases
    readme_directory 
    = /usr/share/doc/packages/postfix/README_FILES
    relayhost 
    = [mail.selfhost.de]
    sample_directory = /usr/share/doc/packages/postfix/samples
    sendmail_path 
    = /usr/sbin/sendmail
    setgid_group 
    maildrop
    smtp_enforce_tls 
    yes
    smtp_sasl_auth_enable 
    yes
    smtp_sasl_password_maps 
    hash:/etc/postfix/smtp_auth
    smtp_sasl_security_options 
    noanonymous
    smtp_tls_CAfile 
    = /etc/postfix/cacert.pem
    smtp_tls_note_starttls_offer 
    yes
    smtp_use_tls 
    yes
    smtpd_recipient_restrictions 
    permit_sasl_authenticated,permit_mynetworks,check                              _relay_domains
    smtpd_sasl_auth_enable 
    yes
    smtpd_sasl_security_options 
    noanonymous
    smtpd_tls_CAfile 
    = /etc/postfix/ssl/cacert.pem
    smtpd_tls_auth_only 
    no
    smtpd_tls_cert_file 
    = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_key_file 
    = /etc/postfix/ssl/smtpd.key
    smtpd_tls_loglevel 
    1
    smtpd_tls_received_header 
    yes
    smtpd_tls_session_cache_timeout 
    3600s
    smtpd_use_tls 
    yes
    tls_random_source 
    dev:/dev/urandom
    unknown_local_recipient_reject_code 
    550
    Brauche Dringend Eure Hilfe.

    Vielen Dank im Voraus.
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 bitmuncher, 17.03.2009
    bitmuncher

    bitmuncher Der Stillgelegte

    Dabei seit:
    08.05.2007
    Beiträge:
    3.171
    Zustimmungen:
    0
    Woran machst du denn fest, dass die Mails nicht ausgeliefert werden? Dein Log behauptet das Gegenteil: status=sent (delivered to mailbox). Wirf mal einen Blick in /var/spool/mail/.
     
  4. jgrieb

    jgrieb Jungspund

    Dabei seit:
    17.02.2009
    Beiträge:
    17
    Zustimmungen:
    0
    Die Mails landen tatsächlich in diesem Verzeichnis. Allerdings in der falschen Mailbox. Deshalb findet mein Mailclient auch nichts wenn er auf den POP3 zugreift.
    Wo kann ich das den korrigieren?
     
  5. #4 bitmuncher, 17.03.2009
    bitmuncher

    bitmuncher Der Stillgelegte

    Dabei seit:
    08.05.2007
    Beiträge:
    3.171
    Zustimmungen:
    0
    Die Frage ist halt, wo sollen sie hin und wo landen sie? Vermutlich wird einfach ein Alias für eine Umleitung ausreichen.
     
  6. jgrieb

    jgrieb Jungspund

    Dabei seit:
    17.02.2009
    Beiträge:
    17
    Zustimmungen:
    0
    Soweit ich weiß, erfolgt die Zuordnung der User zu den Postfächern über die Datei virtusertable.
    Hier poste ich meine mal.
    PHP:
    ###################################
    #
    # ISPConfig virtusertable Configuration File
    #         Version 1.0
    #
    ###################################
    info@www.griebsch-online.de    web18_info
    web18_info
    @www.griebsch-online.de    web18_info
    info
    @griebsch-online.de    web18_info
    web18_info
    @griebsch-online.de    web18_info
    #### MAKE MANUAL ENTRIES BELOW THIS LINE! ####
    Gemäß dieser Konfiguration müßten also alle Mails, die an info@griebsch-online.de gesendet werden, in der Mailbox web18_info abgelegt werden.
    Tatsächlich ist es aber so, dass alle Mails in einer Mailbox mit dem Namen info abgelegt werden, mein Mailclient aber vom Server mit web18_info verbunden wird und dort logischerweise keine Mails findet.. Deshalb möchte ich, dass die Mails in web18_info landen damit ich sie mit meinem Mailclient auch abrufen kann.
    Weiß nur nicht wie ich das hinkriege.
     
  7. #6 bitmuncher, 17.03.2009
    bitmuncher

    bitmuncher Der Stillgelegte

    Dabei seit:
    08.05.2007
    Beiträge:
    3.171
    Zustimmungen:
    0
    Laut deiner main.cf ist deine Aliases-Zuordnung aber in der /etc/aliases

    Code:
    alias_maps = hash:/etc/aliases
    
    (Als Hash, erfordert also ein 'newaliases' nach dem Ändern.)Ich sehe nichts, wo du dem Mailserver mitteilst, dass er was anderes verwenden soll. Allerdings weiss ich auch nicht, was ISPConfig da an Konfigurationen zusammenmurkst.
     
  8. jgrieb

    jgrieb Jungspund

    Dabei seit:
    17.02.2009
    Beiträge:
    17
    Zustimmungen:
    0
    Ich habe inzwischen folgendes gemacht. Ich habe alle bestehenden Mailaccounts auf meinem Server gelöscht. Anschließend habe ich eine E-Mail-Adresse neu angelegt (infoo@griebsch-online.de).
    Dann habe ich alles noch mal getestet mit folgendem Ergebnis:
    - Versenden von local und remote mit smtp_auth funktioniert.
    - Empfang funktioniert nicht. Jetzt kommen die Mails tatsächlich nicht mehr an, sondern werden an den Absender rejectet.
    In der mail.info steht dann folgendes:
    PHP:
    Mar 18 01:51:30 linux1 postfix/smtpd[8559]: connect from mail.gmx.net[213.165.64.20]
    Mar 18 01:51:30 linux1 postfix/smtpd[8559]: NOQUEUErejectRCPT from mail.gmx.net[213.165.64.20]: 554 5.7.1 <infoo@griebsch-online.de>: Recipient address rejectedRelay access deniedfrom=<jgrieb@gmx.deto=<infoo@griebsch-online.deproto=SMTP helo=<mail.gmx.net>
    Mar 18 01:51:30 linux1 postfix/smtpd[8559]: disconnect from mail.gmx.net[213.165.64.20]
    Und ich habe an der Konfiguration definitiv nichts verändert.

    Langsam gehen mir wirklich die Ideen aus.
    Wenn ich mich beim versenden an fremde Hosts mit smtp_auth authentifiziere, und die Mail dort ankommt, wieso wird die Weiterleitung an meine lokale Mailbox dann verweigert?
     
  9. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  10. #8 bitmuncher, 18.03.2009
    bitmuncher

    bitmuncher Der Stillgelegte

    Dabei seit:
    08.05.2007
    Beiträge:
    3.171
    Zustimmungen:
    0
    Dein Server fühlt sich scheinbar nicht für die Domain verantwortlich. Ist sie in /etc/postfix/local-host-names (also mydestination) eingetragen?
     
  11. jgrieb

    jgrieb Jungspund

    Dabei seit:
    17.02.2009
    Beiträge:
    17
    Zustimmungen:
    0
    Gelöst

    Hallo Bitmuncher,
    ich glaube, ich habe das Problem gelöst. Vielen Dank für Deine Hinweise. Nachdem ich Deinen Hinweisen nachgegangen bin, kam ich zu der Erkenntnis, dass die Konfiguration offensichtlich in Ordnung ist und es daran nicht liegen kann.
    Da ich auf dieser Maschine aber die Domains meiner Kunden hosten will, verwende ich das Konfig-Tool ISPConfig. Also fiel mein Verdacht als nächstes darauf. Also habe ich ISPConfig sauber deinstalliert und anschließend neu installiert. Und siehe da - alles funktioniert auf Anhieb einwandfrei.

    Während meiner ersten Lernphase mit ISPConfig hatte ich wohl die Konfiguration beschädigt, als ich aus Unkenntnis anderer Möglichkeiten einige Einträge durch Direktzugriff auf die ISPConfig-Datenbank mit phpMyAdmin gelöscht habe. Inzwischen weiß ich aber wie es auch anders geht.

    Einige Tests werde noch machen. Aber ich glaube da wird nichts mehr passieren.

    Also, nochmals danke.
     
Thema:

Postfix Probleme

Die Seite wird geladen...

Postfix Probleme - Ähnliche Themen

  1. Probleme mit POSTFIX

    Probleme mit POSTFIX: Hallo, ich habe vor lauter POSTFIX, zweimal das gleiche Thema im Forum geschrieben. Sorry! Thomas
  2. Probleme mit Postfix und Cyrus

    Probleme mit Postfix und Cyrus: Ich habe bei mir Postfix und cyrus installiert leider der postfix zeigt mir einen Fehler Permission denied und vor kurzen habe noch dazu den User...
  3. Hab 2 Woody Probleme... mit Postfix

    Hab 2 Woody Probleme... mit Postfix: Hi, ja Woody riecht schon ;-) aber "nerver touch a running system" oder so 1. Also ich hab da eine eMail server laufen mit dem Packet...
  4. Probleme mit Postfix

    Probleme mit Postfix: Hy Leute Seit Gestern versendet mein Postfix-Server keine Mails mehr nach aussen. Ich hatte eine Zeit lang Probleme mit DNS, pingen kann ich...
  5. Probleme beim versand ueber Postfix

    Probleme beim versand ueber Postfix: hallo leute, ich hoffe ihr koennt mir ein wenig weiterhelfen, aber ich weiss echt nicht mehr so recht weiter. Wir haben bei uns Gentoo mit...