phpMyAdmin lädt Backup nicht hoch

Dieses Thema im Forum "SQL und Datenbanken" wurde erstellt von toxicon, 07.11.2008.

  1. #1 toxicon, 07.11.2008
    toxicon

    toxicon Grünschnabel

    Dabei seit:
    07.11.2008
    Beiträge:
    1
    Zustimmungen:
    0
    N'Abend,

    ich hab eine kleines bis mittelschweres Problem. Und zwar folgendes:

    Gestern ist die my-sql-Datenbank unserer Homepage abgeschmiert. Da ich ein relativ junges Backup dieser Datenbank vorliegen habe (2 Tage alt) wollte ich dies sofort hochladen. Allerdings kam folgende Fehlermeldung:
    Code:
    Fehler
    Möglicherweise haben Sie einen Bug im SQL-Parser entdeckt. Bitte überprüfen Sie Ihre Abfrage genaustens, insbesondere auf falsch gesetzte oder nicht geschlossene Anführungszeichen. Eine weitere Ursache könnte darin liegen, dass Sie versuchen eine Datei mit binären Daten, welche nicht von Anführungszeichen eingeschlossen sind, hochzuladen. Sie können alternativ versuchen Ihre Abfrage über das MySQL-Kommandozeileninterface zu senden. Die MySQL-Fehlerausgabe, falls vorhanden, kann Ihnen auch bei der Fehleranalyse helfen. Falls Sie weiterhin Probleme haben sollten oder der Parser dort versagt, wo die Kommandozeile erfolgreich ist, so reduzieren Sie bitte Ihre Abfrage auf den Befehl, welcher die Probleme verursacht, und senden Sie uns einen Bugreport mit den Datenausschnitt, den Sie weiter unten auf dieser Seite finden.:
    ----AUSSCHNITTSANFANG----
    eNodjk1OwzAUhCOVBfKaA7xFl/HDdpqSeBciq1Q4P8SlSOwKCTSSm5pGReFsXA4XaRaj0Wi+UU1T
    NRJyDrkArUoJAiLgMTEbH88IybdGwnzdShi/rNudxu6Etn9Dt3fhNwiMliAYi29Z4uWtFEJyDrY7
    pKAmB3NS/JgnLWGBDMUdPewmao+f5Nk0UJkQspUqNyFslce99AMU1eta6wxiZKQuMv8Hl7igzkak
    fqgvvbAyl7UIOaMejeP73p6HFjnofjhPRGflSkLb0X480iSJU8rJ/4P6cXZ1EwTBdXD/+5EGfy0p
    PtE=
    ----AUSSCHNITTSENDE----
    ----BEGINN DER AUSGABE----
    
    ERROR: C1 C2 LEN: 2 3 15
    STR: 
    
    CVS: $Id: sqlparser.lib.php,v 2.36 2005/08/08 20:22:11 lem9 Exp $
    MySQL: 4.0.27-max-log
    USR OS, AGENT, VER: Win MOZILLA 5.0
    PMA: 2.6.4-pl3
    PHP VER,OS: 4.3.10-200.schlund.1 Linux
    LANG: de-iso-8859-1
    SQL: PK����B»f9�
    
    ----ENDE DER AUSGABE----
    
    SQL-Befehl:
    
    PK����B»f9�
    
    MySQL meldet: Dokumentation
    #1064 - You have an error in your SQL syntax.  Check the manual that corresponds to your MySQL server version for the right syntax to use near 'PK' at line 1 
    Da ich mich nicht sehr mit SQL und so auskenne habe ich ein paar Kumpels drüber schauen lassen, doch die konnten keinen Fehler innerhalb der Datei feststellen.

    Ich hoffe ihr könnt mir helfen. Alle Sachen die ihr noch wissen müsst bitte ich euch zu posten, da ich mich wie gesagt nicht mit Datenbanken usw auskenne.

    Vielen Dank schonmal

    LG toxicon
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 bitmuncher, 12.11.2008
    bitmuncher

    bitmuncher Der Stillgelegte

    Dabei seit:
    08.05.2007
    Beiträge:
    3.171
    Zustimmungen:
    0
    Evtl. wurde die Datei mit einem "falschen" Encoding abgespeichert oder es wird ein Feature angesprochen, das in der MySQL nicht aktiviert ist.
     
  4. #3 supersucker, 12.11.2008
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    Das sieht doch mal verdächtig nach Zeichensalat aus.

    Welches Encoding verwendest du denn DB-intern?
     
Thema:

phpMyAdmin lädt Backup nicht hoch

Die Seite wird geladen...

phpMyAdmin lädt Backup nicht hoch - Ähnliche Themen

  1. MySQL Datenbank / Phpmyadmin Fehler #2002

    MySQL Datenbank / Phpmyadmin Fehler #2002: Wie oben schon beschrieben kommt bei mir immer wenn ich versuche auf Phpmyadmin zu verbinden dieser Fehler : #2002 Die Anmeldung am MySQL-Server...
  2. phpMyAdmin 4.4 veröffentlicht

    phpMyAdmin 4.4 veröffentlicht: Die phpMyAdmin-Entwickler haben ihre freie, in PHP umgesetzte Administrationsoberfläche für MySQL-Datenbanken in der Version 4.4 veröffentlicht....
  3. PHPmyAdmin login funktioniert nicht

    PHPmyAdmin login funktioniert nicht: Hallo zusammen, nachdem ich gestern meine PHP Version von 5.3 auf 5.4 geupdated habe, kann ich mich nicht mehr in PHPmyAdmin einloggen. Komisch...
  4. Phpmyadmin speicher Ort

    Phpmyadmin speicher Ort: Hallo Zusammen, Habe gerade auf meinem Raspberry Pi phpmyadmin installiert. Wenn ich phpmyadmin öffnen will, muss ich folgende Adresse...
  5. Neue Version 4.0.0 von phpMyAdmin

    Neue Version 4.0.0 von phpMyAdmin: Die PHP-Weboberfläche zum Administrieren von MySQL-Datenbanken phpMyAdmin steht in einer überarbeiteten Version 4.0.0 zur Verfügung. Weiterlesen...