Nvidia-Treiberinstallation kann NVIDA-Modul nicht erstellen

Dieses Thema im Forum "Grafik / Video" wurde erstellt von smbdyclldlcs, 10.07.2007.

  1. #1 smbdyclldlcs, 10.07.2007
    smbdyclldlcs

    smbdyclldlcs Doppel-As

    Dabei seit:
    29.07.2006
    Beiträge:
    114
    Zustimmungen:
    0
    Ort:
    Mittelhessen
    Moin zusammen,
    ich versuche seit heute morgen, den nvidia-treiber zu installieren (auf debian unstable), der installer meldet aber immer wieder dass es das Modul "Nvidia" nicht erstellen kann. /var/log/nvidia-installer.log entnehme ich, dass die datei scripts/genksyms/genksyms nicht finden kann. unter /usr/src/linux/scripts/genksyms/ finden sich die dateien:
    genksyms.c, keywords.c_shipped, lex.c_shipped, Makefile, parse.h_shipped, genksyms.h, keywords.gperf, lex.l, parse.c_shipped, parse.y
    was ist hier zu tun?
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 blue-dev, 10.07.2007
    blue-dev

    blue-dev stranger with blue eyes

    Dabei seit:
    30.06.2007
    Beiträge:
    438
    Zustimmungen:
    0
    In dem entsprechenden Ordner "make" eintippen und gucken ob ne binary mit namen "geksyms" zum Vorschein kommt.
     
  4. #3 smbdyclldlcs, 10.07.2007
    smbdyclldlcs

    smbdyclldlcs Doppel-As

    Dabei seit:
    29.07.2006
    Beiträge:
    114
    Zustimmungen:
    0
    Ort:
    Mittelhessen
    bereits versucht, ohne ergebnis

    Mistkiste:/usr/src/linux/scripts/genksyms# make
    make: *** Keine Regel vorhanden, um das Target »/parse.h«,
    benötigt von »/lex.o«, zu erstellen. Schluss.
    Mistkiste:/usr/src/linux/scripts/genksyms#
     
  5. #4 Goodspeed, 11.07.2007
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    Das stört Dich an den Treibern, die Sid mitliefert (v. 100.14.11)?
     
  6. #5 smbdyclldlcs, 11.07.2007
    smbdyclldlcs

    smbdyclldlcs Doppel-As

    Dabei seit:
    29.07.2006
    Beiträge:
    114
    Zustimmungen:
    0
    Ort:
    Mittelhessen
    Das meine Grafikkarte mit denen nicht läuft, außerdem ist es keine sid-installation, sondern Debian 4.0 mit unstable-respos in der sources.list (mag vielleicht doof klingen...)
     
  7. #6 madfool, 11.07.2007
    madfool

    madfool Tripel-As

    Dabei seit:
    12.08.2004
    Beiträge:
    192
    Zustimmungen:
    0
    Äh, wo ist denn da der Unterschied? Sid ist doch Debian unstable oder täusche ich mich da??
     
  8. #7 smbdyclldlcs, 11.07.2007
    smbdyclldlcs

    smbdyclldlcs Doppel-As

    Dabei seit:
    29.07.2006
    Beiträge:
    114
    Zustimmungen:
    0
    Ort:
    Mittelhessen
    Ja, aber es ist ein unterschied ob man direkt unstable/sid von einer DVD/CD installiert oder eine andere Version nimmt und diese upgradet.
     
  9. #8 Goodspeed, 11.07.2007
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    *lol*
    Was sagt den
    Code:
    apt-cache policy libc6
    
     
  10. #9 smbdyclldlcs, 11.07.2007
    Zuletzt bearbeitet: 11.07.2007
    smbdyclldlcs

    smbdyclldlcs Doppel-As

    Dabei seit:
    29.07.2006
    Beiträge:
    114
    Zustimmungen:
    0
    Ort:
    Mittelhessen
    Code:
    Mistkiste:/home/lucas# apt-cache policy libc6
    libc6:
      Installiert:2.5-11
      Mögliche Pakete:2.5-11
      Versions-Tabelle:
         2.6-0exp3 0
              1 http://ftp.de.debian.org experimental/main Packages
     *** 2.5-11 0
            500 http://ftp.de.debian.org unstable/main Packages
            100 /var/lib/dpkg/status
         2.5-9+b1 0
            500 http://ftp.de.debian.org testing/main Packages
    Mistkiste:/home/lucas#
    
    
     
  11. #10 Goodspeed, 11.07.2007
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    Noch Fragen? Du HAST Sid ... und es ist Wurst, ob das per Upgrade oder sonst wie funktioniert ...
    Dann nimm auch die Treiber von da ... denn mit meiner 6600GT haben die keine Probleme gemacht ...
     
  12. #11 smbdyclldlcs, 11.07.2007
    smbdyclldlcs

    smbdyclldlcs Doppel-As

    Dabei seit:
    29.07.2006
    Beiträge:
    114
    Zustimmungen:
    0
    Ort:
    Mittelhessen
    Fakt ist, dass es nicht funktioniert... wie kann ich diesen Treiber denn aktivieren/installieren?
     
  13. #12 Goodspeed, 11.07.2007
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    Code:
    aptitude install module-assistant
    m-a update
    m-a prepare
    m-a a-i nvidia
    aptitude install nvidia-glx
    
    Dann noch die xorg.conf anpassen ... fertig.
     
  14. #13 smbdyclldlcs, 11.07.2007
    Zuletzt bearbeitet: 11.07.2007
    smbdyclldlcs

    smbdyclldlcs Doppel-As

    Dabei seit:
    29.07.2006
    Beiträge:
    114
    Zustimmungen:
    0
    Ort:
    Mittelhessen
    m-a a-i nvidia schlägt fehl:
    Code:
    make[2]: Entering directory `/usr/src/modules/nvidia-kernel/nv'
    failed to determine PATCHLEVEL!
    make[2]: *** [module] Fehler 1
    make[2]: Leaving directory `/usr/src/modules/nvidia-kernel/nv'
    make[1]: *** [build-stamp] Fehler 2
    make[1]: Leaving directory `/usr/src/modules/nvidia-kernel'
    make: *** [kdist_image] Fehler 2       
     
  15. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  16. #14 Goodspeed, 11.07.2007
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    Welcher Kernel? Richtige Kernel-Header installiert? Welcher GCC?
     
  17. #15 smbdyclldlcs, 11.07.2007
    smbdyclldlcs

    smbdyclldlcs Doppel-As

    Dabei seit:
    29.07.2006
    Beiträge:
    114
    Zustimmungen:
    0
    Ort:
    Mittelhessen
    Code:
    Mistkiste:/home/lucas# uname -a
    Linux Mistkiste 2.6.18-4-486 #1 Wed May 9 22:23:40 UTC 2007 i686 GNU/Linux
    Mistkiste:/home/lucas# apt-cache policy gcc
    gcc:
      Installiert:4:4.1.2-3
      Mögliche Pakete:4:4.1.2-3
      Versions-Tabelle:
         4:4.2.0-0 0
              1 http://ftp.de.debian.org experimental/main Packages
     *** 4:4.1.2-3 0
            500 http://ftp.de.debian.org unstable/main Packages
            100 /var/lib/dpkg/status
         4:4.1.1-15 0
            500 http://ftp.de.debian.org testing/main Packages
    Mistkiste:/home/lucas# apt-cache policy linux-headers-2.6.18-4-486
    linux-headers-2.6.18-4-486:
      Installiert:2.6.18.dfsg.1-12etch2
      Mögliche Pakete:2.6.18.dfsg.1-12etch2
      Versions-Tabelle:
     *** 2.6.18.dfsg.1-12etch2 0
            500 http://security.debian.org etch/updates/main Packages
            100 /var/lib/dpkg/status
         2.6.18.dfsg.1-12 0
            500 http://ftp.de.debian.org testing/main Packages
    
     
Thema:

Nvidia-Treiberinstallation kann NVIDA-Modul nicht erstellen

Die Seite wird geladen...

Nvidia-Treiberinstallation kann NVIDA-Modul nicht erstellen - Ähnliche Themen

  1. KDE Startet nach NVIDIA-Treiberinstallation nicht mehr.

    KDE Startet nach NVIDIA-Treiberinstallation nicht mehr.: Guten Nachmittag:) Also ich hab mir heute Nacht mal Mandriva Spring 2007 Als 2. bzw Versuchssystem aufgespielt. Ich hab alles soweit...
  2. Titelleiste futsch nach Nvidia-Treiberinstallation

    Titelleiste futsch nach Nvidia-Treiberinstallation: Hallo! Nutze Gnome / Metacity. Habe neue Treiber (Nvidia) installiert; nun sind die Kopf- oder Titelleisten der Fenster weg und ich kann die...
  3. Wie kann ich x Zeichen hinter einem bestimmten Wort ausgeben ?

    Wie kann ich x Zeichen hinter einem bestimmten Wort ausgeben ?: In mehreren Dateien ist immer mehrfach ein bestimmtes Wort enthalten, gefolgt von einem "=". Ich möchte mir die dahinter folgenden 10 Zeichen...
  4. Wie kann ich das RAM löschen?

    Wie kann ich das RAM löschen?: Wie kann ich das RAM löschen? Danke im Vorraus
  5. Nicht erkannte Zeichen nach Update

    Nicht erkannte Zeichen nach Update: Hi, nachdem ich mein Kali Linux geupdated habe, ist mir aufgefallen dass viele Zeichen auf verschiedenen Nutzeroberflächen nur fehlerhaft...