NIS-server

Dieses Thema im Forum "Debian/Ubuntu/Knoppix" wurde erstellt von Lol0r, 29.08.2007.

  1. Lol0r

    Lol0r Grünschnabel

    Dabei seit:
    29.08.2007
    Beiträge:
    6
    Zustimmungen:
    0
    Hallo an alle Wissenden :)
    Bin noch nicht lange mit Linux am arbeiten. Habe einen Linux Terminalserver mit LTSP aufgesetzt, dieser funktioniert auch soweit.
    Ich habe aber den Auftrag Local Apps zum Laufen zun bringen. In der Doku von LTSP steht geschrieben, dass ich einen NIS-server benötige. Nunja, diese Doku verweist auf ein NIS howto von debian.
    Dieses hab ich soweit befolgt, doch ich kann weder ypserv, noch ypbind und die anderen dateien gestarten. Bei /etc/init.d/nis restart sind anfangs immer ein Haufen Punkte gekommen, und dann start failed, oder sowas in der Art.

    Naja daraufhin hab ich weiter gegoogelt, noch andere Doku's gefunden, die aber wiederrum andere Installationspakete angeben, und auch in der Konfiguration anders von statten gehen!
    Jetzt bin ich soweit das ich mit "locate nis" die "angeblichen" Orte davon finde, aber wenn ich beispielsweise nis starten will, sagt er mir das die Datei nicht existieren würde.
    Kann mir jemand von euch vllt eine gute Dokumentation empfehlen? Die Doku, mit der ich momentan arbeite, bringt mich einfach nicht weiter.
    Oder kennt vielleicht einer von euch beim oben beschriebenes Problem?

    Schon mal danke im Voraus für eure Mühen!
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. juan_

    juan_ König

    Dabei seit:
    22.01.2004
    Beiträge:
    992
    Zustimmungen:
    0
    Ort:
    Berlin
    kenne diese applikation jetzt auch nicht, aber wie hast dus denn installiert ?

    Code:
    apt-cache search NIS
    ...
    nis - Clients and daemons for the Network Information Services (NIS)
    ...
    
    ciao
     
  4. Lol0r

    Lol0r Grünschnabel

    Dabei seit:
    29.08.2007
    Beiträge:
    6
    Zustimmungen:
    0
    hab erst versucht, mit "apt-get install nis"
    das hat nicht funktioniert, egal was ich versucht habe, weiss nicht wieviele seiten von google ich schon durch hab.
    Ja dann hab ich erst nis wieder entfernt, und daraufhin "apt-get install nfs-kernel-server nis". Das hat auch nicht die erhoffte änderung gebracht
    Daraufhin hab ich die einzelnen Pakete die in einer weiteren Doku angegeben waren installiert, bzw. selber kompiliert. Ja und seitdem finde ich nicht mal die Datei um nis zu starten(versuchen zu starten). :hilfe2:
     
  5. sinn3r

    sinn3r Law & Order
    Moderator

    Dabei seit:
    28.12.2006
    Beiträge:
    2.764
    Zustimmungen:
    0
    Ort:
    Wentorf
    Das klingt böse nach Copy und Paste

    Fehlermeldung, oder was du genau versucht hast, würde mehr helfen.
    Das passiert, wenn jm versucht, etwas am Packetmanager vorbei installiert und nicht weis was er tut...
     
  6. Lol0r

    Lol0r Grünschnabel

    Dabei seit:
    29.08.2007
    Beiträge:
    6
    Zustimmungen:
    0
    Ja, hab ja geschrieben, ich bin neu auf dem Gebiet, copy&paste gabs bei mir nicht. Alles von hand eingegeben.

    Also nachdem ich NIS installiert hatte, das erste, kam immer

    Starting NIS services: ypserv yppasswdd ypxfrd ypbindingbinding to YP server..................................................................................................
    ..........................failed(backgrounded).

    Daraufhin hatte ich den selben Fehler mit dem Paket nfs-kernel-server nis

    Ich versteh nicht ganz was du mit "an dem Packetmanager vorbeinstallieren" meinst. Hab die tar.gz pakete runtergeladen, entpackt und eben alles nach einer Anleitung zum installieren von Paketen durchgeführt.

    Naja, auf jeden Fall hab ich dann den kernel-server nis wieder removed und eben die besagten Pakete installiertm bei systemstart versucht er zwar den nis-server zu starten, aber der gleiche Fehler wie oben.
     
  7. #6 bitmuncher, 29.08.2007
    bitmuncher

    bitmuncher Der Stillgelegte

    Dabei seit:
    08.05.2007
    Beiträge:
    3.171
    Zustimmungen:
    0
    Welche Fehlermeldungen gibt es in den Logdateien (syslog, messages und sofern konfiguriert die serverspezifischen Logs)?
     
  8. Lol0r

    Lol0r Grünschnabel

    Dabei seit:
    29.08.2007
    Beiträge:
    6
    Zustimmungen:
    0
    So, also im syslog, messages sehe ich mal keine Fehler bezogen auf NIS, serverspezifische logs hab ich meines wissen nach nicht konfiguriert. :/

    Also, ich hab versucht wieder nis zu starten, wieder die Punkte und failed(backgrounded)
    wenn ich aber danach in die logs schaue, also messages und syslog ist dort nichts verzeichnet
     
  9. #8 bitmuncher, 29.08.2007
    bitmuncher

    bitmuncher Der Stillgelegte

    Dabei seit:
    08.05.2007
    Beiträge:
    3.171
    Zustimmungen:
    0
    Mach mal ein 'grep -r -i "nis" /var/log'. Gibt es dabei einen Output?
     
  10. Lol0r

    Lol0r Grünschnabel

    Dabei seit:
    29.08.2007
    Beiträge:
    6
    Zustimmungen:
    0
    Ja, bekomm output, erstmal ein haufen verschiedene sprachen und ganz unten, ist nur aufgeführt "Package: finish-install" und weiter unten, ein neuer User den ich angelegt hatte. Sonst keine Fehler oder so
     
  11. sinn3r

    sinn3r Law & Order
    Moderator

    Dabei seit:
    28.12.2006
    Beiträge:
    2.764
    Zustimmungen:
    0
    Ort:
    Wentorf
    Ob du nun das kopierst oder eintippst, wirklich verstanden was du da gemacht hast, war wohl nicht oder?

    Es kann gut, dass durch die kompilierte Version es jetzt Probleme mit der Packetmanger Version gibt.

    Hast du checkinstall verwendet oder make install?
     
  12. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  13. Lol0r

    Lol0r Grünschnabel

    Dabei seit:
    29.08.2007
    Beiträge:
    6
    Zustimmungen:
    0
    Ich habe make install verwendet!
    Naja, klar weiss ich erstmal nicht genau was es damit genau auf sich hat, aber irgendwie fängt jeder an.
    Ich weiss auch, dass eventuell der Terminalserver bzw. die Local Apps darauf, ein wenig verfrüht für den Anfang sind. Aber ich bin nunmal in einer Linuxumgebung und irgendwie muss ich es ja lernen.
    Ich hoffe jetzt nur das irgendjemand dasselbe problem hatte, oder wenn nicht mir trotzdem geholfen werden kann.
     
  14. sinn3r

    sinn3r Law & Order
    Moderator

    Dabei seit:
    28.12.2006
    Beiträge:
    2.764
    Zustimmungen:
    0
    Ort:
    Wentorf
    http://wiki.ubuntuusers.de/Programme_kompilieren
    Mal durchlesen, auch die weiteren Links da, mit Glück kannst du das ganze wieder entfernen und es nochmal über den Manager versuchen, wenn das nicht gehen sollte, bitte Fehlermeldung.
    Full ack ;)
    Ist sicher zu schaffen, aber einfach was kompilieren nach irgendwelchen Howtos ist immer eine sehr schlechte Idee, gerade wenn man neu ist.
    Nun kommen bestimmt gleich die, die sagen das man das ja mal lernen muss.
    Sicher, aber wenn erstmal ein Einblick kriegen will, reicht der Manager ;)
     
Thema:

NIS-server

Die Seite wird geladen...

NIS-server - Ähnliche Themen

  1. Leere Liste im Anmeldemanager unter SuSE10.1 mit NIS-Server

    Leere Liste im Anmeldemanager unter SuSE10.1 mit NIS-Server: Hallo, ich habe im Sommer meine 22 Clients von SuSE 9.3 auf 10.1 durch Neuinstallation upgedatet. Die Clients holen sich /home und...