NFS Blockieren beim Schreiben verhndern

Dieses Thema im Forum "Web- & File-Services" wurde erstellt von Fux, 27.12.2007.

  1. Fux

    Fux Jungspund

    Dabei seit:
    05.01.2007
    Beiträge:
    22
    Zustimmungen:
    0
    Hallo zusammen!

    Folgende Situation:

    Server mit NFS-Server, dessen HDs nach einer Stunde ohne Akktivität herunterfahren (SpinDown). (Root-Partition auf anderer HD, die nicht herunterfährt).

    Schreibt man während die HDs down sind lokal oder per SCP, so werden die HDs im Hintergrund hochgefahren während der Kopiervorgang läuft.

    Versucht man das gleiche jedoch auf einem NFS-Mount, so blockt dieser, bis die HDs hochgefahren sind. Obwohl im Cache auf dem Server genug Platz wäre.

    Die NFS-Optionen auf dem Server (/etc/exports) lauten :

    rw,root_squash,async,no_wdelay,no_subtree_check

    auf dem Client:

    rw,v3,rsize=32768,wsize=32768,soft,udp,nolock.

    Weiß jemand, wie ich NFS dazu bringe, zunächst in den Cache zu schreiben und nicht zu blockieren?

    Vielen Dank im Voraus!
    Fux
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. sinn3r

    sinn3r Law & Order
    Moderator

    Dabei seit:
    28.12.2006
    Beiträge:
    2.764
    Zustimmungen:
    0
    Ort:
    Wentorf
    OT:
    Ob das so gut für die Platten ist?
     
  4. Fux

    Fux Jungspund

    Dabei seit:
    05.01.2007
    Beiträge:
    22
    Zustimmungen:
    0
    Ja, ist es. Das ist ein kleiner Homeserver, dessen HDs nur ein- bis zweimal am Tag aktiviert werden. Das ganze läuft soweit - bis auf die beschriebene Verzögerung - seit mehreren Jahren gut.


    Grüße
    Fux
     
  5. sinn3r

    sinn3r Law & Order
    Moderator

    Dabei seit:
    28.12.2006
    Beiträge:
    2.764
    Zustimmungen:
    0
    Ort:
    Wentorf
    Stimmt ok, bin jetzt davon ausgegangen, dass der server unter häufigen zugriffen steht ;)
     
  6. #5 slackfan, 27.12.2007
    slackfan

    slackfan König

    Dabei seit:
    18.04.2006
    Beiträge:
    809
    Zustimmungen:
    0
    Ort:
    Bonn
  7. #6 bitmuncher, 27.12.2007
    bitmuncher

    bitmuncher Der Stillgelegte

    Dabei seit:
    08.05.2007
    Beiträge:
    3.171
    Zustimmungen:
    0
    Da no_wdelay gesetzt ist, dürfte hier das Problem zu suchen sein. Ausserdem solltest du synchronisiertes schreiben (anstelle von async einfach sync) aktivieren, damit der HD-Cache auch genutzt wird. Soweit ich informiert bin, sorgt async dafür, dass der Schreibvorgang nicht über den Cache synchron gehalten wird. Ausserdem ist async nicht gerade anzuraten, wenn paralllele Schreibzugriffe erfolgen.
     
  8. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  9. Fux

    Fux Jungspund

    Dabei seit:
    05.01.2007
    Beiträge:
    22
    Zustimmungen:
    0
    Hallo zusammen,

    vielen Dank für die Tipps soweit!

    In Bezug auf die no_wdelay Option, die ich mal irgendwoher übernommen hatte, gab es offensichtlich ein Verständnis-Problem meinerseits: Ich habe es so verstanden, daß Schreibzugriffe nicht zu Verzögerungen führen sollten. Aber offensichtlich ist es genau anders herum - die Option wdelay (die der Standard zu sein scheint) führt dazu, daß Schreibzugriffe der Clients erst verzögert auf die Platten geschrieben werden.

    Das hat insoweit schonmal geholfen.

    Ob soft oder hard besser ist, versuche ich gerade herauszufinden.

    @bitmuncher:

    Eine Rückfrage hätte ich zu der Option[a]sync: Laut Man-Page soll async die höhere Performance bieten, da Schreibzugriffe gecached werden.

    Du schreibst, daß sync die bessere Wahl wäre. Das hat mich jetzt etwas irritiert. Woher hast du das mit dem Plattencache?

    Grüße
    Fux
     
  10. #8 bitmuncher, 31.12.2007
    bitmuncher

    bitmuncher Der Stillgelegte

    Dabei seit:
    08.05.2007
    Beiträge:
    3.171
    Zustimmungen:
    0
    Meine Erfahrung hat mir gezeigt, dass beim Benutzen von async die Daten verloren waren, wenn der Client die Verbindung trennte. Das zeigte mir, dass offenbar nicht der HD-Cache des Servers genutzt wurde, da dann ein Ausführen von 'sync' die Daten auf die HD geschrieben hätte, was aber nicht der Fall war. Bei meiner Nachfrage auf dem Linux-Channel im Undernet wurde mir das dann bestätigt.
     
Thema:

NFS Blockieren beim Schreiben verhndern

Die Seite wird geladen...

NFS Blockieren beim Schreiben verhndern - Ähnliche Themen

  1. Mozilla: Drei Prinzipien für das Blockieren von Inhalten

    Mozilla: Drei Prinzipien für das Blockieren von Inhalten: Mozilla beobachtet nach eigenen Angaben die aktuellen Entwicklungen beim Blockieren von Inhalten und hat nun drei Prinzipien vorgeschlagen, die...
  2. Microsoft lässt Torrent-Links zu Apache OpenOffice blockieren

    Microsoft lässt Torrent-Links zu Apache OpenOffice blockieren: Jede Woche erhält Google Millionen an Anfragen zum Blockieren von Links zu urheberrechtlich geschütztem Material nach dem »Digital Millennium...
  3. Microsoft lässt Torrent-Links zu Apache Open Office blockieren

    Microsoft lässt Torrent-Links zu Apache Open Office blockieren: Jede Woche erhält Google Millionen an Anfragen zum Blockieren von Links zu urheberrechtlich geschütztem Material nach dem »Digital Millennium...
  4. amavis extension blockieren

    amavis extension blockieren: Hallo, ich möchte auf mein mailserver mittels amavis gewisse dateienendungen z.B. exe, mp3, ... blockieren. Im mail.log sehe ich bei eingehender...
  5. Sendmail gefälschte Absender blockieren

    Sendmail gefälschte Absender blockieren: Hi, kleine Frage, wie kann ich bei Sendmail es verhindern, dass Spammer unsere Domain nehmen um Mails einzuliefern? Beispiel: Die domain...