MySql Socken wech'

Dieses Thema im Forum "Debian/Ubuntu/Knoppix" wurde erstellt von alex_zeitreise, 14.12.2005.

  1. #1 alex_zeitreise, 14.12.2005
    alex_zeitreise

    alex_zeitreise Grünschnabel

    Dabei seit:
    11.12.2005
    Beiträge:
    8
    Zustimmungen:
    0
    Ort:
    Heigenbrücken
    Hallo, großes Problem aber leider keine Lösung:
    Habe heute von 3.0 auf 3.1 Upgedatet, phpmyadmin, syscp installiert
    Der Mysql Server ging mal^^


    daemon.log:
    syslog:
    In: /var/run/mysqld/mysqld.sock sind keine Dateien


    Wie bekomm ich den das wieder hin? Fang gleich zu Heulen.

    Nachtrag:

    vserver123:~# mysql_fix_privilege_tables
    ... Den Tränen nah'
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
    In /etc/mysql/debian.cnf steht der Socket-Path drin. Schau mal, ob der korrekt gesetzt ist und dahin verweist, wo mysqladmin den sucht. Muesste dann wie folgt aussehen:

    socket = /var/run/mysqld/mysqld.sock

    Wenn dem nicht so ist, einfach den Eintrag entsprechend anpassen und die MySQL nochmal neu starten.

    Nachtrag: Wichtig ist auch, dass das Verzeichnis /var/run/mysqld dem User mysql und der Gruppe root gehoert.
     
  4. #3 alex_zeitreise, 14.12.2005
    Zuletzt bearbeitet: 14.12.2005
    alex_zeitreise

    alex_zeitreise Grünschnabel

    Dabei seit:
    11.12.2005
    Beiträge:
    8
    Zustimmungen:
    0
    Ort:
    Heigenbrücken
    /etc/mysql/debian.cnf
    vserver123:~# chown mysql:root /var/run/mysqld
    hatte ich ausgeführt


    und im gleichen ordner liegt noch die
    debain-start

     
  5. theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
    Dann fueg mal die oben genannte Zeile in die debian.cnf am Ende ein.
     
  6. #5 alex_zeitreise, 14.12.2005
    alex_zeitreise

    alex_zeitreise Grünschnabel

    Dabei seit:
    11.12.2005
    Beiträge:
    8
    Zustimmungen:
    0
    Ort:
    Heigenbrücken
    Gemacht!
    Dann das:
     
  7. theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
    Was sagen denn die /var/log/mysql.err und die /var/log/mysql.log?
     
  8. #7 alex_zeitreise, 14.12.2005
    alex_zeitreise

    alex_zeitreise Grünschnabel

    Dabei seit:
    11.12.2005
    Beiträge:
    8
    Zustimmungen:
    0
    Ort:
    Heigenbrücken
    /var/log/mysql.log

    /var/log/mysql/mysql.err
    /var/log/mysql.err Dateigröße 0

    Das er so ab 10:00 Uhr nicht mehr loggt ? hhhmm da ging es noch, irgendwann um die Zeit hab ich dann SysCp, WebMin etc. Installiert
     
  9. theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
    Hmm, also das letzte, was mir da noch einfallen wuerde, waere, dass das Passwort fuer debian-sys-maint fuer die aktuelle Installation nicht stimmt. Sichere mal dein Datenverzeichnis der MySQL, deinstalliere die MySQL mit --purge, ueberpruefe, dass auch wirklich alle Konfigs geloescht wurden und installiere die MySQL dann wieder neu. Danach nur noch die Datenbanken (also den Inhalt des Datenverzeichnisses) zurueckspielen und die MySQL starten, um zu sehen, ob es dann wieder geht.
    Ansonsten besorge dir ne Binary-Version von mysql.com, installiere die wie empfohlen und spiele den Inhalt deines MySQL-Datenverzeichnisses in das Datenverzeichnis der neuen MySQL. Danach nur noch das Init-Skript austauschen und die MySQL starten.
     
  10. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  11. #9 alex_zeitreise, 14.12.2005
    Zuletzt bearbeitet: 14.12.2005
    alex_zeitreise

    alex_zeitreise Grünschnabel

    Dabei seit:
    11.12.2005
    Beiträge:
    8
    Zustimmungen:
    0
    Ort:
    Heigenbrücken
    Kann ich die Binary auch "drüber installieren" ...?

    Irgendwie sieht halt das Image eh' nicht so gut aus. Das ist glaube ich eine
    angepasse Confixx Version.
    Soll ich das init.d/mysql script sichern und dann erneut einspielen ?

    Naja. ob ich ---purge machen kann ? Dazu muss der doch den Daemon neu laden das geht doch nicht. (Zumindest beim --install zickt er)


    Dumm Frag: Ist das schuld ?


    ln /var/run/mysqld/mysqld.sock /var/spool/postfix/var/run/mysqld/mysqld.sock

    SysCp Punkt 2.2 http://www.syscp.de/docs/faq/german
     
  12. theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
    Moeglich, glaube ich aber nicht, dass das daran Schuld ist.
    Die Binary-Version kannst du nicht drueber installieren, da diese in einem einzigen Ordner liegt und nicht, wie unter Debian ueblich verteilt aufs /usr-Verzeichnis. Wenn du die Binary-Version installierst, findest du da drin irgendwo nen Skript namens mysql.server, das du einfach nach /etc/init.d/ kopierst. Damit es aber richtig funktioniert, muss die Binary-Version nach /usr/local/mysql entpackt werden. Wichtig ist, dass du vor dem Deinstallieren der Debian-Version dein MySQL-Datenverzeichnis sicherst, also das Verzeichnis, wo die DBs drin liegen.
    Im Zweifelsfall kannst du mit dpkg deinstallieren, da gibts bestimmt force-Optionen. Siehe dazu auch 'man dpkg', hab die Optionen jetzt nicht alle im Kopf.
    Confixx war schon immer Muell und dahin sollte man es auch werfen *find*. Ich vermute also mal, dass es sich um einen Root-Server handelt. :)

    Schnellste Loesung duerfte also sein:
    1. MySQL-Binary-Version downloaden
    2. Nach /usr/local entpacken
    3. Das so entstandene Verzeichnis /usr/local/mysql-<version> nach /usr/local/mysql verlinken
    4. Start-Skript der Binary-Version nach /etc/init.d/ kopieren
    5. Datenbanken von /var/lib/mysql nach /usr/local/mysql/data kopieren
    6. Debian-Version von MySQL deinstallieren (im Zweifel mit force-Option)
    7. /etc/init.d/mysql irgendwohin als Backup verschieben (hauptsache es bleibt nicht im init.d)
    8. '/etc/init.d/mysql.server start' ausfuehren
    9. /usr/local/mysql/bin/* nach /usr/local/bin/ verlinken, damit dir die ganzen MySQL-Tools (mysqladmin usw. im PATH zur Verfuegung stehen), alternativ /usr/local/mysql/bin in den PATH aufnehmen

    Hoffe, dass ich jetzt nichts vergessen habe, aber danach sollte eigentlich alles wieder laufen.
     
Thema:

MySql Socken wech'

Die Seite wird geladen...

MySql Socken wech' - Ähnliche Themen

  1. Keine passenden MySQL Socken

    Keine passenden MySQL Socken: _
  2. Freelancer gesucht - Debian / MySQL / Pearl / PHP - Erfahrung

    Freelancer gesucht - Debian / MySQL / Pearl / PHP - Erfahrung: Hallo, suche einen Freelancer für einen Webdienst... mit obigen Kenntnissen! Bitte Stundensatz mit Kurzbeschreibung mitteilen. NOCH WAS: Also...
  3. MySQL 5.7 angekündigt

    MySQL 5.7 angekündigt: Oracle hat MySQL 5.7 in der offiziellen Version angekündigt. Das populäre freie Datenbanksystem wird in Version 5.7 bei bestimmten Abfragen...
  4. MySQL 5.7 angekündigt

    MySQL 5.7 angekündigt: Oracle hat MySQL 5.7 in der offiziellen Version angekündigt. Das populäre freie Datenbanksystem wird in Version 5.7 bei bestimmten Abfragen...
  5. mysql Select Abfrageergebnis in unterschiedlichen Variablen sichern

    mysql Select Abfrageergebnis in unterschiedlichen Variablen sichern: Hallo zusammen, es geht um folgenden Teil meiner .sh-Datei: NumberCheck=`mysql $SQL_ARGS "SELECT lkw, Firma FROM adb_group WHERE...