Munin Plugin port_ssh gibt 0 zurück

Dieses Thema im Forum "Debian/Ubuntu/Knoppix" wurde erstellt von Strubbl, 15.07.2008.

  1. #1 Strubbl, 15.07.2008
    Strubbl

    Strubbl Grünschnabel

    Dabei seit:
    02.02.2007
    Beiträge:
    3
    Zustimmungen:
    0
    Hallo,
    ich habe zwei identische Ubuntu hardy Server. Auf beiden ist munin eingerichtet. Ich hab das Plugin das ich im Betreff genannt habe, installiert. Das soll mittels munin die SSH-verbindungen zu den Servern beobachten.
    Auf dem einen Server A funktioniert es auch super. Nur auf dem anderen B wird ständig ein 0-Graph gezeichnet, also angeblich gibt es auf den Server nie eine SSH-Verbindung. Ich habe schon so einiges probiert, aber ich komme einfach nicht weiter.


    Ich poste mal ein paar ausgaben, während zu jedem Server eine SSH-Verbindung aufgebaut ist:
    auf dem server A, wo es funktioniert:
    Code:
    /etc/munin/plugins$ ./port_ssh 
    count.value 1
    auf dem Server B, wo es nicht funktioniert
    Code:
    /etc/munin/plugins$ ./port_ssh 
    count.value 0
    noch eine Ausgabe von Server A:
    Code:
    cat /proc/net/tcp6
      sl  local_address                         remote_address                        st tx_queue rx_queue tr tm->when retrnsmt   uid  timeout inode
    dann im Unterschied zum Server B:
    Code:
    cat /proc/net/tcp6 
      sl  local_address                         remote_address                        st tx_queue rx_queue tr tm->when retrnsmt   uid  timeout inode
       0: 00000000000000000000000000000000:DD92 00000000000000000000000000000000:0000 0A 00000000:00000000 00:00000000 00000000     0        0 3349808 1 de812000 300 0 0 2 -1
       1: 0000000000000000FFFF0000054C5EC2:DD92 0000000000000000FFFF0000E7485EC2:0810 01 00000000:00000000 02:000678A5 00000000     0        0 3344517 3 de812580 21 4 17 3 -1
    Also muss es doch irgendwo eine Config geben, die nicht gleich ist. Nur welche ist das? Und diese scheint der Grund dafür zu sein, dass das munin-Plugin für ssh auf dem einen Server nicht funktioniert...

    Kann mir jemand weiterhelfen? Evtl, wie ich dem Plugin näher kommen kann?
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
Thema:

Munin Plugin port_ssh gibt 0 zurück

Die Seite wird geladen...

Munin Plugin port_ssh gibt 0 zurück - Ähnliche Themen

  1. Munin RRDCached

    Munin RRDCached: Hi, ich möchte munin auf einer CentOs 6 Maschine so configurieren dass die graphen mit rrdcached gebildet werden. Leider habe ich nur ein HowTo...
  2. squid und munin: keine Daten

    squid und munin: keine Daten: Hallo, OpenSuSE 10.3 munin 1.2.5 squid 2.6.STABLE14 Ich habe die squid-Plugins: squid_traffic, squid_cache und squid_requests aktiviert....
  3. Munin installation spinnt ?!?!

    Munin installation spinnt ?!?!: Hi Leute, ich habe irgendwie das Gefühl, das die Munin-packages in dem Ubuntu-Repo nicht mehr wirklich funktionieren. Angefangen hat es, das ich...
  4. Munin und memcached überwachen.

    Munin und memcached überwachen.: Hallo Leute, ich versuche gerade irgendwie das memcached script zum laufen zu bekommen. Allerdings geht nichts ... also ich hab alle benötigten...
  5. munin fragt keine nodes ab

    munin fragt keine nodes ab: Hi Leute, ich habe das Problem das der munin-cron sich mit keiner node zum Abfragen der Werte verbinden will. Ich steh echt auf dem Schlauch und...