Module wollen nicht geladen werden

Dieses Thema im Forum "Gentoo" wurde erstellt von bartlaby, 29.12.2003.

  1. #1 bartlaby, 29.12.2003
    bartlaby

    bartlaby Tripel-As

    Dabei seit:
    18.02.2003
    Beiträge:
    150
    Zustimmungen:
    0
    Ort:
    Haren, Niedersachsen (Immer dem Schnaps nach)
    Hi
    nun folgt ein Problem, dass ich schon seit eh und je mit Gentoo (teilweise auch Linux allgemein) hatte:
    Die Module wollen einfach nicht geladen werden.
    lsmod zeigt keine module an und per modprobe kann ich auch keine laden. Derzeitiger Versuchskernel auf meinem Server: 2.6.0 (bzw. development-sources aus portage)
    folgende fehlermeldung erhalte ich zum Beispiel bei iptabels (in webmin):
    installiert habe ich den kernel folgendermaßen:

    emerge development-sources
    make menuconfig
    make
    make modules_install

    danach reboot und in grub ausgewählt. allerdings kommen dann ne menge fehlermeldungen beim booten ähnlich der da oben von webmin. Wenn ich die /var/log/messages anhängen soll, sagt es mir.
    ich brauche :help: sons bringt mich das noch ummen verstand ;(
     
  2. Anzeige

    Schau dir mal diesen Ratgeber an. Viele Antworten inkl. passender Shell-Befehle!
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 lordlamer, 29.12.2003
    lordlamer

    lordlamer Haudegen

    Dabei seit:
    15.05.2003
    Beiträge:
    703
    Zustimmungen:
    0
    Ort:
    hamburg
    hi

    was hastn alles bei make menuconfig geändert?
    da musste doch dann iptables mit einbinden was bei dir nicht geschehen ist. das müsstest du nachholen und dann neu kompilieren.

    ich machs immer mit:
    make dep clean bzImage modules modules_install

    und dann bin ich fertig damit :)

    cui
     
  4. Aracon

    Aracon Routinier

    Dabei seit:
    12.10.2003
    Beiträge:
    438
    Zustimmungen:
    0
    Ich glaube es liegt daran, dass du deine module-init-tools nicht aktuleisiert hast.
     
  5. #4 bartlaby, 29.12.2003
    bartlaby

    bartlaby Tripel-As

    Dabei seit:
    18.02.2003
    Beiträge:
    150
    Zustimmungen:
    0
    Ort:
    Haren, Niedersachsen (Immer dem Schnaps nach)
    die module-init-tools habe ich manuell aktualisiert und bei emerge -p development-sources wollte er die auch nicht mehr mitinstallieren. daher gehe ich davon aus, dass ich die aktuellsten module-init-tools und modutils habe.
    @lordlamer:
    das war doch aber die Vorgehensweise von der Kernel 2.4er Reihe. Ich hab sonst immer gehört, dass ab Kernel 2.6 man nur noch "make - make modules_install" machen muss.
    und zu iptables: ich versteh nicht, was du meinst. ich habe ip_tables mit eingebunden. allerdings noch nichtmal als modul, sondern fest einkompiliert.
     
  6. chuck

    chuck die bloede kuh

    Dabei seit:
    28.08.2003
    Beiträge:
    33
    Zustimmungen:
    0
    hast du den modul support in den kernel ein kompeliert?
     
  7. #6 bartlaby, 29.12.2003
    bartlaby

    bartlaby Tripel-As

    Dabei seit:
    18.02.2003
    Beiträge:
    150
    Zustimmungen:
    0
    Ort:
    Haren, Niedersachsen (Immer dem Schnaps nach)
    jep is drin
    bei Loadable Module support siehts so aus:
    [*] Enable loadable module support
    [*] Module unloading
    [ ] Forced module unloading
    [ ] Module versioning support (EXPERIMENTAL)
    [*] Automatic kernel module loading
     
  8. #7 HangLoose, 29.12.2003
    HangLoose

    HangLoose kleiner Bruder von ruth

    Dabei seit:
    07.11.2003
    Beiträge:
    319
    Zustimmungen:
    0
    Ort:
    HH
    wenn du iptables fest im kernel drin hast, können sie natürlich auch nicht als modul geladen werden. oder steh ich jetzt völlig auf'm schlauch ?(


    Gruß HL
     
  9. #8 bartlaby, 30.12.2003
    bartlaby

    bartlaby Tripel-As

    Dabei seit:
    18.02.2003
    Beiträge:
    150
    Zustimmungen:
    0
    Ort:
    Haren, Niedersachsen (Immer dem Schnaps nach)
    hab das problem mit bissl biegen und bissl brechen behoben
    hab module-init-tools komplett deinstalliert (per unmerge und nochmal von hand) und dann neu installiert. jetzt tuts
     
Thema:

Module wollen nicht geladen werden

Die Seite wird geladen...

Module wollen nicht geladen werden - Ähnliche Themen

  1. Git 2.8 unterstützt paralleles Laden von Submodulen

    Git 2.8 unterstützt paralleles Laden von Submodulen: Mit der Freigabe von Git 2.8.0 haben die Entwickler das Quellcode-Verwaltungssystem um diverse neue Funktionen ergänzt. Die wohl prominenteste...
  2. SFC hält Auslieferung von binären ZFS-Modulen für GPL-Verletzung

    SFC hält Auslieferung von binären ZFS-Modulen für GPL-Verletzung: Die Software Freedom Conservancy hält Canonicals Plan, das Dateisystem ZFS als binäres Modul ab Ubuntu 16.04 mitzuliefern, für eine...
  3. Raspberry Pi und Linux für Solarmodule

    Raspberry Pi und Linux für Solarmodule: Die auf den Bau und Betrieb von Solarkraftwerken spezialisierte Storm Energy GmbH aus Nürnberg verbaut in ihrem neuen SunSniffer ein Raspberry Pi...
  4. CoMo-Booster für RPi Compute Module

    CoMo-Booster für RPi Compute Module: Vor wenigen Wochen hat die Raspberry Pi Foundation ihren Platinenrechner als Compute Module in den Handel gebracht, eine Platine aud RPi-Basis,...
  5. RPi Compute Module für industrielle Nutzer

    RPi Compute Module für industrielle Nutzer: Die Raspberry Pi Foundation hat im letzten Jahr am Design ihres Einplatinenrechners Raspberry Pi (RPi) gefeilt und den BCM2835-Prozessor, den 512...