media-libs/libdlna error

Dieses Thema im Forum "Gentoo" wurde erstellt von karloff, 12.11.2009.

  1. #1 karloff, 12.11.2009
    karloff

    karloff Routinier

    Dabei seit:
    09.07.2007
    Beiträge:
    317
    Zustimmungen:
    0
    Ort:
    ~/
    Moin,

    hab gerade nen komisches Problem wenn ich media-libs/libdlna compilieren will:

    Folgende Fehlermeldung
    Code:
    >>> Emerging (1 of 3) media-libs/libdlna-0.2.3 from sunrise
     * libdlna-0.2.3.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...                            [ ok ]
     * checking ebuild checksums ;-) ...                                                [ ok ]
     * checking auxfile checksums ;-) ...                                               [ ok ]
     * checking miscfile checksums ;-) ...                                              [ ok ]
    >>> Unpacking source...
    >>> Unpacking libdlna-0.2.3.tar.bz2 to /var/tmp/portage/media-libs/libdlna-0.2.3/work
    >>> Source unpacked in /var/tmp/portage/media-libs/libdlna-0.2.3/work
    >>> Compiling source in /var/tmp/portage/media-libs/libdlna-0.2.3/work/libdlna-0.2.3 ...
    Checking for compiler available...
    Checking for libavformat ...
    Error, can't find libavformat !
    See file "config.log" produced by configure for more details.
     * 
     * ERROR: media-libs/libdlna-0.2.3 failed.
     * Call stack:
     *               ebuild.sh, line   49:  Called src_compile
     *             environment, line  106:  Called die
     * The specific snippet of code:
     *       ./configure --prefix=/usr || die "./configure failed";
     *  The die message:
     *   ./configure failed
     * 
     * If you need support, post the topmost build error, and the call stack if relevant.
     * A complete build log is located at '/var/tmp/portage/media-libs/libdlna-0.2.3/temp/build.log'.
     * The ebuild environment file is located at '/var/tmp/portage/media-libs/libdlna-0.2.3/temp/environment'.
     * This ebuild is from an overlay named 'sunrise': '/usr/local/portage/layman/sunrise/'
     * 
    
    >>> Failed to emerge media-libs/libdlna-0.2.3, Log file:
    
    >>>  '/var/tmp/portage/media-libs/libdlna-0.2.3/temp/build.log'
    
    Soweit ja noch verständlich, unverständlich wird es erst bei:

    Code:
    ~ $ locate libavformat
    /usr/include/libavformat
    /usr/include/libavformat/avio.h
    /usr/include/libavformat/avformat.h
    /usr/lib/vlc/demux/libavformat_plugin.so
    /usr/lib/vlc/demux/libavformat_plugin.la
    /usr/lib/libavformat.so
    /usr/lib/libavformat.so.52
    /usr/lib/libavformat.so.52.31.0
    /usr/lib/pkgconfig/libavformat.pc
    /usr/lib/libavformat.a
    
    Allem anschein nach sind ist die lib ja doch da, wird allerdings nicht gefunden, weiß jemand rat, oder wie man rausbekommt wo er nachguckt damit man das ggf. umbiegen kann?
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 doc, 12.11.2009
    Zuletzt bearbeitet: 12.11.2009
    doc

    doc Kaffeetrinker

    Dabei seit:
    26.08.2006
    Beiträge:
    586
    Zustimmungen:
    0
    Ort:
    bremen
    hmmh vieleicht erwartet libdnla eine neuere version, aber der ebuild erzwingt diese nicht ...

    ich würde mal ffmpeg reemergen, wenns nicht geht eine version höher probieren etc...

    edit:

    nee, aber fast

    http://bugs.gentoo.org/show_bug.cgi?id=204007

    mit der aktuellen stable von ffmpeg lüppt das nicht ohne patch

    übrigens google hilft meistens :p
     
  4. #3 karloff, 13.11.2009
    karloff

    karloff Routinier

    Dabei seit:
    09.07.2007
    Beiträge:
    317
    Zustimmungen:
    0
    Ort:
    ~/
    Besten Dank, allerdings hab ich gegooglet aber nur müll gefunden ... o.O aber hab vergessen bei bugs.gentoo nachzuschauen ... wie dumm von mir ... - weniger kaffee tags über dann ist der kopf am abend auch noch fitt :oldman
     
Thema:

media-libs/libdlna error

Die Seite wird geladen...

media-libs/libdlna error - Ähnliche Themen

  1. postfix - fputs-error

    postfix - fputs-error: Ich hoffe, dass sich wer von euch mit postfix bzw. der Fehlermeldung auskennt. Ich habe nach dem Youtube-Video postfix eingerichtet: [MEDIA] Nun...
  2. journal commit I/O error auf SSD

    journal commit I/O error auf SSD: Hallo zusammen Habe meiner "Sun Ultra 45" (SPARC System) eine 64GB-SSD eingebaut, und dort das OS (Debian 7) installiert. In unregelmässigen...
  3. Kein Sound im Spiel - OpenAL error

    Kein Sound im Spiel - OpenAL error: Ich hab in einem Spiel leider keinen Sound. In der Konsole kommt in einer Endlosschleife immer diese Meldung: OpenAL error: 40964 (Audio_Tick...
  4. syntax error near unexpected token `&'

    syntax error near unexpected token `&': Hallo Ich habe ein Scrip angepasst bzw. erweiter und habe nun an einer Stelle ein Problem. Vor der erweiterung ist es einwandfrei...
  5. Update error für OpenSuse 12.3 für "libsolv-tools-0.3.2-2.14.1"

    Update error für OpenSuse 12.3 für "libsolv-tools-0.3.2-2.14.1": Hallo, ich kann mein OpenSuse 12.3 nicht mehr richtig updaten. beim versuch bekomme ich folgende Meldung: ( 1/23) Installing:...