LevelOne wpc-0101

Dieses Thema im Forum "Internet, lokale Netzwerke und Wireless Lan" wurde erstellt von h2owasser, 24.05.2003.

  1. #1 h2owasser, 24.05.2003
    Zuletzt bearbeitet: 24.05.2003
    h2owasser

    h2owasser Sxe Power User

    Dabei seit:
    07.12.2002
    Beiträge:
    491
    Zustimmungen:
    0
    So wie ich mich jetzt im Internet erkundet habe, gibt es Probleme mit dem Treiber der LevelOne wpc-0101. Peinlich dabei ist das Fakt, das sogar auf der Verpackung eine "Linux-Unterstützung" angegeben wird. In Realität erweist sich allersdings der Treiber auf der Mitgelieferten CD als ein für Redhat vorcompilierter Treiber.... toll. Auf der Hompage von Levelone steht garnichts über Linux und auf der Seite von Realtek kann man lediglich der Binärytreiber für Redhat8 runterladen. - Auch sehr aktuell.

    Falls jemand den Source Code für mich hat, dann bitte posten. Aber auch bitte keine Ratschläge, wie ich den Compilierten Treiber auf meinem Debian-System zum laufen bringe. Das ist sowieso Mist. thx.
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    Ich hab mir die karte auch zu testzecken gekauft !

    Unter Gentoo kein Thema.

    Du saugst dir den RTL8180 Treiber von der Realtek Seite -
    http://www.realtek.com.tw/downloads/downloads1-3.aspx?software=True&compamodel=RTL8180L

    das entpackst du ... passt das Makefile an (nur oben die Kernelversion eintragen!)
    dann "make" und fertig !

    Allerdings benötigst du noch "iwpriv" (war bei mir im packet wireless-tools)

    dann hast du in dem verzeichnis der Zip-Datei ./wlanup und ./wlandown

    funktioniert prima

    habe mir grade noch eine elsa MC11 mit Orinoco Gold Cipsatz zum Wardriven gekauft (im set mit einem AP 99 Euro bei eBay)

    Wenn es dann IRGENDWANN mal Linux Treiber für die 54MBit Karten gibt rüste ich auf :)


    -----------------------EDIT-------------------
    Da diese Karte keine von Kismet unterstützen Chipsatz hatt, ist sie eignetlich nur zum Netzwerkeinsatz gut.
    Wardriving ist leider nicht möglich :(
     
  4. #3 LinuxSchwedy, 27.10.2003
    LinuxSchwedy

    LinuxSchwedy ehem. Mod

    Dabei seit:
    12.12.2002
    Beiträge:
    1.797
    Zustimmungen:
    0
    Hi devilz,

    könntest du bitte ausführlicher beschreiben ?:]

    Ich habe jetzt auch eine Karte mit dem Chip. Die Datei habe ich entpackt und kompiliert. Klappte fehlerfrei. :) Gentoo halt ...

    Nur ich komme nicht weiter ...

    Kann ich iwpriv auch von Hand installieren ? Habe jetzt keinen direkten Anschluss an den Router ... Und die ganze Geschichte muss irgendwie eingerichtet sein, damit ich wlan nutzen kann. So eine Scheiße. :devil:
     
  5. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    emerge wireless-tools

    darinn sollte iwpriv sein ... dann mußt du damit die einstellungen für dein WLAN setzen ...
     
  6. #5 LinuxSchwedy, 27.10.2003
    LinuxSchwedy

    LinuxSchwedy ehem. Mod

    Dabei seit:
    12.12.2002
    Beiträge:
    1.797
    Zustimmungen:
    0
    man, bist du schnell :]

    ich kann jetzt kein emerge ausführen, weil unter gentoo kein netz ... :(
     
  7. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    Oh .. das ist schlecht ... das solltest du schon haben !
     
  8. #7 LinuxSchwedy, 30.10.2003
    LinuxSchwedy

    LinuxSchwedy ehem. Mod

    Dabei seit:
    12.12.2002
    Beiträge:
    1.797
    Zustimmungen:
    0
    @devilz,

    welche Einstellungen sind mit iwpriv zu machen ?
     
  9. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    Die wichtigsten Einstellungen für ein Wireless LAN sind ESSID, Mode, Frequency (bzw. Channel) und Encryption key. Wenn man einen (oder mehrere) AccessPoints ohne Verschlüsselung betreibt ist es unter Linux nur notwendig den Netzwerknamen (ESSID) zusetzen und den Modus auf Managed umzustellen. Der entsprechende AccessPoint wird automatisch gefunden und auch benutzt. Im Beispiel wäre der Netzwerkname
    "WIRELESS_LAN".

    notebook# iwconfig eth0 essid WIRELESS_LAN
    notebook# iwconfig eth0 mode managed


    Das setzen der Frequency (bzw. Channel) ist unter Linux im Managed Modus nicht erlaubt. Hier wird standardmäßig der Kanal 3 benutzt, was einer Frequenz von 2.422GHz entspricht.

    Ein Wireless LAN sollte immer mit eine WEP128 Verschlüsselung betrieben werden und somit ist es natürlich notwendig dem Treiber den Schlüssel mitzuteilen. Standardmäßig können die Wireless LAN Karten vier verschiedene Schlüssel gleichzeitig speichern, wovon eine aber nur aktive sein kann. Karten mit WEP64 und WEP128 Verschlüsselung unterstützen sowohl 40-Bit (5 Zeichen) wie auch 104-Bit (13 Zeichen) lange Schlüssel. Man kann die Schlüssel als Hex-Wert oder auch als Zeichenkette angeben. Bei der Angabe als Zeichenkette ist ein "s:" voranzustellen. Ob es sich um einen WEP64 oder WEP128 Schlüssel handelt unterscheidet das Programm iwconfig automatisch an der Länge der Eingabe. Die Position im Kartenspeicher wird ein eckigen Klammern hinter dem Schlüssel angegeben. Nur die Positionsangabe aktiviert den Schlüssel.

    notebook# iwconfig eth0 key s:abcde [1]
    notebook# iwconfig eth0 key s:abcdefghijklm [2]
    notebook# iwconfig eth0 key 6162636465666768696A6B6C6D [3]
    notebook# iwconfig eth0 key [3]

    Natürlich kann man sich auch die aktuell gespeicherten Schlüssel anzeigen lassen. Hierfür muss man das Programm iwlist benutzen. Der aktuell benutzte Schlüssel erscheint auch in der Auflistung von iwconfig.

    notebook# iwlist eth0 keys
    eth0 2 key sizes : 40, 104bits
    4 keys available :
    [1]: 6162-6364-65 (40 bits)
    [2]: 6162-6364-6566-6768-696A-6B6C-6D (104 bits)
    [3]: 6162-6364-6566-6768-696A-6B6C-6D (104 bits)
    [4]: off
    Current Transmit Key: [3]

    Nun kann das Interface mit ifconfig und route konfiguriert werden und man kann die Arbeit im Netzwerk beginnen. Mit Hilfe von dhcpcd oder dhcpclient kann ein DHCP Server zur Konfiguration herangezogen werden.

    notebook# ifconfig eth0 192.168.0.100 netmask 255.255.255.0
    notebook# route add default gw 192.168.0.1



    Mehr unter http://www.holtmann.org/linux/wlan/

    oder

    http://www.hpl.hp.com/personal/Jean_Tourrilhes/Linux/
     
  10. #9 LinuxSchwedy, 30.10.2003
    Zuletzt bearbeitet: 30.10.2003
    LinuxSchwedy

    LinuxSchwedy ehem. Mod

    Dabei seit:
    12.12.2002
    Beiträge:
    1.797
    Zustimmungen:
    0
    Danke devilz. :)

    Ich wusste, dass ich mich auf dich verlassen kann. :respekt:

    Ich werde mich morgen drum kümmern (bin jetzt zu kaputt dafür) ...

    PS: Warum findet man solche Infos auf deutsch nicht im Netz ? ... auch wenn man lange googlt ? :rolleyes:
     
  11. #10 LinuxSchwedy, 01.11.2003
    LinuxSchwedy

    LinuxSchwedy ehem. Mod

    Dabei seit:
    12.12.2002
    Beiträge:
    1.797
    Zustimmungen:
    0
    @devilz

    Ich konnte unter Slackware und Gentoo den Realtek-Treiber ohne Fehler kompilieren. Auch mit modprobe (#modprobe rtl8180_24x ) konnte ich die Module fehlerfrei laden. Slackware lädt dieses Modul sogar beim Booten automatisch (da kommen mind. 12 Zeilen ...).

    Unter Gentoo habe ich z.B. das Modul in das Verzeichnis /lib/module/kenel-.../driver/net (...oder so) hineinkopiert.

    Nur wenn ich bei beiden #ifconfig oder #iwconfig eingebe, wird die Netzwerkkarte gar nicht aufgelistet. Also eth0 wird gar nicht erkannt !:(

    Da eth0 nicht da ist, kann ich natürlich auch keine Einstellungen mit iwpriv machen. :devil:

    Kannst du oder jemand andere mir weiterhelfen ?

    PS: Hier ist eine noch genauere Beschreibung des Problems
     
  12. #11 LinuxSchwedy, 02.11.2003
    LinuxSchwedy

    LinuxSchwedy ehem. Mod

    Dabei seit:
    12.12.2002
    Beiträge:
    1.797
    Zustimmungen:
    0
    Kann mir wirklich keiner helfen ? Hat echt keiner WLan am Laufen ? :(

    Ich bin frustriert, weil ich weder mit SuSE noch mit Gentoo noch mit Slackware ins Internet kann. X(

    Unter Win2k ( wo ich grad gezwungenermassen arbeite ... ) gab es keine Probleme mit dem USB-Stick und mit der WLAN-PCI-Karte (mit dem Realtek-Chip) ... Ätzend ...
     
  13. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    Doch WLan schon ... nur deine Karte nicht :)

    Die Einstellungen hatte ich doch gepostet ....
     
  14. #13 LinuxSchwedy, 02.11.2003
    LinuxSchwedy

    LinuxSchwedy ehem. Mod

    Dabei seit:
    12.12.2002
    Beiträge:
    1.797
    Zustimmungen:
    0
    Ja das stimmt, die Einstellungen hast du gepostet ...

    Ich habe aber, obwohl die Treiber fehlerfrei kompiliert sind und ein Modul existiert (siehe oben), kein eth0 im System ... :( :rolleyes:

    Deswegen kann ich keine Einstellungen mit iwpriv machen. :devil:
     
  15. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  16. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    wlan0 existiert auch nicht ?
     
  17. #15 LinuxSchwedy, 02.11.2003
    LinuxSchwedy

    LinuxSchwedy ehem. Mod

    Dabei seit:
    12.12.2002
    Beiträge:
    1.797
    Zustimmungen:
    0
    Doch wlan0 ja und zwar, wenn man iwconfig eingibt.
     
Thema:

LevelOne wpc-0101

Die Seite wird geladen...

LevelOne wpc-0101 - Ähnliche Themen

  1. Levelone USB Wlan Adapter und Suse 10

    Levelone USB Wlan Adapter und Suse 10: Hi, bin totaler Neuling mit Linux, habe mir Suse 10 vor 2 Tagen installiert und wollte nun mal meinen USB Wlan Adapter, WNC-0301, von Levelone...
  2. LevelOneWNC-0301 und (Arcor)Prestige660 vertragen sich nicht

    LevelOneWNC-0301 und (Arcor)Prestige660 vertragen sich nicht: Hallo Allerseits, ich schlage mich jetzt seit gut einer Woche mit einem zickigen LevelOneWNC-0301 USB-Wlan-Stick und dessen verbindung zum...
  3. LevelOne WNC-0300USB unter SUSE 9.0

    LevelOne WNC-0300USB unter SUSE 9.0: Wie kriege ich mein WNC-0300USB unter SUSE (9.0) LINUX zum laufen? Unter Windoofs 98/2000 funktioniert alles (Netzwerk, Internet) bestens......
  4. Levelone unter Redhat 9 funzt net

    Levelone unter Redhat 9 funzt net: Levelone unter Redhat 9 funzt net RTL 8180 geht nicht!! Hallo hab da ein doofes Problem bin mehr oder weniger Linux Newbie aber überzeugter....