Kismet mit Atheros Karte

Dieses Thema im Forum "Anwendungen" wurde erstellt von z00k, 10.10.2006.

  1. #1 z00k, 10.10.2006
    Zuletzt bearbeitet: 11.10.2006
    z00k

    z00k I love my slack! Do u?

    Dabei seit:
    24.01.2005
    Beiträge:
    302
    Zustimmungen:
    0
    Ort:
    earth.getLocation("z00k");
    hey guys

    hab schon wieder ne neue wifi karte... diesmal eine TP-Link TL-WN610G mit dem Atheros chip AR5212 .
    dachte jetzt waere mein kismet horror (vorher broadcom user ;-) ) endlich vorbei, doch schon steht ein neues problem vor der tuer:
    habe die neusten madwifi treiber (v0.9.2) installiert und die karte funzt auch ohne probleme:
    Code:
    wifi0     no wireless extensions.
    
    ath0      IEEE 802.11g  ESSID:"scanme"  Nickname:"m0bile"
              Mode:Managed  Frequency:2.437 GHz  Access Point: 00:04:E2:D4:6B:60
              Bit Rate:54 Mb/s   Tx-Power:17 dBm   Sensitivity=0/3
              Retry:off   RTS thr:off   Fragment thr:off
              Encryption key:6A75-7374-6861-7665-326B-6E30-77   Security
    mode:restricted
              Power Management:off
              Link Quality=14/94  Signal level=-81 dBm  Noise level=-95 dBm
              Rx invalid nwid:58663  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:0   Missed beacon:0
    
    anschliessend hab ich kismet installiert und konfiguriert:

    Code:
    ...
    
    # User to setid to (should be your normal user)
    suiduser=z00k
    
    # Sources are defined as:
    # source=sourcetype,interface,name[,initialchannel]
    # Source types and required drivers are listed in the README under the
    # CAPTURE SOURCES section.
    # The initial channel is optional, if hopping is not enabled it can be used
    # to set the channel the interface listens on.
    # YOU MUST CHANGE THIS TO BE THE SOURCE YOU WANT TO USE
    source=madwifing_g,ath0,mysrc
    #source=madwifi_g,wifi0,mysrc2
    
    # Comma-separated list of sources to enable.  This is only needed if you defined
    # multiple sources and only want to enable some of them.  By default, all defined
    # sources are enabled.
    # For example:
    enablesources=mysrc
    
    ...
    
    wenn ich kismet nun starte kommt folgendes:

    Code:
    
    Server options:  none
    Client options:  none
    Starting server...
    Will drop privs to z00k (1000) gid 100
    Enabling channel hopping.
    Enabling channel splitting.
    Source 0 (mysrc): Enabling monitor mode for madwifing_g source interface
    ath0 channel 6...
    WARNING: ath0 appears to not accept the Madwifi-NG controls. Will attempt to
    configure it as a standard Madwifi-old interface. If you are using
    madwifi-ng, be sure to set the source interface to the wifiX control
    interface, NOT athX
    FATAL: 'get_mode' does not return integer parameters.
    Waiting for server to start before starting UI...
    
    
    JA natuerlich hab ich nach dieser meldung auch ausprobiert, den source auf folgendes zu stellen: source=madwifing_g,wifi0,mysrc

    bevor ich den madwifi-ng treiber versucht habe, hab ich alle options von oben auch mit dem 'normalen' madwifi treiber versucht:
    source=madwifi_g,ath0,mysrc
    oder
    source=madwifi_g,wifi0,mysrc

    nutze Slackware 10.2 mit kernel v2.6.17.9

    so ewig langer text hoffe habe nix wichtiges vergessen...

    kann mir irgendwer weiterhelfen? :hilfe2:

    gReetZ
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. z00k

    z00k I love my slack! Do u?

    Dabei seit:
    24.01.2005
    Beiträge:
    302
    Zustimmungen:
    0
    Ort:
    earth.getLocation("z00k");
    so fuer alle die es trotzdem noch interessiet, hab das problem mitlerweile selbst geloest indem ich einfach ein kernel update auf 2.6.18 gemacht hab und schon liefs...

    trotzdem macht die karte komischerweise immer noch einige zicken, da sie irgendwie nur manchmal (oder nur eine gewisse zeit) scannt und dann einfach aufhoert... dieses problem ist jedoch einfach mit einem simplen 'ifconfig ath0 down | ifconfig ath0 up' bzw restart zu beheben (zumindest fuer kurze zeit) :D

    gReeTz
     
Thema:

Kismet mit Atheros Karte

Die Seite wird geladen...

Kismet mit Atheros Karte - Ähnliche Themen

  1. Einrichtung von Kismet

    Einrichtung von Kismet: Hi, ich bin vor kurzem von Linux zu FreeBsd gewechselt, nachdem viele Dinge nicht so einfach zu konfigurieren waren wie unter Linux, sind...
  2. Kismet zeigt keine Netztwerke an (Mac OS X)

    Kismet zeigt keine Netztwerke an (Mac OS X): Hi, nein ich meine nicht das knacken von Netzwerken:D Sondern Kismet allgemein:)) Also: Ich hab ein MacBook Pro (MacBookPro5,5) MacPorts,...
  3. Kismet findet kein Netzwerk

    Kismet findet kein Netzwerk: Hi, ich bin zu Testzwecken auf SUSE 11.0 umgestiegen. Ich möchte mit Kismet nem Bekannten zeigen, dass er mit seiner WEP-Verschlüsselung nicht...
  4. gkismet

    gkismet: hi, also wieder titel schon sagt versuch eich rgade gkismet ans laufen zu kriegen :)) alerdings wenn ich ins terminal gkismet eingebe spuckt er...
  5. kismet/Wlan problem

    kismet/Wlan problem: Hi Leute, ich bin kompletter Anfänger was Linux angeht, daher schon mal im vorraus sry, wenn ich nicht glei alles auf anhieb verstehe^^ Nun zu...