KDE-Stil für gtk-Apps will nich...

Dieses Thema im Forum "KDE" wurde erstellt von gropiuskalle, 12.09.2007.

  1. #1 gropiuskalle, 12.09.2007
    gropiuskalle

    gropiuskalle terra incognita

    Dabei seit:
    01.07.2006
    Beiträge:
    4.857
    Zustimmungen:
    0
    Ort:
    Berlin
    Bei mir funktioniert die optische Anpassung von gtk-Anwendungen wie Gimp nicht so wie ich will bzw. eigentlich sogar überhaupt nicht. Wenn ich gtk-Kisten starte, erscheinen sie in einem superhäßlichen Austerngrau, was ja eigentlich nicht so wild wäre (bei Firefox und Thunderbird verwende ich z.B. ein anders Theme, dadurch kommt das nicht zum Tragen), zumal die meisten von mir benutzten Proggies auf KDE setzen - manchmal nervt es aber doch, insbesondere bei Gimp, bei dessen Benutzung ich im ästhetischen Sinne vielleicht etwas sensibler bin. So sieht das aus:

    [​IMG]

    Und das sagt die Konsole:

    Code:
    kalle@hoppers:~> gimp
    
    (gimp:4537): Gtk-WARNING **: Unable to locate theme engine in module_path: "qtengine",
    
    (gimp:4537): Gtk-WARNING **: Unable to locate theme engine in module_path: "qtengine",
    
    (gimp:4537): Gtk-WARNING **: Unable to locate theme engine in module_path: "qtcurve",
    
    Zu den beiden Fehlermeldungen (welche auch von anderen gtk-Anwendungen ausgegeben werden) habe ich bei google einiges gefunden, z.B. wird zur Installation von 'gtk-qt-engine' und anschließender Konfiguration mittels KControl geraten ('KDE-Stil in GTK-Anwendungen verwenden'), was leider nichts brachte. Auch eine Reinstallation bzw. ein upgrade von glib fruchteten nicht.

    Das Ganze tritt seit meiner SuSE-Neuinstallation auf, und vielleicht spielt ja eine Rolle, dass ich dabei eine bereits bestehende /home-Partition eingebunden habe, wodurch ich einiges zu schrauben hatte (da die config-Dateien in /home z.T. nicht mehr passten), mittlerweile glaube ich jedoch, alles soweit passend gemacht zu haben.

    Nur eben diese Mist-Optik nicht. Hat jemand vielleicht noch 'ne Idee?
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    Welche GTK Version? Welche Gimp Version? Welche KDE Version?
    Updates über smart?

    Ich hatte eine weile GTK2 broken - nach einigen Smart updates lief es wieder ...
     
  4. #3 gropiuskalle, 12.09.2007
    gropiuskalle

    gropiuskalle terra incognita

    Dabei seit:
    01.07.2006
    Beiträge:
    4.857
    Zustimmungen:
    0
    Ort:
    Berlin
    GTK: 1.2.10-961.1

    GTK2: 2.10.11-9.3

    KDE: 3.5.7 release 74.2

    Gimp (unstable): 2.4.0rc2.0pm1

    Dass das ein unstable-release ist, spielt vermutlich keine Rolle, denn der bug tritt bei jeder gtk-Anwendung auf (und zwar bereits bevor ich Gimp-unstable installierte).

    Updates laufen über smart, die Kiste ist auf dem neuesten Stand und die optischen Fehler treten erst seit der Neuinstallation auf.
     
  5. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    Mal das gtk-theme gewechselt? Du scheinst noch das gtk-qt Theme zu verwenden.

    Kann sein das es broken ist ...
     
  6. #5 gropiuskalle, 12.09.2007
    gropiuskalle

    gropiuskalle terra incognita

    Dabei seit:
    01.07.2006
    Beiträge:
    4.857
    Zustimmungen:
    0
    Ort:
    Berlin
    Zumindest hat die durch Deinen Tipp angeregte De- und Reinstallation von Themes irgendwann dafür gesorgt, dass ich die Themes in KControl schon mal wechseln konnte und keine Fehlermeldungen mehr auftauchten. Nach einer weiteren Reinstallation von 'gtk-qt-engine' bewirkte dann wieder die Funktion 'KDE-Stil in GTK-Anwendungen verwenden' genau das besagte und der Fund des Paketes 'gtk2-engine-qtpixmap'...

    ...stellte mir netterweise dann auch noch die Funktion der farblichen Anpassung beider Umgebungen in KControl zur Verfügung (die sich allerdings nicht unter den GTK-Einstellungen befindet sondern schlicht und eigentlich ja auch logisch unter 'Farben'). Zwischendurch setzte ich in der Konsole jeweils den Befehl 'ldconfig' ab, den Tipp hatte ich aus 'nem Forum, wo es um ein ähnliches Problem ging.

    Und jetzt sieht es wieder Vernünftig aus hier. Warum auch immer. :)
     
Thema:

KDE-Stil für gtk-Apps will nich...

Die Seite wird geladen...

KDE-Stil für gtk-Apps will nich... - Ähnliche Themen

  1. SAMBA für Windows10 Domäne einrichten

    SAMBA für Windows10 Domäne einrichten: Hallo, ich habe letztes Wochenende verzweifelt versucht, Samba auf meinem Server einzurichten, daher versuche ich aktuell meinen Fehler zu...
  2. Empfehlung für Server Distribution

    Empfehlung für Server Distribution: Hallo, ich habe hier zu Hause einen kleinen Heimserver, auf welchem ich ein paar Daten für den Zugriff im Haus, einen kleinen Web Service für...
  3. Kleinigkeiten für Euch, mich nicht :-) pkg_add ; DVD rw mounten

    Kleinigkeiten für Euch, mich nicht :-) pkg_add ; DVD rw mounten: Hallo, ich habe 2 Problemchen. Ich kann nichts mehr installieren. Ich brauche aber unbedingt ein Brenn-Programm. Ein schönen Partitionierer usw....
  4. Welche Distri für Programming from the Ground Up

    Welche Distri für Programming from the Ground Up: Hallo! Ich möchter gerne das Buch Programming from the Ground Up durcharbeiten. savannah_nongnu_org/projects/pgubook/ Da geht es um Programmieren...
  5. Zeichen an Zeilenanfang für bestimmten Zeilenbereich einfügen

    Zeichen an Zeilenanfang für bestimmten Zeilenbereich einfügen: Hallo, ich würde gerne in einem Textdokument, z.B. von Zeile 10 - 18, an den Zeilenanfang ein # einfügen. Habe mir schon diverse Seiten zu SED...