Interner Lautsprecher ist still

Dieses Thema im Forum "Linux OS" wurde erstellt von Mitzekotze, 20.09.2007.

  1. #1 Mitzekotze, 20.09.2007
    Mitzekotze

    Mitzekotze little man

    Dabei seit:
    01.12.2006
    Beiträge:
    750
    Zustimmungen:
    0
    Servus zusammen,

    der interne Lautsprecher meines Toshiba Satellite a100-491 gibt im normalen Betrieb keinen Ton von sich. z.B. gibt das Programme "beep" oder die Bash keinen Piepton aus. In der config.gz ist der Treiber für den internen Lautsprecher als Modul gekennzeichnet:
    Code:
    CONFIG_INPUT_PCSPKR=m
    Aber trotz des geladenen Moduls pcsprk funktioniert der Lautsprecher nicht. Er ist aber trotzdem vorhanden, da ich im Grub Bootloader durch mehrmaliges drücken der Pfeiltasten ihm ein Piepsen entlocken konnte.

    Hat einer von euch eine Ahnung woran das liegen könnte?
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 Mitzekotze, 21.09.2007
    Mitzekotze

    Mitzekotze little man

    Dabei seit:
    01.12.2006
    Beiträge:
    750
    Zustimmungen:
    0
    Keiner eine Idee?
     
  4. #3 bitmuncher, 21.09.2007
    bitmuncher

    bitmuncher Der Stillgelegte

    Dabei seit:
    08.05.2007
    Beiträge:
    3.171
    Zustimmungen:
    0
    Im Grub kommt das Signal des PC-Speakers auch noch über das BIOS. Woran machst du denn fest, daß er nicht funktioniert?
     
  5. #4 Tomekk228, 21.09.2007
    Tomekk228

    Tomekk228 Lebende Foren Legende

    Dabei seit:
    14.08.2007
    Beiträge:
    2.417
    Zustimmungen:
    0
    Ort:
    /home/tomekk/
    Ich hab jetzt getestet was du meinst.

    Bei mir das selbe spiel, kein Piepton in der konsole oder sonst wo im System vom Notebook internen "beeper".

    Stört mich ehrlich gesagt auch nicht ;) Wieso solle er piepen hihi.

    Zu deinem Problem:
    Ich weiß noch aus Opensuse zeiten, das ich unter der Konsole von KDE bzw Opensuse einstellen konnte wo er ton ausgaben abgeben sollte, z.b soundserver/alsa usw.

    Vllt geht es mit deiner Konsole auch, google einfach mal dannach. Somit wäre es ein "work around" da ja die notebook lautsprecher ja auch im notebook sind *gg*
     
  6. #5 Gott_in_schwarz, 21.09.2007
    Zuletzt bearbeitet: 22.09.2007
    Gott_in_schwarz

    Gott_in_schwarz ar0

    Dabei seit:
    22.04.2007
    Beiträge:
    546
    Zustimmungen:
    0
    Ort:
    Niedersachsen
    Da du nichts von Fehlermeldungen gesagt hast liege ich mit meinem Tip wahrscheinlich falsch, aber Posten schadet ja nichts.

    *postcountpush*

     
  7. #6 Mitzekotze, 22.09.2007
    Mitzekotze

    Mitzekotze little man

    Dabei seit:
    01.12.2006
    Beiträge:
    750
    Zustimmungen:
    0
    @bitmuncher: Weil z.B. das Programm beep mit geladenem pcspkr Modul keinen Ton von sich gibt. Aber allgemein funktioniert er ja bzw. ist vorhanden, bloß unter Linux höre ich keinen Ton.

    @Tomekk228: Voraus gegangen war dem ganzen dieser Thread hier *klick* und das wollte ich halt auch auf meinem System probieren. Ich hab mal gegoogelt und in der manpage von urxvt nachgeforscht aber nichts gefunden :( .

    @Gott_in_schwarz: Nein bei mir kommt keinerlei Fehlermeldung beim ausführen von beep ansonsten hätte ich sie ja gepostet ;) .
     
  8. wiese

    wiese Grünschnabel

    Dabei seit:
    08.10.2006
    Beiträge:
    4
    Zustimmungen:
    0
    Ort:
    Schöllnach
    Gute Morgen
    kann es sein das du das modul pcspkr in der
    Code:
    /etc/rc.conf
    geblacklistet hast??? das würde erklären warum im grub der beep funktioniert und unter linux dann nicht
     
  9. #8 Mitzekotze, 22.09.2007
    Mitzekotze

    Mitzekotze little man

    Dabei seit:
    01.12.2006
    Beiträge:
    750
    Zustimmungen:
    0
    Mh leider nein, ich hab keinerlei Module auf der Blackliste
    Code:
    MOD_BLACKLIST=()
    und das Modul pcspkr ist auch ganz normal in unter MODULES=() eingefügt.
     
  10. #9 bitmuncher, 23.09.2007
    bitmuncher

    bitmuncher Der Stillgelegte

    Dabei seit:
    08.05.2007
    Beiträge:
    3.171
    Zustimmungen:
    0
    Funktioniert beep nur in einem grafischen Terminal oder auch auf einem TTY nicht. Bei KDE z.B. ist es möglich im Kontrollzentrum unter "Sound & Multimedia"->Signalton die Lautstärke des Beeps einzustellen. Ist diese auf 0% gesetzt, herrscht natürlich Schweigen.
     
  11. #10 Mitzekotze, 23.09.2007
    Mitzekotze

    Mitzekotze little man

    Dabei seit:
    01.12.2006
    Beiträge:
    750
    Zustimmungen:
    0
    Auch in einer TTY herrscht Stille. Unter welchem Punkt könnte man die Lautstärke des internen Lautsprechers im alsamixer regeln? Vielleicht hab ich einfach nur den falschen Menüpunkt nicht aktiviert (hab alle durchprobiert :( ).
     
  12. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  13. #11 bitmuncher, 23.09.2007
    bitmuncher

    bitmuncher Der Stillgelegte

    Dabei seit:
    08.05.2007
    Beiträge:
    3.171
    Zustimmungen:
    0
    Da der Systembeep nicht über Alsa-Module ausgegeben wird, wirst du dafür keinen Regler im Alsamixer finden. Hast du evtl. den Beep für deine Shell oder allgemein in der /etc/inputrc deaktiviert?
     
  14. #12 Mitzekotze, 23.09.2007
    Zuletzt bearbeitet: 23.09.2007
    Mitzekotze

    Mitzekotze little man

    Dabei seit:
    01.12.2006
    Beiträge:
    750
    Zustimmungen:
    0
    Also in meiner /etc/inputrc steht folgendes:
    Code:
    [B]# do not bell on tab-completion
    #set bell-style none[/B]
    
    set meta-flag on
    set input-meta on
    set convert-meta off
    set output-meta on
    
    $if mode=emacs
    
    # for linux console and RH/Debian xterm
    "\e[1~": beginning-of-line
    "\e[4~": end-of-line
    "\e[5~": beginning-of-history
    "\e[6~": end-of-history
    "\e[7~": beginning-of-line
    "\e[3~": delete-char
    "\e[2~": quoted-insert
    "\e[5C": forward-word
    "\e[5D": backward-word
    "\e\e[C": forward-word
    "\e\e[D": backward-word
    "\e[1;5C": forward-word
    "\e[1;5D": backward-word
    
    # for rxvt
    "\e[8~": end-of-line
    
    # for non RH/Debian xterm, can't hurt for RH/DEbian xterm
    "\eOH": beginning-of-line
    "\eOF": end-of-line
    
    # for freebsd console
    "\e[H": beginning-of-line
    "\e[F": end-of-line
    $endif
    
    # Include user-specific configuration
    $include ~/.inputrc
    
    demnach müsste eigentlich die Lautsprecher ein Ton von sich geben oder?
    In der .inputrc in meinem Home Verzeichnisses befindet sich auch nur folgende Zeile:
    Code:
    set completion-ignore-case on
     
Thema:

Interner Lautsprecher ist still

Die Seite wird geladen...

Interner Lautsprecher ist still - Ähnliche Themen

  1. Router und interner ntpd?

    Router und interner ntpd?: Hallo Wie kann man feststellen, ob mein Router (TP-link842ND) ntpd, oder nur ntpdate nutzt ? Er holt sich automatisch die Zeit (gibt...
  2. RHEL interner Update-Server

    RHEL interner Update-Server: Hi @all, gibt es bei RHEL die Möglichkeit einen Update-Server zu bauen? Meine Idee ist, dass ich einen RHEL-Server hinstelle, der in der DMZ...
  3. Problem mit Bind und interner Adress/Namensauflösung

    Problem mit Bind und interner Adress/Namensauflösung: Hallo, hier läuft bind8 auf FreeBSD 5.2.1, benutzt habe ich folgendes HOWTO: http://www.tuxweb.net/howto/dns/bsd/bind-89-bsd4x.html In den...
  4. Interner Server - Firewall notwendig?

    Interner Server - Firewall notwendig?: Hey und Hallo, ich habe die Tage einen neuen Debianserver bei uns im Netzwerk installiert und als OpenVPN-Server konfiguriert. Ebenfalls läuft...
  5. OpenSuse, Internerverbindung mit Windows Me teilen

    OpenSuse, Internerverbindung mit Windows Me teilen: Hallo, ich habe folgendes Anliegen: Ich habe hier zwei Rechner stehen, auf dem einen läuft OpenSuse 10.2 und auf dem anderen Windows Me. Der...