gtk+ lässt sich nicht emergen

Dieses Thema im Forum "Gentoo" wurde erstellt von malaclypse, 23.02.2005.

  1. #1 malaclypse, 23.02.2005
    malaclypse

    malaclypse Grünschnabel

    Dabei seit:
    04.10.2004
    Beiträge:
    6
    Zustimmungen:
    0
    Hallo alle zusammnen!

    Wenn ich versuche gtk+ zu emergen bricht der Vorgang nach einiger Zeit mit folgender Meldung ab:

    Code:
    ...
    /bin/sh ../libtool --mode=link i686-pc-linux-gnu-gcc  -march=athlon-xp -O2 -pipe  -fomit-frame-pointer -Wall   -o libpixbufloader-tiff.la -rpath /usr/lib/gtk-2.0 /2.4.0/loaders -avoid-version -module  io-tiff.lo -ltiff libgdk_pixbuf-2.0.la -l gmodule-2.0 -ldl -lgobject-2.0 -lglib-2.0 -lm
    grep: //usr/lib/gcc/i686-pc-linux-gnu/3.4.3/libstdc++.la: No such file or direct ory
    /bin/sed: can't read //usr/lib/gcc/i686-pc-linux-gnu/3.4.3/libstdc++.la: No such  file or directory
    libtool: link: `//usr/lib/gcc/i686-pc-linux-gnu/3.4.3/libstdc++.la' is not a val id libtool archive
    make[4]: *** [libpixbufloader-tiff.la] Fehler 1
    make[4]: Leaving directory `/var/tmp/portage/gtk+-2.4.14/work/gtk+-2.4.14/gdk-pi xbuf'
    make[3]: *** [all-recursive] Fehler 1
    make[3]: Leaving directory `/var/tmp/portage/gtk+-2.4.14/work/gtk+-2.4.14/gdk-pi xbuf'
    make[2]: *** [all] Fehler 2
    make[2]: Leaving directory `/var/tmp/portage/gtk+-2.4.14/work/gtk+-2.4.14/gdk-pi xbuf'
    make[1]: *** [all-recursive] Fehler 1
    make[1]: Leaving directory `/var/tmp/portage/gtk+-2.4.14/work/gtk+-2.4.14'
    make: *** [all] Fehler 2
    
    !!! ERROR: x11-libs/gtk+-2.4.14 failed.
    !!! Function src_compile, Line 78, Exitcode 2
    !!! (no error message)
    !!! If you need support, post the topmost build error, NOT this status message.
    Was hat es denn da mit der libstdc++.la auf sich?
    Es wäre nett, wenn mir jemand weiterhelfen könnte.

    Grüsse
    mala
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 malaclypse, 23.02.2005
    malaclypse

    malaclypse Grünschnabel

    Dabei seit:
    04.10.2004
    Beiträge:
    6
    Zustimmungen:
    0
    Ah, libstdc++ ist eine Bibliothek, die der Compiler braucht.

    Code:
    If you have issues with packages unable to locate libstdc++.la,
    then try running 'fix_libtool_files.sh' on the old gcc versions.
    
    Habe eine Lösung gefunden.
    Trotzdem Danke an alle die hier reingeschaut haben.
     
Thema:

gtk+ lässt sich nicht emergen

Die Seite wird geladen...

gtk+ lässt sich nicht emergen - Ähnliche Themen

  1. GTK+ 3.20 freigegeben

    GTK+ 3.20 freigegeben: Version 3.20 der GUI-Bibliothek GTK+ ist mit Verbesserungen und Erweiterungen bei der Verwendung von CSS und verbesserter Wayland-Unterstützung...
  2. Day: Anwendungsisolation und GTK+-Szenegraphen in Gnome

    Day: Anwendungsisolation und GTK+-Szenegraphen in Gnome: Das Gnome-Projekt macht Fortschritte bei den Anwendungs-Sandkästen und GTK+-Szenegraphen. Für Allan Day vom Gnome-Design-Team sind das die beiden...
  3. GTK+ 3.16 freigegeben

    GTK+ 3.16 freigegeben: Version 3.16 der GUI-Bibliothek GTK+ ist erschienen. Sie unterstützt erstmals den Display-Server Mir und bringt einige neue Kontrollelemente....
  4. GTK+ 3.12 ändert das Aussehen der Dialoge

    GTK+ 3.12 ändert das Aussehen der Dialoge: Mit der Freigabe der neuen Version von Gtk+ werden die Entwickler unter anderem das Aussehen der Dialoge überarbeiten. Die wohl größte Änderung...
  5. Chrome wechselt von GTK+ zu Aura

    Chrome wechselt von GTK+ zu Aura: Wie bereits in der Vergangenheit angekündigt, wechselt auch die Linux-Version des Google-Browsers Chrome zu Aura. Damit gleicht das Unternehmen...