Firewall FreeBSD aktivieren?

Dieses Thema im Forum "FreeBSD" wurde erstellt von salim_aliya, 14.03.2009.

  1. #1 salim_aliya, 14.03.2009
    salim_aliya

    salim_aliya Grünschnabel

    Dabei seit:
    14.03.2009
    Beiträge:
    5
    Zustimmungen:
    0
    Hallo Leute,

    ich bin schon ein bisschen erfahrener Linux user, und habe FreeBSD auf einen Testrechner Zuhause bei mir frisch installiert. Ich habe da ein paar Fragen:

    Diesen testrechner möchte ich später als Router fungieren, da mein jetziger zu swach für meine anforderungen ist.

    Auf diesen Server möchte ich gerne Squid installieren, als transparenten Proxy. Über Squid soll der komplette Netz traffic, egal welcher Port umgeleitet werden. Das hat den Sinn, da ich bestimmte zugriffe (nicht nur auf Webseiten) zu bestimmten Servern verbieten will.

    Squid konnte ich erfolgreich einrichten, dieser funktioniert perfekt. Mein Problem allerdings ist, wie schaffe ich es, dass der komplette traffic über squid geleitet wird?

    In Zahlreichen Foren müsste ich dazu regeln definieren, die dies tun, aber mein System scheint, als hätte es gar keine Firewall aktiviert. Versuche, diese zu aktivieren hat immer gescheitert bisher, ich denke mal die tutorials waren alle zu alt und deshalb nicht mehr auf den aktuellsten stand. Oder es haben irgendwie schritte gefehlt. Naja jedenfalls bin ich immer wieder gescheitert.

    Wie gesagt, FreeBSD ist komplett frisch installiert, nur squid ist als einziges Programm drauf.

    Wie aktiviere ich nun die Firewall? Kennt jemand ein passendes Howto dafür?
    Gerne würde ich auch die Firewall so einrichten, wie man sie bei routern kennt, mit Portfreigabe, Portweiterleitung etc.

    Habt ihr gute Denkanstöße für mich?
    Danke im vorraus
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. larry

    larry Tripel-As

    Dabei seit:
    27.11.2007
    Beiträge:
    159
    Zustimmungen:
    0
    pf(4) aktivierst du mit /etc/rc.d/pf start. Trag in die /etc/rc.conf pf_enable="YES" ein.

    Weitere Informationen zu PF:
    http://www.openbsd.org/faq/pf/
     
  4. #3 bytepool, 14.03.2009
    bytepool

    bytepool Code Monkey

    Dabei seit:
    12.07.2003
    Beiträge:
    791
    Zustimmungen:
    0
    Ort:
    /home/sweden/göteborg
    Hi,

    und ansonsten scheinen die wichigsten Dinge doch auch im Handbuch zu stehen. Oder meintest du, dass der Teil outdated ist?
    http://www.freebsd.org/doc/de_DE.ISO8859-1/books/handbook/firewalls.html

    Soweit ich weiss ist das korrekt, wenn du keine aktiviert hast, duerfte auch keine laufen.

    mfg,
    bytepool
     
  5. #4 salim_aliya, 14.03.2009
    Zuletzt bearbeitet: 14.03.2009
    salim_aliya

    salim_aliya Grünschnabel

    Dabei seit:
    14.03.2009
    Beiträge:
    5
    Zustimmungen:
    0
    Hallo,
    danke, ich bin schon einen schritt weiter. PF war bereits aktiviert über die /etc/rc.conf

    jetzt scheint die firewall zu laufen. Ich habe folgendes tutorial gemacht http://www.cyberciti.biz/faq/freebsd-enable-pf-altq-firewall-support/ und habe einige punkte aus eueren links zu meiner installation kombiniert und die firewall somit installieren können.

    Die Config hat allerdings scheinbar nicht so ganz geklappt, ich habe die komplete config von https://www.bsdwiki.de/Firewall_Regeln#PF_.28Free-.2C_Open-_und_NetBSD.29 übernommen und als interface eines meiner Netzwerkkarten gesetzt. Jetzt scheint die Firewall zu funktionieren aber so ganz hat SSH freischalten denke ich nicht geklappt, da ich mich ausgesperrt habe.

    Ich habe zwei Netzwerkkarten:
    rl0 für Internet Modem zum einwählen
    msk0 für die Rechner bei mir Zuhause

    ich habe nur bei ext_if den Wert auf "msk0" gesetzt, also meiner Netzwerkkarte, die ich nachher für mein Netzwerk nutzen will. Kein Zugriff war möglich. Eine änderung auf rl0 hatte ebenfalls nichts genützt, auf keines der beiden Netzwerkkarten konnte ich auf SSH zugreifen (habe durchprobiert)

    Einen Lösungsansatz habe ich bereits: Ich denke mal das hat was mit ALTQ zu tun, dessen config habe ich ebenfalls leicht editiert aus dem tutorial übernommen und sie bei /etc/altq.conf gespeichert. Aber das hatte nichts gebracht.

    Hat einer eine Idee, wo ich ansetzen müsste, den Fehler zu beseitigen?

    Danke für Hilfe
     
  6. larry

    larry Tripel-As

    Dabei seit:
    27.11.2007
    Beiträge:
    159
    Zustimmungen:
    0
    Wenn du vom lokalen Netzwerk über SSH auf deinen zukünftigen Router willst, reicht erstmal
    Code:
    pass in quick on $int_if proto tcp from any to any port ssh
    So sperrst du dich erstmal nicht aus.
    Für deine Zwecke, empfehl ich dir dann das Handbuch.
     
  7. #6 salim_aliya, 15.03.2009
    salim_aliya

    salim_aliya Grünschnabel

    Dabei seit:
    14.03.2009
    Beiträge:
    5
    Zustimmungen:
    0
    Hallo, Danke!

    Hat geklappt!
     
  8. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
Thema:

Firewall FreeBSD aktivieren?

Die Seite wird geladen...

Firewall FreeBSD aktivieren? - Ähnliche Themen

  1. suche eine firewall für freeBSD 5.2.1

    suche eine firewall für freeBSD 5.2.1: hi suche eine firewall, möglichst via GUI konfigurierbar für freeBSD 5.2.1
  2. Firewall pfSense 2.3 erschienen

    Firewall pfSense 2.3 erschienen: Version 2.3 der auf FreeBSD beruhenden Firewall-Distribution pfSense bringt unter anderem eine noch einmal neu geschriebene Weboberfläche und eine...
  3. DNS, DNS-Crypt und Firewall

    DNS, DNS-Crypt und Firewall: Hallo! Ich bin gerade wieder an meiner Hardware-Firewall dran und drehe ein paar Hähne enger zu. Da kam mir die Frage mit dem DNS auf. Ich habe...
  4. Firewall Smoothwall Express 3.1 veröffentlicht

    Firewall Smoothwall Express 3.1 veröffentlicht: Die Entwickler der Smoothwall-Gemeinschaft haben ihre freie Firewalldistribution Smoothwall Express in der Version 3.1 veröffentlicht. Smoothwall...
  5. Untangle NG Firewall 11 veröffentlicht

    Untangle NG Firewall 11 veröffentlicht: Das US-amerikanische Unternehmen Untangle hat seine Firewall- und Gateway-Distribution Untangle NG Firewall in der Version 11 veröffentlicht....