cups-problem

Dieses Thema im Forum "Drucker / Scanner" wurde erstellt von supersucker, 15.10.2006.

  1. #1 supersucker, 15.10.2006
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    hi,

    ich könnte mit drucken unter linux wieder mal amok laufen........

    Ich hab einen Canon IP 2000 unter Ubuntu Dapper sowie turboprint, dieser hat unter Breezy auf einem anderen Rechner schon funktioniert.

    Was ich gemacht hab:

    - Drucker angeschlossen, der device manager sagt mir nun das das device für den Drucker /dev/usblp0 ist
    - Turboprint installiert und xtpsetup gestartet.

    Da hab ich nun folgendes eingegeben:

    Code:
    shortname: tp0
    config_name: Canon_PIXMA_iP2000.1 
    Connection: local Printer
    Device Name: /dev/usblp0
    
    Das wars, mehr kann man in dem Dialog nicht festlegen.....soweit so simpel, dachte ich zumindest......

    Gehe ich aber nun auf "print testpage"

    passiert gar nichts und ich sehe in der Konsole aus der ich xtp-setup heraus gestartet habe:

    Code:
    request id is tp0-0 (1 file(s)
    
    Nur dann passiert halt nix mehr....

    Schaue ich nun auf

    Code:
    http://localhost:631
    nach sehe ich in der Sektion Printers folgendes;

    Code:
    Description: Canon_PIXMA_iP2000
    Location:
    Make and Model: Canon_PIXMA_iP2000 TurboPrint
    Printer State: processing, accepting jobs, published.
    Device URI: usb:/dev/usblp0
    
    Sieht ja eigentlich soweit ok, versuche aber nun über das web-interface eine testpage auszudrucken, kommt nach kurzer Zeit:

    Code:
    "Printer not connected; will retry in 30 seconds..."
    
    Aber er ist ja verbunden, sonst hätte ich ihn ja schon gar nicht einrichten können......

    Irgendwer ne Idee?

    Hier ist mal noch cupsd.conf:

    Code:
    #
    #
    #   Sample configuration file for the Common UNIX Printing System (CUPS)
    #   scheduler.  See "man cupsd.conf" for a complete description of this
    #   file.
    #
    
    # Log general information in error_log - change "info" to "debug" for
    # troubleshooting...
    LogLevel warning
    
    # Administrator user group...
    
    User cupsys
    SystemGroup lpadmin
    
    # Only listen for connections from the local machine.
    # These settings are configured in /etc/cups/cups.d/ports.conf so that
    # changing them does not require to change this file.
    Listen localhost:631
    # Listen /var/run/cups/cups.sock
    
    # Show shared printers on the local network.
    # The 'Browsing' setting is configured in /etc/cups/cups.d/browse.conf
    # so that changing it does not require to change this file.
    # Browsing Off
    BrowseOrder allow,deny
    BrowseAllow @LOCAL
    BrowseAddress @LOCAL
    
    # Default authentication type, when authentication is required...
    DefaultAuthType Basic
    
    # Restrict access to the server...
    <Location />
      Order allow,deny
      Allow localhost
      Allow @LOCAL
    </Location>
    
    <Location /admin>
    AuthType Basic
    Require user @SYSTEM
    ## Restrict access to local domain
    Deny From All
    Allow From 192.168.1.0/24
    </Location>
    
    # Restrict access to configuration files...
    <Location /admin/conf>
      AuthType Basic
      Require user @SYSTEM
      Order allow,deny
      Allow localhost
    </Location>
    
    # Set the default printer/job policies...
    <Policy default>
      # Job-related operations must be done by the owner or an adminstrator...
      <Limit Send-Document Send-URI Hold-Job Release-Job Restart-Job Purge-Jobs Set-Job-Attributes Create-Job-Subscription Renew-Subscription Cancel-Subscription Get-Notifications Reprocess-Job Cancel-Current-Job Suspend-Current-Job Resume-Job CUPS-Move-Job>
        Require user @OWNER @SYSTEM
        Order deny,allow
      </Limit>
    
      # All administration operations require an adminstrator to authenticate...
      <Limit Pause-Printer Resume-Printer Set-Printer-Attributes Enable-Printer Disable-Printer Pause-Printer-After-Current-Job Hold-New-Jobs Release-Held-New-Jobs Deactivate-Printer Activate-Printer Restart-Printer Shutdown-Printer Startup-Printer Promote-Job Schedule-Job-After CUPS-Add-Printer CUPS-Delete-Printer CUPS-Add-Class CUPS-Delete-Class CUPS-Accept-Jobs CUPS-Reject-Jobs CUPS-Set-Default>
        AuthType Basic
        Require user @SYSTEM
        Order deny,allow
      </Limit>
    
      # Only the owner or an administrator can cancel or authenticate a job...
      <Limit Cancel-Job CUPS-Authenticate-Job>
        Require user @OWNER @SYSTEM
        Order deny,allow
      </Limit>
    
      <Limit All>
        Order deny,allow
      </Limit>
    </Policy>
    
    # Include files in /etc/cups/conf.d
    Include /etc/cups/cups.d/ports.conf
    Include /etc/cups/cups.d/browse.conf
    
    #
    #
    
    
    Bin für jede Idee dankbar........
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. cremi

    cremi Dude

    Dabei seit:
    15.02.2004
    Beiträge:
    329
    Zustimmungen:
    0
    Ort:
    AUT/Ktn
    hast du das irgendwie gelöst bekommen?
     
  4. EkMEK

    EkMEK Grünschnabel

    Dabei seit:
    01.05.2007
    Beiträge:
    3
    Zustimmungen:
    0
    Hi!

    Hatte bei mir ähnliche Probleme - mein Oki B4100 wurde erkannt, wenn ihn anschließe und bei CUPS auch in der Verwaltung angezeigt, ich konnte ihn problemlos einrichten usw., aaaber: Sobald ich etwas drucken wollte, tauchte auf einmal die Meldung auf "Printer not connected; will retry in 30 seconds..."

    Ich habe so ziemlich alles durchprobiert, was ich in locker 20 Stunden googlen (okay, einschl. Versuche... ;) ) gefunden habe, Wirkung habe ich erst erzielt, als ich den Drucker dann über die Kommandozeile eingerichtet habe (warum auch immer das einen Unterschied zum Webinterface macht...):

    # foomatic-configure -s cups -p HP-LaserJet_1100 -c /dev/usb/lp0 -n B4100 -d hpijs

    bzw.:
    # foomatic-configure -s cups -p [Druckerbeschreibung] -c [Gerätepfad] -n [AnzeigeName] -d [Druckertreiber]

    • Die Druckerbeschreibungen liegen bei mir (Gentoo) als .xml in /usr/share/foomatic/db/source/printer/ einfach den richtigen (oder wie in meinem Fall: kompatiblen) Dateinamen ohne .xml angeben
    • Gerätepfad ist der Pfad, unter dem das Gerät eingebunden wird - bei mir hat's mir klappt /dev/usb/lp0, aber im Netz sind auch häufiger /dev/usblp0 o.ä. zu finden
    • Anzeigename kannst Du frei wählen
    • Die Druckertreiber liegen ebbenfalls als .xml vor - bei mir unter /usr/share/foomatic/db/source/driver/ auch hier Dateiname ohne .xml benutzen

    Bei mir war der Drucker anschließend ohne Neustart von Cups verfügbar.
    Hoffentlich ist Dir damit geholfen :)

    Grüsse und Haere Mai ;)
     
Thema:

cups-problem