alsa stottert manchmal (kein PulseAudio)

Dieses Thema im Forum "Linux OS" wurde erstellt von Gast1, 15.10.2013.

  1. #1 Gast1, 15.10.2013
    Zuletzt von einem Moderator bearbeitet: 15.10.2013
    Gast1

    Gast1 Guest

    Hi
    Ich habe ab und zu, nicht regelmäßig, das Problem, dass die Audioausgabe stottert. Zudem verhält sich alsamixer sehr Träge wenn dieses Problem auftaucht.
    Leider ist die einzige Lösung die ich zu dem Thema finden kann PulseAudio zu deaktivieren. Allerdings habe ich kein PA installiert, somit fällt das als Fehlerquelle schon mal raus :)

    Bisher war es oft so, dass bereits nach dem booten der Sound schon nicht flüssig lief, sodass ich direkt rebootet habe. Danach war dann das Problem auch behoben. Diese Situation war etwa einmal im Monat, bis ich auf Linux 3.11 updatete womit das Problem bis heute behoben war.

    Heute Trat das Problem allerdings erst sehr lange nach dem Systemstart auf. Ich habe gestern, und den ganzen Morgen (kein reboot über nacht) problemlos Musik gehört, und zwischendurch recht häufig auch die Lautstärke geändert. Bis dann nach einer erneuten Änderung der Lautstärke das stottern begann.

    Zu meinem Benutzungsverhalten :)
    Ich habe die meiste Zeit mocp laufen, und parallel den alsamixer. Die Lautstärkenänderung nehme ich mit beiden Tools am master-regler vor. Zu dem Zeitpunkt als der Fehler auftrat lief allerdings zusätzlich eine VLC-Instanze (neben 3 weiteren, gemuteten VLC-Instanzen).
    Kurz: alsamixer, mocp, und 4x VLC griffen auf alsa zu.

    Zum System:
    Basierend auf Slackware 14 x86-64, allerdings mit folgenden Änderungen:
    - Linux 3.11.3
    - alsa-utils 1.0.27.1
    - libalsa 1.0.27.2
    - mocp 2.5.0-beta1 rev2529M
    - VLC 2.0.8 rev2.0.7-29-g12aebf9

    Frage:
    - Wie kann ich so ein reboot "manuell" durchführen, also, was muss ich machen, damit ich ohne das ganze System neu zu booten das Problem (vorübergehend) behoben habe? Das erneute Aufrufen von /etc/rc.d/rc.alsa führt nur dazu, dass die Audioeinstellungen (mixer) zurückgesetzt werden.
    - Und zweitens, was genau ist mein Problem? :) Wo muss ich anfangen zu suchen?

    Ich hoffe meine Infos sind ausreichend, ansonsten liefere ich nach :) (Bitte keine Diskussion warum ich 5 audio-player laufen habe :) )

    Edit1:
    - In den Logfiles ist natürlich nichts aufgelistet :)
    - das bei Debian (auch anderen?) verwendete Tool /sbin/alsa existiert nicht (auch nicht in /usr/ oder sonstwo... ;) )
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 karloff, 15.10.2013
    karloff

    karloff Routinier

    Dabei seit:
    09.07.2007
    Beiträge:
    317
    Zustimmungen:
    0
    Ort:
    ~/
    Ich würde mir mal die Stormsparfunktion deiner soundkarte anschauen, ich hatte damals mit meiner onboard intel auch einige probleme bis ich die stormsparfunktion ausgeknippst habe, ob das bei dir was hilft, weiß ich nicht, aber wäre ein ansatzpunkt.

    Der Manuelle reboot deiner soundkarte sollte gehen wenn du alsa als kernel module kompilierst dann kannst du es mit modprobe rein und raus werfen, schön ist das allerdings nicht.
     
  4. Gast1

    Gast1 Guest

    Ist zwar jetzt auf die Schnelle schwer zu testen, aber ich bedanke mich schonmal für den Tipp :)

    Und was das alsa-modul angeht: Symptom-Behandlung ist immer Unsauber, da kommt es auf das wie auch nicht mehr an :D
     
  5. Gast1

    Gast1 Guest

    Das mit der Power-save-geschichte hat das Problem offensichtlich nicht gelöst. Vielleicht habe ich auch ein paar Punkte übersehen... Ich habe in der kernel-config lediglich das ac97-powersave-feature deaktiviert. Mehr konnte ich zu dem Thema nicht finden. Im sysfs steht jedenfalls in power/control "on" was bedeutet, dass für dieses Gerät kein Powermanagement stattfindet.

    Als temporäre Lösung, also um ein reboot zu verhindern reicht es das Gerät zu reseten:
    Code:
    echo "1" > /sys/devices/$DEVICE/reset
    Und damit ist nun vielleicht auch die Hardware interessant geworden. lspci sagt: "AMD Hudson Azalia Controller (rev 01)"
     
  6. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
Thema:

alsa stottert manchmal (kein PulseAudio)

Die Seite wird geladen...

alsa stottert manchmal (kein PulseAudio) - Ähnliche Themen

  1. Asus U30sd + Arch + Alsa...

    Asus U30sd + Arch + Alsa...: Moin, ich habe hier ein Asus U30SD mit Arch aufgesetzt, was auch recht gut läuft. Nun allerdings hab ich so meine Schwierigkeiten mit Alsa und...
  2. Alsa: snd-hda-intel geht nicht mehr

    Alsa: snd-hda-intel geht nicht mehr: Hallo, ich verwende Aptosid als Distribution und hatte bisher keine nennenswerten Probleme mit ALSA. Ich habe eine interne Soundkarte, die ich...
  3. »OpenSuse Box« wird zu »Balsam Professional«

    »OpenSuse Box« wird zu »Balsam Professional«: Die open-slx GmbH, bekannt als Anbieter der »OpenSuse Box« und des OpenSuse-Anwender-Supports, kündigte mit »Balsam Professional« ein auf...
  4. VLC redundantes Einstellungs-hin-und-her-aendern [ALSA]

    VLC redundantes Einstellungs-hin-und-her-aendern [ALSA]: Hier mal wieder ein Problem: Da ich ueber das optische SPDIF zum Verstaerker gehe, habe ich bei den VLC Einstellungen unter Sound als Output...
  5. alsaconf ja oder nein

    alsaconf ja oder nein: Hallo Was haltet ihr davon, daß alsaconf bei einigen Distrsi (Debian, Ubuntu) nicht mehr in den Alsa-utils auftaucht. Ich finde es sehr...