Zugrif auf Samba aus anderem IP-Bereich

A

an_no

Gast
Hallo an alle,

ich habe einen Samba-Server an dem unter anderem ein Windows-Terminalserver hängt auf den ich von zu Hause zugreifen kann. Beide Netze sind mittels VPN-Router verbunden. Soviel zur Vorgeschichte.
Ich möchte nun von zu Hause direkt auf die Sambafreigaben zugreifen ohne mich auf dem Terminalserver anzumelden. Wenn ich an meinem Heimrechner die IP des TS suche, bekomme ich alle dort eingerichteten Freigaben angezeigt. Versuch ich das mit dem Linux-Server bekomme ich keine Verbindung. (Hintergrund ist, ich möchte mit einem Kopierer direkt auf eine Sambafreigabe scannen).
Ich kann vom Linux-Server aus meinen Rechner zu Hause anpingen und umgedreht. Auch eine Test mit ausgeschalteter Firewall auf beiden Seiten brachte keinen Erfolg.
Die Logdateien auf dem Linuxserver (log.smbd, log.nmbd und massage) zeigen keinerlei Einträge.
Ich habe es schon mit der Option hosts allow in der global-Section versucht. Das brachte allerdings keinen Erfolg.

Hier ist die global-Section meiner smb.conf.
Code:
[global]
workgroup = EGS
netbios name = ls1
server string = PDC Server Samba 3.0.02
encrypt passwords = yes
map to guest = Bad User
null passwords = yes
keepalive = 10
logon script = %G.bat
domain logons = Yes
os level = 256
socket options = TCP_NODELAY IPTOS_LOWDELAY
preferred master = Yes
domain master = Yes
local master = Yes
security = user
wins support = yes
kernel oplocks = yes
time server = yes
log level = 0
deadtime = 0
smb ports = 139
lock spin count = 1
lock spin time = 2
printing = CUPS
printcap name = /etc/printcap
# rintcap cache time = 750
add machine script = /usr/sbin/useradd -g 100 -s /bin/false -M %u
# add machine script = /usr/sbin/useradd -c Machine -d /var/lib/nobody -s /bin/false %m$
unix charset = UTF-8
level2 oplocks = no
passdb backend = tdbsam
admin users = root
profile acls = yes
# cups options = raw
# include = /etc/samba/dhcp.conf
# logon path = \\%L\profiles\.msprofile
# logon home = \\%L\%U\.9xprofile
# logon drive = P:
# usershare allow guests = Yes

und so sehen meine Shares aus
Code:
[freigabename]
comment = Kommentar
path = /data/verzeichnis
writeable = yes
browsable = yes
create mask = 0777
admin users = +gruppe
directory mask = 0777

Mir gehen langsam die Ideen aus. Schon mal Danke im Voraus...
 

HBtux

Linuxer
Beiträge
72
Gibst Du einfach die IP-Adresse des Samba-Servers in die Adresszeile des Windows-Explorer ein???
Heim-Rechner ist ein Windows-PC...... Richtig?

Versuche mal, ob es über die Namensauflösung funktioniert....
Trage mal den Namen des Samba-Servers "ls1" in die "lmhosts"-Datei vom Windows-PC ein...
( C:\WINDOWS\system32\drivers\etc\lmhosts )


Weiteren Tipp für die Fehlersuche....
- Ports: 139 und 445
- Protokoll: SMB und CIFS
 

Ähnliche Themen

Samba 4.9.5-Debian - Kennwort von unix übernehmen

Zugriff Ubuntu 16.04. auf Freigabe 18.04. LTS nicht möglich

Samba Dateien und Ordner verschieben

Samba-Server mit Univention Corporate Server

Keine Zugriff von Windows 10 auf Sambafreigaben

Oben