XP - Ubuntu - GrubLoader

Lumma

Red Hat Neuling
Beiträge
34
Hallo! Ich habe jetzt WinXP und Ubuntu auf einer Platte installiert, zuerst XP dahinter Ubuntu, beim start des GrubLoader steht nur Loading.. und dann tut sich nix mehr, ich kann kein OS booten! Kann man da keinen anderen bootloader wählen? was soll ich machen? ?(
 

schwedenmann

Foren Gott
Beiträge
2.694
Ubuntu und Grub

hallo


hast du denn grub korrekt in den MBR installiert, oder wohin hast du grub installiert?


Mit einer LiveCDdie per Grub bootet 8z.B. kanotix) kannst dein Ubuntu booten, vorrausgesetzt du weißt wo deine Rootpartiton liegt und wie der kernel lautet. Vmlinuz reicht nämlich meisten und hier auf keinen fall aus, um den Ubuntukernel zu booten.

Ob Ubuntu einen Rettungsmodus, also ein bestehendes Festplattensystem booten kann, weiß ich nicht. Einfach die Doku auf der CD durchlesen.

Mfg
schwedenmann
 

Lumma

Red Hat Neuling
Beiträge
34
ich habs schon 2 mal probiert, 1 mal in den MBR und einmal woanders! Geht nicht! Es steht immer nur Loading, please Wait! Und dann geht nix mehr! Kann ja net sein bei 3ghz! :))

Was soll ich jetzt machen? Kann ich keinen anderen bootloader verwenden?
 

schwedenmann

Foren Gott
Beiträge
2.694
Ubuntu und Grub

Hallo

Ich sehe da im Moment nur 2 Möglichkeiten

1. Wenn du nach dem Installtionsort für Grub gefragt wirst gib
/dev/fd0 oder (fd0) an, damit Grum auf Diskette egschrieben wird, hat bei mir aber nciht funktioneirt, weiß auch auch nicht warum.

2. Du schreibst grub in die Rootpartition von Ubuntu und besorgst dir den Bootmanger Gag.
Den kannst du erstmal auf Diskette schriebn und damit Windoof und Linux booten. Bei Gag gibts du dann die Rootpartition von Ubuntu an, danach müßte GAG dann grub in / aufrufen und Grub bootet dann dein Ubuntu, so ist jedenfalls die Theorie, ob die Praxis genauso aussieht, probeir es aus.
Wenn das klappt, kannst du GAG in den MBR schreiben.


Mfg
schwedenmann
 

theton

Bitmuncher
Beiträge
4.820
Ubuntu und lilo

Ubuntu hat auch lilo dabei, einfach mal von nem knoppix (oder ubuntu-live) booten, ubuntu-partition(en) einhaengen mit chroot in die Ubuntu-Umgebung wechseln, Lilo installieren und gut is. Ich vermute aber, dass dein grub nicht im mbr ist. Also die gleiche Prozedur mit Knoppix/Ubuntu-Live machen und dann einfach 'grub-install /dev/hda' in der Ubuntu-Chroot-Umgebung ausführen.
 

Lumma

Red Hat Neuling
Beiträge
34
so, ich hab jetzt mal einen 1. schritt geschaftt! und zwar

ich hab die win XP CD reingelegt und folgendermaßen partitioniert!

C: 100 MB NTFS
D: 55 GB NTFS
restlicher Speicher

dann hab ich XP auf D: installiert und C: so gelassen!

Nach der XP Installation Ubuntu CD rein!

Folgendermaßen vorgegangen:

C: formatiert zu /Boot

restlicher Platz aufgeteilt in

1024 MB Swap
10 GB /Home
10 GB / (root)

so, nach der installation ladet Grub und ich kann ubuntu starten! ABER XP nicht! Es wird nicht angezeigt! Kann ich es in Grub irgendwie einbinden?? Danke im Voraus für eure Ratschläge!
 

Ähnliche Themen

Keine grafische Oberfläche (Debian Installation)

Ubuntu DvD Fehler

Linux "vergisst" Dateisystem?

Grub Boot Menü - Windows 10 hinzufügen

journal commit I/O error auf SSD

Oben