Xgl+Compiz macht schwarze Kästchen und lauter anderen Ulk

Diskutiere Xgl+Compiz macht schwarze Kästchen und lauter anderen Ulk im KDE Forum im Bereich X Window; Hi, also ich habe mich mal netschlossen Xgl und Compiz unter openSuSE10.3 zu probieren. Hat alles auch ganz gut geklappt... mittel...

  1. #1 2TAKTER, 06.12.2007
    Zuletzt bearbeitet: 06.12.2007
    2TAKTER

    2TAKTER Foren As

    Dabei seit:
    26.11.2007
    Beiträge:
    94
    Zustimmungen:
    0
    Ort:
    Würzburg (zugezogen)
    Hi,
    also ich habe mich mal netschlossen Xgl und Compiz unter openSuSE10.3 zu probieren.
    Hat alles auch ganz gut geklappt...
    mittel
    Code:
    gnome-xgl-switch --enable-xgl
    habe ich xgl als Windowmanager festgelegt. Leider habe ich nach dem Neustart auf meinem Desktop viele tolle Anzeige fehler gehabt. Die Titelleiste bei den fenstern hat gefehlt, Desktopicons wurden teils als schwarze Kästchen angezeigt und auch Schrift wurde meist nur als toller Balken angezeigt.
    Also schnell im init 3 alles rückgängig gemacht und mit Xorg als windowsmanager funzt wieder alles...

    Meine Frage ist jetzt woran dieses Phänomen liegt. Ich nutze eine GeForce 6200 LE mit geschlossenen nvidia-treibern und twinview.

    Ich habs...
    in der
    Code:
    /etc/sysconfig/displaymanager
    muss
    Code:
    DISPLAYMANAGER_XGL_OPTS="-accel glx:pbuffer -accel xv:pbuffer"
    in
    Code:
    DISPLAYMANAGER_XGL_OPTS="-accel glx:pbuffer -accel xv:fbo"
    geändert werden.

    Schon kann er Open GL nutzen und meine Fenster eiern hübsch durch die Gegend
     
  2. Anzeige

    Anzeige

    Wenn du mehr über Linux erfahren möchtest, dann solltest du dir mal folgende Shellkommandos anschauen.


    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 gropiuskalle, 06.12.2007
    gropiuskalle

    gropiuskalle terra incognita

    Dabei seit:
    01.07.2006
    Beiträge:
    4.857
    Zustimmungen:
    1
    Ort:
    Berlin
    Code:
    gnome-xgl-switch --enable-xgl
    Dieser Befehl ist nicht der günstigste (und aktiviert übrigens keinen Windowmanager), wenn man eine NVidia-Karte nutzt, denn der proprietäre NVidia-Treiber stellt ein Modul namens 'nvidia-glx' zur Verfügung, welcher eine wesentlich bessere Performance erreicht als XGL. Deswegen zwei Tipps:

    Code:
    gnome-xgl-switch --disable-xgl
    nvidia-xconfig --composite
    nvidia-xconfig --allow-glx-with-composite
    nvidia-xconfig --render-accel
    nvidia-xconfig --add-argb-glx-visuals -d 24
    ...und das Paket » Fusion-Icon « installieren (erhältlich über das X11:XGL-Repository), damit verwaltest Du den ganzen Compiz-Kram nämlich etwas einfacher.
     
Thema:

Xgl+Compiz macht schwarze Kästchen und lauter anderen Ulk

Die Seite wird geladen...

Xgl+Compiz macht schwarze Kästchen und lauter anderen Ulk - Ähnliche Themen

  1. Manjaro macht Snap Store leicht verfügbar

    Manjaro macht Snap Store leicht verfügbar: Der Arch-Linux-Ableger Manjaro bietet in seinem Testing-Kanal einen Ausblick auf kommende Entwicklungen. Aktuell geht es um ein neues...
  2. Zink macht Fortschritte

    Zink macht Fortschritte: Zink, die OpenGL-Implementation über der Vulkan-Schnittstelle, hat im letzten Dreivierteljahr einige Fortschritte gemacht. Einige Anwendungen...
  3. Was macht ihr im Internet am liebsten?

    Was macht ihr im Internet am liebsten?: Mich würde mal interessieren, wie ihr euch eure Zeit in Internet am liebsten vertreibt?
  4. Google Chrome macht das halbe Hundert voll

    Google Chrome macht das halbe Hundert voll: Chrome 50 wurde in den stabilen Release-Kanal übernommen und will die Ladezeiten von Webseiten mit einer Preload-Funktion verbessern. Weiterlesen...
  5. OpenMandriva macht sich von ROSA unabhängig

    OpenMandriva macht sich von ROSA unabhängig: Das OpenMandriva-Projekt betreibt jetzt unabhängige Build-Server und ist damit komplett eigenständig. Auch eine Server-Distribution ist in Arbeit....
  1. Diese Seite verwendet Cookies um Inhalte zu personalisieren. Außerdem werden auch Cookies von Diensten Dritter gesetzt. Mit dem weiteren Aufenthalt akzeptierst du diesen Einsatz von Cookies.
    Information ausblenden