XGL/Beryl

Marvin

User
Beiträge
590
Ich hab mir mal Beryl für Ubuntu 6.10 geholt, lief auch wunderbar, bis zum nächsten Neustart ab da kann Beryl nicht mehr umschalten und ist nicht mehr zu nutzen...;(
Wie kann ich das ändern?

* Beryl system compatiblity check *
**************************************************************

Detected xserver : XGL

Checking Display :0.0 ...

Checking for XComposite extension : passed (v0.3)
Checking for XDamage extension : passed
Checking for RandR extension : passed
Checking for XSync extension : passed

Checking Screen 0 ...

Checking for GLX_SGIX_fbconfig : passed
Checking for GLX_EXT_texture_from_pixmap : passed

** (beryl-manager:7063): WARNING **: Beryl hat ein tödliches Signal erhalten 11
.
.
.

Ging auch bei Ubuntu 6.06 super, bis zum nächsten Start von X...
.
.
.
EDIT (autom. Beitragszusammenführung) :
.

Ich hab aber nicht den neusten Nvidia Beta Treiber installiert...

Beryl funzt jetzt leider ist ALLES weiß...
 
Zuletzt bearbeitet:

Uschi

Endverbraucher
Beiträge
177
schonmal mit advanced options -> rendering path -> copy im beryl-manager versucht? falls dass nicht hilft, dann versuchs mal mit AIGLX ist imho sowieso stabiler und schneller.

// edit: falls das mit copy nicht funktioniert, dann schreib auch mal wie du XGL startest, wenn du Xgl auf einer X-Session laufen lasst dann kann dass nämlich schnell mal zu einer white cube führen
 

Goodspeed

Foren Gott
Moderator
Beiträge
4.168
Kannst Du XGL ohne Beryl vernünftig starten, d.h. mit KDE oder Gnome arbeiten?
Läuft dbus?
Eventuell mal eine aktuelle Version von Beryl ziehen ...

Als Nvidia-Besitzer finde ich AIGLX "einfacher" ... sofern man den 9er Nvidia-Treiber installiert ...
 

Marvin

User
Beiträge
590
Ja, Gnome und KDE kann ich starten, denn Beryl ist nicht im Autostart.
Weiß nicht ob dbus läuft guck ich aber gleich.
Hab das allerneuste Beryl!

Ich hab den Nvidia Treiber über APT-GET installiert...
 

Goodspeed

Foren Gott
Moderator
Beiträge
4.168
Code:
apt-cache policy nvidia-glx
sollte die Version offenbaren ... die 8er geht nicht mit AIGLX ... nur die 9er.
K.A. ob die bei Ubuntu schon bei ist ...

Ach ja ... wenn Du im laufenden KDE/Gnome den beryl-manager startest, kommt der Fehler, ja?
dann starte den mal über
Code:
strace beryl-manager
und poste mal die letzten ... sagen wir mal ... 20 Zeilen ... vielleicht stecht das was brauchbares ...
(eventuell muss strace erst installiert werden ...)
 
Zuletzt bearbeitet:

Marvin

User
Beiträge
590
Installiert:1.0.8776+2.6.17.7-11.1
Mögliche Pakete:1.0.8776+2.6.17.7-11.1
Versions-Tabelle:
*** 1.0.8776+2.6.17.7-11.1 0
500 http://security.ubuntu.com edgy-security/restricted Packages
100 /var/lib/dpkg/status
1.0.8774+2.6.17.5-11 0
500 http://de.archive.ubuntu.com edgy/restricted Packages

"Ach ja ... wenn Du im laufenden KDE/Gnome den beryl-manager startest, kommt der Fehler, ja?"
Ja genau...

strace beryl-manager

auch hier wird der Monitor weiß...
Soll ich vielleicht mal auf AIGLX oder "Nvidia" umstellen?

http://wiki.beryl-project.org/wiki/Install_Beryl_on_Ubuntu

Ich hab das mit der Anleitung gemacht.
 

Goodspeed

Foren Gott
Moderator
Beiträge
4.168
weiß? Kannst Du über ne Konsole (Strg+Alt+F1) schauen, ob neben beryl auch emerald läuft?
Beryl speichert alle Einstellungen unter ~/.beryl
Vielleicht hilft es, den Ordner umzubennen oder zu löschen.

Ach ja ... klar kannste AIGLx versuchen ... ob es was ändert werden wir dann ja sehen ;)
 

Marvin

User
Beiträge
590
Also, ich kann den Beryl-Manager/Emerald nutzen ohne Beryl zu starten, ich hab mal zum testen alles ausgeschaltet, hat aber nichts genutzt...
 

Marvin

User
Beiträge
590
Also ich kann den Beryl-Manager nutzen ohne Beryl zu nutzen also keine Effekte.
 

Goodspeed

Foren Gott
Moderator
Beiträge
4.168
?? Würdest Du das dann bitte mal tun? Und den ~/.emerald Ordner gleich mit ...
 

Goodspeed

Foren Gott
Moderator
Beiträge
4.168
Hmmm ... komisch das.
Kannst es ja mit AIGLX versuchen ... wenn das aber nicht hilft, würde ich direkt mal im Beryl-Forum nachfragen ...
 

Uschi

Endverbraucher
Beiträge
177
Was passiert wenn du das machst was ich gesagt habe also rendering path auf copy stellen?
Auf der anleitung gibt es mehrere startmöglichtkeiten, welche hast du verwendet? startest du XGL auf X?

//edit also das ändern auf copy geht im beryl-manager unter options -> rendering path -> copy
den beryl manager kannst du ja aufrufen wenn ich dass richtig verstanden habe.
 
Zuletzt bearbeitet:

Marvin

User
Beiträge
590
So ich glaub ich hab was wichtiges rausgefunden!
Wenn ich das Paket xserver-xgl entferne und dann wieder installiere klappt es problemlos bis zum nächsten reboot.
Wenn ich aber xserver-xgl nicht installiert habe kann mein X nicht starten...
.
.
.
EDIT (autom. Beitragszusammenführung) :
.

Hier meine xorg.conf:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder3) Fri Dec 15 10:12:14 PST 2006


Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
RgbPath "/usr/lib/X11/rgb"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 30.0 - 110.0
VertRefresh 50.0 - 150.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
Option "UseDisplayDevice" "DFP-0"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "XAANoOffscreenPixmaps"
Option "AddARGBGLXVisuals" "True"
SubSection "Display"
Depth 24
Modes "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
Option "AddARGBGLXVisuals" "True"
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection
 
Zuletzt bearbeitet:

Ähnliche Themen

Ubuntu X / dbus problem

[suse10.2]beryl Problem

Beryl

ati x1600 und beryl, schwierige sache ?

Textkonsole mit KMS zu klein

Oben