X als Dienst beenden

Diskutiere X als Dienst beenden im RedHat,Fedora & CentOS Forum im Bereich Linux Distributionen; So, ein kleines Problemchen: Welches InitScript startet eigentlich den Xserver? Ich würde das gerne verhindern - bin aber zu faul, ein init 4 zu...

  1. #1 saiki, 30.01.2004
    Zuletzt bearbeitet: 30.01.2004
    saiki

    saiki Bratwurstgriller

    Dabei seit:
    18.03.2003
    Beiträge:
    934
    Zustimmungen:
    0
    So, ein kleines Problemchen:
    Welches InitScript startet eigentlich den Xserver? Ich würde das gerne verhindern - bin aber zu faul, ein init 4 zu machen, da dort noch ein paar wichtige scripte gestartet werden die ich brauche.
    Ich will nur das X nicht startet.
     
  2. Anzeige

    Anzeige

    Wenn du mehr über Linux erfahren möchtest, dann solltest du dir mal folgende Shellkommandos anschauen.


    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 qmasterrr, 30.01.2004
    qmasterrr

    qmasterrr Foren Gott

    Dabei seit:
    01.01.2004
    Beiträge:
    2.735
    Zustimmungen:
    0
    started x bei dir automatisch?
     
  4. saiki

    saiki Bratwurstgriller

    Dabei seit:
    18.03.2003
    Beiträge:
    934
    Zustimmungen:
    0
    Ja, es startet automatisch.
     
  5. #4 qmasterrr, 30.01.2004
    qmasterrr

    qmasterrr Foren Gott

    Dabei seit:
    01.01.2004
    Beiträge:
    2.735
    Zustimmungen:
    0
    nimm es einfach aus dem startscript rausund wenn du es brauchst gib startx ein
     
  6. hehejo

    hehejo blöder Purist

    Dabei seit:
    12.10.2003
    Beiträge:
    1.280
    Zustimmungen:
    0
    Ganz einfach:
    Code:
    update-rc.d -f kdm remove
    update-rc.d -f gdm remove
    update-rc.d -f xdm remove
    So werden aus den /etc/rc.dX die Startscriptlinks entfernt.
    Wird kein ?dm gestartet startet auch kein X.
    Dann musst du dich normal einloggen und x per hand oder per startx starten.
     
  7. #6 qmasterrr, 30.01.2004
    qmasterrr

    qmasterrr Foren Gott

    Dabei seit:
    01.01.2004
    Beiträge:
    2.735
    Zustimmungen:
    0
    wenn du x wieder schließen willst kannst du [Ctrl]+[Alt]+[BackSpace] drücken
     
  8. Aracon

    Aracon Routinier

    Dabei seit:
    12.10.2003
    Beiträge:
    438
    Zustimmungen:
    0
    Started man ihn damit nicht neu? Oder bin ich jetzt aufm holzweg? :devil:
     
  9. #8 qmasterrr, 30.01.2004
    qmasterrr

    qmasterrr Foren Gott

    Dabei seit:
    01.01.2004
    Beiträge:
    2.735
    Zustimmungen:
    0
    nein mit [Ctrl]+[Alt]+[Del] startest du deinen rechner neu
     
  10. #9 damager, 30.01.2004
    damager

    damager Moderator

    Dabei seit:
    27.08.2003
    Beiträge:
    3.065
    Zustimmungen:
    0
    das ist je nach einstellung richtig aber mit
    [Ctrl]+[Alt]+[BackSpace]
    startet man definitiv den x-server neu.

    @saiki
    versuchs mal mit:
    1. abmelden aus dem windowmanager so das du auf xdm/kdm/wdm bist
    2. in die console mit z.b. [Ctrl]+[Alt]+[F1] wechseln und mit
    /etc/init.d/xdm stop den anmelde-manager beenden den dieser startet X.

    wenn du gar nicht mehr willst das X automatisch startet dann reicht es unter:
    /etc/inittab
    den eintrag id:5:initdefault: in id:3:initdefault: zu ändern.

    somit änderst den default runlevel und x startet nicht mehr.

    bei bedarf kannst du es, wie bereits erwähnt, mit startx wieder aktivieren.
     
  11. #10 qmasterrr, 30.01.2004
    qmasterrr

    qmasterrr Foren Gott

    Dabei seit:
    01.01.2004
    Beiträge:
    2.735
    Zustimmungen:
    0
    dann scheint das von distri zu distri verschieden zusein bei meinem slackware 9.1 schalte den xserver 100% mit [Ctrl]+[Alt]+[BackSpace]
    aus. (Hab cih ja schon oftgenug gemacht)
     
  12. #11 GeekGirl, 30.01.2004
    GeekGirl

    GeekGirl voll das krasse Bunny

    Dabei seit:
    30.04.2003
    Beiträge:
    241
    Zustimmungen:
    0
    ganz einfach: wenn ein Desktopmanager wie KDM, GDM oder XDM die X-Session managed, dann startet X mit Strg+Alt+Backspace neu (Einstellung respawn in /etc/inittab), startet man X ohne DM, also mit startx, dann beendet die gleiche Tastenkombi die Session...
     
  13. #12 damager, 30.01.2004
    damager

    damager Moderator

    Dabei seit:
    27.08.2003
    Beiträge:
    3.065
    Zustimmungen:
    0
    GeekGirl:
    danke für die auflösung :]

    "which brain" <--- genial :D
     
  14. #13 qmasterrr, 30.01.2004
    qmasterrr

    qmasterrr Foren Gott

    Dabei seit:
    01.01.2004
    Beiträge:
    2.735
    Zustimmungen:
    0
    dann sind dochjetzt alle probleme gelößt und unklarheiten behoben oder?
     
  15. #14 GeekGirl, 31.01.2004
    GeekGirl

    GeekGirl voll das krasse Bunny

    Dabei seit:
    30.04.2003
    Beiträge:
    241
    Zustimmungen:
    0
    klar, is ja auch meiner Phantasie entsprungen :D:D:D
     
  16. saiki

    saiki Bratwurstgriller

    Dabei seit:
    18.03.2003
    Beiträge:
    934
    Zustimmungen:
    0
    Leute, soweit wie ihr war ich auch schon! Wir reden aber über Fedora!

    Es gibt in /etc/init.d/ kein startscript für einen WM bzw. Loginmanager.

    Und das ist mein Problem, ich weis nicht, welches Script überhaupt den Loginmanager bzw. Xserver bei Fedora startet
     
  17. #16 qmasterrr, 31.01.2004
    qmasterrr

    qmasterrr Foren Gott

    Dabei seit:
    01.01.2004
    Beiträge:
    2.735
    Zustimmungen:
    0
    versuch es mal in /etc/rc.d/
     
  18. #17 damager, 31.01.2004
    damager

    damager Moderator

    Dabei seit:
    27.08.2003
    Beiträge:
    3.065
    Zustimmungen:
    0
    hmmm ... hab mir jetzt mal fedora einwenig angeguckt und hab auch auf anhieb kein init-skript gefunden.
    irgendwo und irgendwer muss /usr/bin/gdm-binary gestartet haben?!?!

    ein killall /usr/bin/gdm-binary bewirkt auch nur einen neustart von X

    eine suche in den runlevel directorys nach dem skript die diesen aufruf war erfolglos ...
     
  19. #18 GeekGirl, 31.01.2004
    GeekGirl

    GeekGirl voll das krasse Bunny

    Dabei seit:
    30.04.2003
    Beiträge:
    241
    Zustimmungen:
    0
    gibt es in /etc/rc'irgendeineNummer'd/ keine Links, wie z.B. S99xdm, die du zurückverfolgen kannst? manchmal ist ein Script nicht in /etc/init.d, sondern in /etc/rcSd... nur ne Idee...
     
  20. #19 qmasterrr, 31.01.2004
    qmasterrr

    qmasterrr Foren Gott

    Dabei seit:
    01.01.2004
    Beiträge:
    2.735
    Zustimmungen:
    0
    also das müsste doch auf der offiziellen seite stehen oder irre ich mich da?
     
  21. saiki

    saiki Bratwurstgriller

    Dabei seit:
    18.03.2003
    Beiträge:
    934
    Zustimmungen:
    0
    Ne, da steht nich wirklich was.
    Das einzige Script, was ich mir vorstellen könnte, was den Xserver mitstartet ist der X-Font-Server (xfs).
    Muss ich mir mal genau anschauen.
     
Thema:

X als Dienst beenden

Die Seite wird geladen...

X als Dienst beenden - Ähnliche Themen

  1. Mozilla erweitert Betatest für VPN-Dienst

    Mozilla erweitert Betatest für VPN-Dienst: Mozilla hat eine Android-App für den geschlossenen Betatest des kostenpflichtigen VPN-Diensts »Firefox Private Network« freigegeben. Eine iOS-App...
  2. Artikel: Pretix: Open-Source Alternative zu/für Event-Ticketdienstleister

    Artikel: Pretix: Open-Source Alternative zu/für Event-Ticketdienstleister: Pretix ist eine freie Anwendung, um Tickets für Veranstaltungen auszugeben und zu verwalten. Weiterlesen...
  3. Free Software Foundation bewertet Codehosting-Dienste

    Free Software Foundation bewertet Codehosting-Dienste: Die Free Software Foundation (FSF) hat Bewertungen nach den selbst definierten Richtlinien für mehrere Codehosting-Dienste herausgegeben....
  4. Mozilla beendet den Persona-Dienst

    Mozilla beendet den Persona-Dienst: Mozilla will Ende November sein Single-Sign-On-System für Webseiten Persona komplett aufgeben. Seit Mozilla sich aus der Entwicklung zurückgezogen...
  5. iscsi-dienst mit virtl. laufwerk unter solaris einrichten

    iscsi-dienst mit virtl. laufwerk unter solaris einrichten: hallo zusammen das habe ich versucht: sudo pkg install group/feature/storage-server sudo svcadm enable stmf sudo zfs create -V 1g...
  1. Diese Seite verwendet Cookies um Inhalte zu personalisieren. Außerdem werden auch Cookies von Diensten Dritter gesetzt. Mit dem weiteren Aufenthalt akzeptierst du diesen Einsatz von Cookies.
    Information ausblenden