Verdächtiger Startvorgang, Freeze wenn KDE4.

kasumi

Eroberer
Beiträge
59
Hallo.

Ich wollte eben meine FreeBSD-Maschine booten, beim Startvorgang fallen mir einige Verrücktheiten auf:

http://h9.abload.de/img/p10308471fxog.jpg Man sieht es hier.

Zum Beispiel werden dbus und hald zwei Mal gestartet? Wenn ich die Einträge in /etc/rc.conf kommentiere, tauchen diese Meldungen nicht auf, dbus und hald werden überhaupt nicht gestartet, und, O Wunder, Maus und Tastatur funktionieren unter KDM nicht.

Bei dem Abschnitt des Bootvorganges bleibt der Computer für etwa 50 Sekunden stehen, kein Freeze oder so, es dauert nur sehr lange, die KDM configuration zwei mal zu updaten. Des weiteren lösche ich /var/run/dbus/dbus.pid immer wieder, aber der message bus kann trotzdem nie gestartet werden ...

Und KDE freezt auch etwa 3-4 Sekunden, nachdem er vollständig geladen wurde. Die Meldung, die ich noch sehe, bezieht sich auf die Sound Devices, ob KDE sie permanent vergessen soll. Bei Relogs hat gestern aber alles noch hervorragend funktioniert.

Hier noch einige Informationen:

Code:
[root@deneb /dev]# cat /etc/rc.conf
hostname="deneb"
keymap="german.cp850.kbd"
ifconfig_re0="DHCP"
#sshd_enable="YES"
ntpd_enable="YES"
# Set dumpdev to "AUTO" to enable crash dumps, "NO" to disable
dumpdev="AUTO"
hald_enable="YES"
dbus_enable="YES"
local_startup="${local_startup} /usr/local/kde4/etc/rc.d/"
kdm4_enable="YES"
linux_enable="YES"
[root@deneb /dev]# uname -a
FreeBSD deneb 9.0-RELEASE FreeBSD 9.0-RELEASE #0: Tue Jan  3 07:46:30 UTC 2012     root@farrell.cse.buffalo.edu:/usr/obj/usr/src/sys/GENERIC  amd64

Danke für eure Hilfe. :)

Achja, sshd wurde auch kommentiert, da der Start immer 1-2 Minuten gedauert hat ...
 

Akendo

4k3nd0
Beiträge
399
Wie es aussieht wird bei herunterfahren deines System die PID files nicht gelöscht. DBus verweigert wohl den starten wenn es keine neue PID setzten kann. Hast du schon mal versucht die /var/run/dbus/dbus.pid zu entfernen?
 

kasumi

Eroberer
Beiträge
59
Wie es aussieht wird bei herunterfahren deines System die PID files nicht gelöscht. DBus verweigert wohl den starten wenn es keine neue PID setzten kann. Hast du schon mal versucht die /var/run/dbus/dbus.pid zu entfernen?

Öfters schon habe ich diese Datei gelöscht, aber anscheinend bringt das nichts ...
 

HPollak

Foren As
Beiträge
93
Nach deinem Bildschirmfoto nach zu urteilen, versucht dein System den DBus ein 2 mal zu starten, das jedoch in die Hose geht, weil das PID-File schon vorhanden ist, ähnlich sieht es bei den nachfolgenden Prozessen aus.

Kann es sein das dein local_startup="${local_startup} /usr/local/kde4/etc/rc.d/" nochmals den dbus started?

Weiters hilft vielleicht noch weiter (dort wird ein ähnliches Problem beschrieben und die {} durch () ersetzt ): http://forums.freebsd.org/archive/index.php/t-5973.html

Wenn das nicht hilft, schau mal ob du im /var/log/messages, eventuell ist dein system auch anders konfiguriert, dann halt in den entsprechenden Files was der dbus so auspuckt.
 

kasumi

Eroberer
Beiträge
59
Danke.

So ist es aber nicht, wenn ich hald_enable="YES" und dbus_enable="YES" kommentiere, werden sie nicht gestartet. Und beim Bootvorgang auch nicht erwähnt, logischerweise funktionieren Maus und Tastatur dann bei KDM nicht, also liegt es wohl nicht daran.

Sollte es nochmals auftauchen, informiere ich. :D
 

Fusselbär

FreeBSD Noobie
Beiträge
198
Kann es sein das dein local_startup="${local_startup} /usr/local/kde4/etc/rc.d/" nochmals den dbus started?

Das wird es wohl sein, stand auch in UPDATING:
Code:
less +/20111016 /usr/ports/UPDATING
Also, remove /usr/local/kde4/etc/rc.d from local_startup in rc.conf(5).
Failure to do this will cause all enabled scripts in /usr/local/etc/rc.d
to be started twice.
 

kasumi

Eroberer
Beiträge
59
Das bedeutet konkret, ich soll die ganze Zeile auskommentieren?

Probiern wirs einfach mal. :D

Eine Frage hätte ich noch: SSHD. Der braucht auch immer einenhalb Minuten zum starten, ich hab ihn deshalb gleich kommentiert, weil ich SSHD nunmal nicht recht oft brauche. Wartet der auf einen Timeout? Fehlermeldungen gibts keine.
 

Fusselbär

FreeBSD Noobie
Beiträge
198
Die Dauer vom sshd Start dürfte an DHCP liegen.
/etc/sshd muss auf /etc/rc.d/LOGIN warten.
/etc/rc.d/LOGIN wartet wiederum auf /etc/rc.d/DAEMON
der /etc/DAEMON wartet auf /rc.d/NETWORKING
Bis die IP vom DHCP Server des Routers an die FreeBSD Kiste vergeben wurde kann deshalb sshd nicht starten, wenn DHCP verwendet wird.
Ich verwende hier statische IPs im Lan, damit startet sshd blitzschnell.

Falls die FreeBSD Kiste irgendwo steht wo es machbar ist, würde ich statische IPs im Lan bevorzugen.
Sonst muss die FreeBSD Kiste erst auf den DHCP Server warten, bis der eine IP zugewiesen hat.
Wie eine statische IP in FreeBSD gesetzt wird, steht im Handbuch unter
12.8.2. Konfiguration von Netzwerkkarten:
http://www.freebsd.ch/doc/de_DE.ISO8859-1/books/handbook/config-network-setup.html
In der /etc/rc.conf auch das setzen des defaultrouter nicht vergessen:
Code:
defaultrouter="192.168.1.1"
Die 192.168.1.1 steht nur als Beispiel da, es muss natürlich die korrekte IP vom Router sein.

Dann noch für die Namensauflösung sorgen, steht auch im Handbuch
unter 12.10.2. Hostnamen
http://www.freebsd.ch/doc/de_DE.ISO8859-1/books/handbook/configtuning-configfiles.html
Sowohl /etc/resolv.conf als auch /etc/hosts müssen eingerichtet sein, damit alles blitzschnell rennt.

Kleiner Extratipp noch:
Wenn die /etc/rc.conf Fehler enthält startet FreeBSD nicht durch.
Um zu überprüfen, das sich beim editieren der /etc/rc.conf kein Syntax Fehler eingeschlichen hat
kann man folgendes vor dem rebooten tun:
Code:
sh /etc/rc.conf
 

Ähnliche Themen

OpenSUSE 12.1: Gnucash startet nicht mehr

XFCE freezes at startup

Mauszeiger ruckelt

HP PSC 2175 - CUPS druckt nicht

Ubuntu X / dbus problem

Oben