UFS modul unter SUSE installieren

Diskutiere UFS modul unter SUSE installieren im Unix Derivate & sonst. Unix Fragen Forum im Bereich BSD / Unix; hallo Ich möchte freeBSD partitionen (slices) "READ ONLY" unter SUSE 9.1 mounten. kann ich UFS modul nachtraglich installieren, oder...

  1. ccc

    ccc Routinier

    Dabei seit:
    01.11.2003
    Beiträge:
    288
    Zustimmungen:
    0
    hallo

    Ich möchte freeBSD partitionen (slices) "READ ONLY" unter SUSE 9.1 mounten.
    kann ich UFS modul nachtraglich installieren, oder funktioniert nur wenn ich den kernel neu kompiliere ?

    wo kann ich dieses modul finden ?
    auf der SUSE Installations CD's finde einfach nicht.
     
  2. Anzeige

    Anzeige

    Wenn du mehr über Linux erfahren möchtest, dann solltest du dir mal folgende Shellkommandos anschauen.


    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 qmasterrr, 30.05.2004
    qmasterrr

    qmasterrr Foren Gott

    Dabei seit:
    01.01.2004
    Beiträge:
    2.735
    Zustimmungen:
    0
    Ort:
    Germany/NRW/Wesel
    also wenn du es nicht mit modprobe ufs laden kannst musst du wohl den kernel neu kompilieren
     
  4. ccc

    ccc Routinier

    Dabei seit:
    01.11.2003
    Beiträge:
    288
    Zustimmungen:
    0
    modprobe ufs kann ich problemlos laden, aber die BSD partition kann ich nicht mounten

    ich probiere mit

    mount -t ufs /dev/hdb3 /mnt
     
  5. #4 qmasterrr, 31.05.2004
    qmasterrr

    qmasterrr Foren Gott

    Dabei seit:
    01.01.2004
    Beiträge:
    2.735
    Zustimmungen:
    0
    Ort:
    Germany/NRW/Wesel
    mkdir /mnt/bsd

    mount -t ufs /dev/hdb3 /mnt/bsd

    damit erstellste nen neuen ordner und mountest dann dahin
     
  6. ccc

    ccc Routinier

    Dabei seit:
    01.11.2003
    Beiträge:
    288
    Zustimmungen:
    0
    habe gemacht, aber nach wie vor bekomme eine Felermeldung:

    # mount -t ufs /dev/hdb3 /mnt
    mount: wrong fs type, bad option, bad superblock on /dev/hdb3,
    or too many mounted file systems
    linux:~ # mount -t ufs /dev/hdb3 /mnt/bsd
    mount: wrong fs type, bad option, bad superblock on /dev/hdb3,
    or too many mounted file systems
     
  7. ookami

    ookami Haudegen

    Dabei seit:
    06.07.2002
    Beiträge:
    543
    Zustimmungen:
    0
    Du muszt den ufs type festlegen. IIRC

    Lies dazu die manual oder STFSC. ;)
     
  8. #7 qmasterrr, 31.05.2004
    qmasterrr

    qmasterrr Foren Gott

    Dabei seit:
    01.01.2004
    Beiträge:
    2.735
    Zustimmungen:
    0
    Ort:
    Germany/NRW/Wesel
    aus der kernel Doc

    USING UFS
    =========

    mount -t ufs -o ufstype=type_of_ufs device dir


    UFS OPTIONS
    ===========

    ufstype=type_of_ufs
    UFS is a file system widely used in different operating systems.
    The problem are differences among implementations. Features of
    some implementations are undocumented, so its hard to recognize
    type of ufs automatically. That's why user must specify type of
    ufs manually by mount option ufstype. Possible values are:

    old old format of ufs
    default value, supported os read-only

    44bsd used in FreeBSD, NetBSD, OpenBSD
    supported os read-write

    ufs2 used in FreeBSD 5.x
    supported os read-only

    sun used in SunOS (Solaris)
    supported as read-write

    sunx86 used in SunOS for Intel (Solarisx86)
    supported as read-write

    nextstep
    used in NextStep
    supported as read-only

    nextstep-cd
    used for NextStep CDROMs (block_size == 2048)
    supported as read-only

    openstep
    used in OpenStep
    supported as read-only


    POSSIBLE PROBLEMS
    =================

    There is still bug in reallocation of fragment, in file fs/ufs/balloc.c,
    line 364. But it seem working on current buffer cache configuration.


    BUG REPORTS
    ===========

    Any ufs bug report you can send to daniel.pirkl@email.cz (do not send
    partition tables bug reports.)
    ./filesystems/ufs.txt lines 21-56/56 (END)
     
  9. ccc

    ccc Routinier

    Dabei seit:
    01.11.2003
    Beiträge:
    288
    Zustimmungen:
    0
    jetzt scheint klar zu sein

    bei mir ist freeBSD 5.2 installiert, also braucht es ufs2 und nicht ufs

    korrekt wäre es vermutlich in meinem fall:

    # mount -t ufs2 /dev/hdb3 /mnt/bsd

    dies geht aber NICHT, weil ufs2 modul nicht installiert ist

    modprobe ufs2

    bricht bei mir mit fehlermeldung ab
     
  10. devilz

    devilz Pro*phet

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen

    Falsch !!!


    "aus der kernel Doc

    USING UFS
    =========

    mount -t ufs -o ufstype=type_of_ufs device dir"

    also mount -t ufs -o ufstype=ufs2 /dev/hdb3 /mnt/bsd
     
  11. #10 qmasterrr, 31.05.2004
    qmasterrr

    qmasterrr Foren Gott

    Dabei seit:
    01.01.2004
    Beiträge:
    2.735
    Zustimmungen:
    0
    Ort:
    Germany/NRW/Wesel
    der devilz hat vollkommen recht :)
     
  12. devilz

    devilz Pro*phet

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    Danke :)
    Aber ich hab ja nur gelesen .... :D
     
  13. ccc

    ccc Routinier

    Dabei seit:
    01.11.2003
    Beiträge:
    288
    Zustimmungen:
    0
    bekomme aber Fehlermeldung:

    # mount -t ufs -o ufstype=ufs2 /dev/hdb3 /mnt/bsd
    mount: wrong fs type, bad option, bad superblock on /dev/hdb3,
    or too many mounted file systems
     
  14. #13 qmasterrr, 31.05.2004
    qmasterrr

    qmasterrr Foren Gott

    Dabei seit:
    01.01.2004
    Beiträge:
    2.735
    Zustimmungen:
    0
    Ort:
    Germany/NRW/Wesel
    mach mal nen slash hinter dem mount point nen mount point als datei ist schlecht
     
  15. #14 qmasterrr, 31.05.2004
    qmasterrr

    qmasterrr Foren Gott

    Dabei seit:
    01.01.2004
    Beiträge:
    2.735
    Zustimmungen:
    0
    Ort:
    Germany/NRW/Wesel
    ne anderesrum ne datei als mountpoint
     
  16. ccc

    ccc Routinier

    Dabei seit:
    01.11.2003
    Beiträge:
    288
    Zustimmungen:
    0
    mit dem slash geht auch nicht
     
Thema: UFS modul unter SUSE installieren
Besucher kamen mit folgenden Suchen
  1. opensuse ufs2

Die Seite wird geladen...

UFS modul unter SUSE installieren - Ähnliche Themen

  1. Git 2.8 unterstützt paralleles Laden von Submodulen

    Git 2.8 unterstützt paralleles Laden von Submodulen: Mit der Freigabe von Git 2.8.0 haben die Entwickler das Quellcode-Verwaltungssystem um diverse neue Funktionen ergänzt. Die wohl prominenteste...
  2. Pangea Sun: Modulares Notebook sucht Unterstützer

    Pangea Sun: Modulares Notebook sucht Unterstützer: Eine Kampagne auf Indiegogo versucht, 600.000 US-Dollar zu sammeln, um ein modulares, offenes und damit nachhaltigeres Notebook zu entwickeln. Das...
  3. Qt ändert Lizenz einiger Module

    Qt ändert Lizenz einiger Module: Die Qt Company ändert die Lizenz der Module Wayland Compositor, Application Manager und PDF von der LGPLv3 zur GPLv3. Damit fallen sie künftig...
  4. Go 1.13 mit sicheren Modul-Downloads

    Go 1.13 mit sicheren Modul-Downloads: Google hat die Systemprogrammiersprache Go in Version 1.13 freigegeben. Der Download von Modulen wird nun mit kryptografischen Hashes abgesichert...
  5. Raspberry Pi: Neues Kamera-Modul verfügbar

    Raspberry Pi: Neues Kamera-Modul verfügbar: Fast drei Jahre nach der ersten Vorstellung eines Kameramoduls für den Kleinstrechner Raspberry Pi liefert die hinter dem Gerät stehende...
  1. Diese Seite verwendet Cookies um Inhalte zu personalisieren. Außerdem werden auch Cookies von Diensten Dritter gesetzt. Mit dem weiteren Aufenthalt akzeptierst du diesen Einsatz von Cookies.
    Information ausblenden