Ubuntu und Swat

Diskutiere Ubuntu und Swat im Debian/Ubuntu/Knoppix Forum im Bereich Linux Distributionen; Hallo, ich bin neu hier und beschäftige mich schon länger mit Linux habe schon so einige Distro´s durch und bin bei Ubuntu hängen geblieben. Aber...

  1. #1 Subchannel, 03.03.2006
    Zuletzt bearbeitet: 04.03.2006
    Subchannel

    Subchannel Foren As

    Dabei seit:
    03.03.2006
    Beiträge:
    87
    Zustimmungen:
    0
    Hallo,
    ich bin neu hier und beschäftige mich schon länger mit Linux habe schon so einige Distro´s durch und bin bei Ubuntu hängen geblieben. Aber eine frage habe ich wie bekomme ich Swat unter Ubuntu 5.10 zum laufen? Und was ist der unterschied zwischen Ubuntu Server und Ubuntu? Gibs da was besonderes oder ist es einfach nur abgespeckt? Habe es wie in der manpage beschrieben gemacht und schon Beiträge im Internet gelesen aber ich bekomme einfach kein zugriff, ich bin mir nicht sicher ob swat überhaupt richtig läuft.
    :hilfe2:
    inetd.conf sieht so aus:
    #<off># netbios-ssn stream tcp nowait root /usr/sbin/tcpd /usr/sbin/smbd
    #<off># swat stream tcp nowait.400 root /usr/sbin/tcpd /usr/sbin/swat
     
  2. Anzeige

    Anzeige

    Wenn du mehr über Linux erfahren möchtest, dann solltest du dir mal folgende Shellkommandos anschauen.


    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. heady

    heady Routinier

    Dabei seit:
    13.12.2005
    Beiträge:
    424
    Zustimmungen:
    0
    Ort:
    im Herzen Europas
    zum thema swat:
    zuerst: apt-get install swat
    dann: man swat -> das tun, was beim punkt installation steht
     
  4. #3 Subchannel, 04.03.2006
    Subchannel

    Subchannel Foren As

    Dabei seit:
    03.03.2006
    Beiträge:
    87
    Zustimmungen:
    0
    Hat aber nix gebracht, dennoch danke!
    Ich hoffe es hilft mir hier mal jemand. Wenn nicht muss ich es mal wieder selber probieren aber ich dachte dafür sind foren doch da.
     
  5. heady

    heady Routinier

    Dabei seit:
    13.12.2005
    Beiträge:
    424
    Zustimmungen:
    0
    Ort:
    im Herzen Europas
    was meinst du mit hat mir nix gebracht, was ist passiert, gabs Fehler?
    du musst schon genauere und detailliertere angaben machen
     
  6. #5 Nemesis, 04.03.2006
    Nemesis

    Nemesis N3RD

    Dabei seit:
    28.01.2005
    Beiträge:
    2.176
    Zustimmungen:
    0
  7. heady

    heady Routinier

    Dabei seit:
    13.12.2005
    Beiträge:
    424
    Zustimmungen:
    0
    Ort:
    im Herzen Europas
    ja im google zu suchen ist sicher komplizierter als hier ein eigenen thread zu erstellen ;)
     
  8. #7 Subchannel, 04.03.2006
    Subchannel

    Subchannel Foren As

    Dabei seit:
    03.03.2006
    Beiträge:
    87
    Zustimmungen:
    0
    Was soll das denn heißen? Ich habe ja schon ne menge probiert und die genannten einträge gemacht(aus der manpage) aber ich kann swat nicht über den browser aufrufen. Ich habe mir auch schon selbst anleitungen gesucht und bin danach vorgegangen aber es funzt nicht ich würde hier keinen tread aufmachen wenn es geklappt hätte. Ich weiß einfach nicht wie das unter Ubuntu gemacht wird und habe gehofft das mir hier einer helfen kann.
     
  9. #8 Nemesis, 04.03.2006
    Nemesis

    Nemesis N3RD

    Dabei seit:
    28.01.2005
    Beiträge:
    2.176
    Zustimmungen:
    0
    was hast du denn genau gemacht bis jetzt? beschreib ma bitte.
     
  10. #9 schwedenmann, 04.03.2006
    schwedenmann

    schwedenmann Foren Gott

    Dabei seit:
    18.11.2003
    Beiträge:
    2.694
    Zustimmungen:
    5
    Ort:
    Wegberg
    swat

    Hallo

    So wie ich das sehe mußt su

    die 2. Zeile auskommentiern, also "<off> entfernen, dann entweder reboot oder
    inetd.conf neueinlesen.

    Dann per Browser auf port 901 lauschen.
    Vorher aber dei /etc/samba/conf sichern, die wird nämlich drch swat überschrieben




    Mfg
    schwedenmann

    P.S.
    Du weißt das swat das Rootpaßwort im Klartext übermittelt !!
     
  11. #10 heady, 04.03.2006
    Zuletzt bearbeitet: 04.03.2006
    heady

    heady Routinier

    Dabei seit:
    13.12.2005
    Beiträge:
    424
    Zustimmungen:
    0
    Ort:
    im Herzen Europas
    danke damit hast du uns allen sehr geholfen...schön und gut, das du dich informiert hast, aber wenn man ein problem hat, sollte man es genau erläutern...

    ps: wie man die inetd.conf und die /etc/services konfiguriert, damit swat läuft müsste eigentlich auch in den man pages stehen...ich gehe mal davon aus das du das getan hast...

    eine letzte idee wäre, dass der 901er port durch entsprechende software (firewall) gesperrt ist...

    hast du schon in den logfiles(ich glaube /var/log/messages) nachgeschaut, was dort ausgespuckt wird??
     
  12. #11 Subchannel, 04.03.2006
    Subchannel

    Subchannel Foren As

    Dabei seit:
    03.03.2006
    Beiträge:
    87
    Zustimmungen:
    0
    Habe alles schon ausgeklammert. Was meinst du mit root psw. im klartext übermittelt. Das problem ist wenn ich im browser: http://localhost:901 aufrufe bekomme ich die antwort "Bei dem versuch localhost:901 zu erreichen wurde die verbindung zurückgesetzt" Mit der FW habe ich kein plan sind bei ubuntu die regeln schon vorkonfiguriert? An welche stelle oder wir genau muss ich swat installieren? Muss es noch in den smb ordner?
     
  13. #12 Nemesis, 04.03.2006
    Nemesis

    Nemesis N3RD

    Dabei seit:
    28.01.2005
    Beiträge:
    2.176
    Zustimmungen:
    0
    ähm, wie hast du swat installiert? ich hoffe doch mit apt.
    root pw in klartext übermittelt heisst, da steht dann nich irgen ein "RGB%&7745IG567" sondern dein <passwort>
    hast du ne fw installiert?
     
  14. #13 Subchannel, 05.03.2006
    Subchannel

    Subchannel Foren As

    Dabei seit:
    03.03.2006
    Beiträge:
    87
    Zustimmungen:
    0
    Habe keine FW installiert. Ich habe swat mit dem Paketmanager installiert. Ich probiers nochmal mit apt und sage euch dann was passiert ist. Danke bis dahin.
     
  15. heady

    heady Routinier

    Dabei seit:
    13.12.2005
    Beiträge:
    424
    Zustimmungen:
    0
    Ort:
    im Herzen Europas
    ich hatte das problem, das ich bei meinem swat(wars der swat?) server nicht vom localhost also lokal zugreifen konnte, sondern nur außerhalb vom netz...hast du das auch schon mal probiert?

    edit: achja...wie startest du den swat?
     
  16. #15 Subchannel, 05.03.2006
    Zuletzt bearbeitet: 05.03.2006
    Subchannel

    Subchannel Foren As

    Dabei seit:
    03.03.2006
    Beiträge:
    87
    Zustimmungen:
    0
    Wie ich swat starte? Habe einfach das gemacht was in der manpage steht oder besser so wie es vorher immer gemacht habe aber auf port 901 läuft kein deamon wenn ich mit nmap scanne. ipchains habe ich auch nicht festgelegt. Sowohl intern und extern komme ich nicht auf swat. Bin jetzt die ganze installation nochmal durchgegangen und meiner meinung nach ist alles so wie es sein soll. Ich habe 2 Netzwerkkarten aber die eine ist inaktiv kann es daran liegen? Ich möchte ja nur eine benutzen. Ich weiß das gehört nicht hierher aber weiß jemand wie ich bei Suse 10.0 die installationsquellen so erweitere das ich dafür swat bekomme?
     
  17. #16 supersucker, 05.03.2006
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    also ich hab von swat keine ahnung, aber:

    und

    und du hast keine firewall laufen?!?

    was sagt uns das?

    das dein swat höchstwahrscheinlich gar nicht läuft.

    mach mal ein:

    Code:
    ps aux | grep -i swat
    und kuck ob das ding überhaupt läuft!

    wenn nicht starte das ding halt, wie steht im ubuntu-handbuch ausführlich beschrieben steht, normalerweise über sowas wie:

    Code:
    /etc/init.d/swat start
    wenn das nicht klappt kuck unter /etc/init.d ob überhaupt ein start-script für swat vorhanden ist.
     
  18. #17 Nemesis, 05.03.2006
    Zuletzt bearbeitet: 05.03.2006
    Nemesis

    Nemesis N3RD

    Dabei seit:
    28.01.2005
    Beiträge:
    2.176
    Zustimmungen:
    0
    hm, bei mir will swat gerade auch nicht, komisch, ich schau ma an was es liegt, wenn ich den fehler hab, dann poste ich ihn hier, vielleicht is bei dir das selbe

    edit:
    hm, ka warums net will.
    naja, editiert man halt wieder von hand.

    könntest du auch machen, is nicht viel schwehrer, der unterschied is nur, dass swat farbe hat ;)
    die datei is die /etc/samba/smb.conf
     
  19. #18 Subchannel, 05.03.2006
    Subchannel

    Subchannel Foren As

    Dabei seit:
    03.03.2006
    Beiträge:
    87
    Zustimmungen:
    0
    Jo das wars. Gibt kein Startskript für das ding. Danke!!! Nun weiß ich auch nicht warum. Bin gerade am Suse 10.0 aufsetzen und probiere es da nochmal. Danke an euch alle. Ich melde mich nochmal wenn ich mehr weiß.
     
  20. #19 Nemesis, 05.03.2006
    Nemesis

    Nemesis N3RD

    Dabei seit:
    28.01.2005
    Beiträge:
    2.176
    Zustimmungen:
    0
    Der Eintrag für den älteren Typ der Kontrolldatei kann sein:

    Code:
    # swat is the Samba Web Administration Tool
    	swat stream tcp nowait.400 root /usr/sbin/swat swat
    Ein Eintrag für die neuere Variante der Kontrolldatei in xinetd könnte so aussehen:

    Code:
    # default: off
    # description: SWAT is the Samba Web Admin Tool. Use swat \
    #              to configure your Samba server. To use SWAT, \
    #              connect to port 901 with your favorite web browser.
    service swat
    {
    	port    = 901
    	socket_type     = stream
    	wait    = no
    	only_from = localhost
    	user    = root
    	server  = /usr/sbin/swat
    	log_on_failure  += USERID
    	disable = yes
    }
     
  21. #20 Goodspeed, 06.03.2006
    Zuletzt bearbeitet: 06.03.2006
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.168
    Zustimmungen:
    2
    Ort:
    Dresden
    Mach mal in der inetd.conf aus
    Code:
    #<off># swat stream tcp nowait.400 root /usr/sbin/tcpd /usr/sbin/swat
    ein
    Code:
    swat stream tcp nowait.400 root /usr/sbin/tcpd /usr/sbin/swat
    Und danach als root oder per sudo ein:

    /etc/init.d/inetd restart

    P.S.: Für SWAT gibt es kein Start-Script, da es über den inetd gestartet wirde ...
     
Thema:

Ubuntu und Swat

Die Seite wird geladen...

Ubuntu und Swat - Ähnliche Themen

  1. Xubuntu wechselt zu GitHub

    Xubuntu wechselt zu GitHub: Der freie Ubuntu-Ableger Xubuntu zieht von Launchpad zu Github. Die Entwickler erhoffen sich von diesem Schritt eine größere Beteiligung der...
  2. Ubuntu 20.04.1 LTS erscheint im Juli

    Ubuntu 20.04.1 LTS erscheint im Juli: Die erste Aktualisierung für Ubuntu 20.04.1 LTS »Focal Fossa« erscheint am 23. Juli und behebt hauptsächlich Fehler der stabilen Veröffentlichung...
  3. Ubuntu 20.10 heißt »Groovy Gorilla«

    Ubuntu 20.10 heißt »Groovy Gorilla«: Das für den 22. Oktober zur Veröffentlichung vorgesehene Ubuntu 20.10 trägt den Beinamen »Groovy Gorilla«. Weiterlesen...
  4. Ubuntu 20.04 LTS freigegeben

    Ubuntu 20.04 LTS freigegeben: Die Ubuntu-Gemeinschaft hat die Linux-Distribution Ubuntu 20.04 LTS »Focal Fossa« wie geplant mit zahlreichen Neuerungen veröffentlicht....
  5. Ubuntu 20.04 LTS als Beta freigegeben

    Ubuntu 20.04 LTS als Beta freigegeben: Canonical hat die Betaversion zu Ubuntu 20.04 LTS »Focal Fossa« zum Testen freigegeben. Die stabile Version soll am 23. April erscheinen....
  1. Diese Seite verwendet Cookies um Inhalte zu personalisieren. Außerdem werden auch Cookies von Diensten Dritter gesetzt. Mit dem weiteren Aufenthalt akzeptierst du diesen Einsatz von Cookies.
    Information ausblenden