UBUNTU 9.04 Aufloesungsproblem

Diskutiere UBUNTU 9.04 Aufloesungsproblem im Installation & Basiskonfiguration Forum im Bereich Linux/Unix Allgemein; Tachchen, Ich moechte mich von Vorne raus dafuer entschuldigen, wieder einen Aufloesungsthreat geoeffnet zu haben. Jedoch auch die Suche mit...

  1. KlausK

    KlausK Jungspund

    Dabei seit:
    05.05.2009
    Beiträge:
    10
    Zustimmungen:
    0
    Tachchen,

    Ich moechte mich von Vorne raus dafuer entschuldigen, wieder einen Aufloesungsthreat geoeffnet zu haben. Jedoch auch die Suche mit Google hat mich nicht zu dem Ergebniss gefuehrt das ich brauche.

    Folgendes Problem:

    Ich habe ein 64bit System AMD Athlon, eine nVidia Geforce 8800 und einen ACER AL1916W Monitor.
    Das System UBUNTU habe ich über Wubi installiert (läuft klasse). Wie schon im Titel habe ich Probleme die Auflösung korrekt einzustellen.
    Den neusten Graphik Treiber habe ich installiert (Version 180).
    Leider habe ich Probleme meine 1440x900 Pixel drauf zu bekommen. Im X-Server Fenster von nVidia kann ich zwar die Auflösung eintragen, aber dadurch kann ich nur den Desktop weiter verschieben (nach rechts und nach unten), jedoch bleibt die aktuelle Auflösung von 1280 x1024 bestehen.

    Code:
    sudo nvidia-xconfig
    bringt auch nicht den gewünschten Effekt und in der xorg.conf finde ich keine Auflösungsdaten.
    Code:
    Section "ServerLayout"
        Identifier     "Default Layout"
        Screen         "Default Screen" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Mouse0" "CorePointer"
    EndSection
    
    Section "Module"
        Load           "glx"
    EndSection
    
    Section "InputDevice"
    
        # generated from default
        Identifier     "Keyboard0"
        Driver         "keyboard"
    EndSection
    
    Section "InputDevice"
    
        # generated from default
        Identifier     "Mouse0"
        Driver         "mouse"
        Option         "Protocol" "auto"
        Option         "Device" "/dev/psaux"
        Option         "Emulate3Buttons" "no"
        Option         "ZAxisMapping" "4 5"
    EndSection
    
    Section "Monitor"
        Identifier     "Configured Monitor"
    EndSection
    
    Section "Device"
        Identifier     "Configured Video Device"
        Driver         "nvidia"
    EndSection
    
    Section "Screen"
        Identifier     "Default Screen"
        Device         "Configured Video Device"
        Monitor        "Configured Monitor"
        DefaultDepth    24
        Option         "NoLogo" "True"
        SubSection     "Display"
            Depth       24
            Modes      "nvidia-auto-select"
        EndSubSection
    EndSection
    Ich habe mich schon durch ein paar Foren gehangelt, aber noch keine Antwort auf mein Problem gefunden. Ich wäre euch sehr verbunden, wenn mir einer das erklären könnte, oder einen passenden Link zu anbieten kann.

    Die Texte in Wiki verstehe ich nur zum Teil, deswegen auch meine bitte an euch.
    Ich bin abhängig von Windows und möchte diese Abhängigkeit niederlegen. Wenn ich das geschafft habe, höre ich auch auf zu rauchen ^^

    Gruß Klaus
     
  2. Anzeige

    Anzeige

    Wenn du mehr über Linux erfahren möchtest, dann solltest du dir mal folgende Shellkommandos anschauen.


    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 slackfan, 05.05.2009
    slackfan

    slackfan König

    Dabei seit:
    18.04.2006
    Beiträge:
    809
    Zustimmungen:
    0
    Ort:
    Bonn
    Hallo,

    schon http://henry78.at/tech/acer-al1916w-running-xorg-at-1440x900/ und http://ubuntuforums.org/archive/index.php/t-276303.html probiert? Führt mich zu etwas derartigem:

    Code:
    Section "Monitor"
        Identifier     "Configured Monitor"
        Option         "DPMS"
        Modeline     "1440x900_55.89" 98.96 1440 1520 1672 1904 900 901 904 930 -HSync +Vsync
    EndSection
    
    Section "Screen"
        Identifier     "Default Screen"
        Device         "Configured Video Device"
        Monitor        "Configured Monitor"
        DefaultDepth    24
        Option         "NoLogo" "True"
        SubSection     "Display"
            Depth       24
            Modes      "1440x900_55.89"
        EndSubSection
    EndSection
    Keine Garantie.

    cu
     
  4. KlausK

    KlausK Jungspund

    Dabei seit:
    05.05.2009
    Beiträge:
    10
    Zustimmungen:
    0
    Hab es soeben versucht. In der xorg.conf schreibt er es ohne Probleme rein. Auch ein reboot hilft leider nichts.

    Aber danke für deine Hilfe...bin zuvor nicht auf die Idee gekommen nach meinem Monitor zu suchen...hatte alles nur nicht diesen Begriff.


    regards
     
  5. defcon

    defcon Kaiser
    Moderator

    Dabei seit:
    22.08.2005
    Beiträge:
    1.493
    Zustimmungen:
    1
    Ort:
    Bruchsal
    Versuchs mal so

    Code:
    sudo dpkg-reconfigure xserver-xorg
    
     
  6. #5 KlausK, 05.05.2009
    Zuletzt bearbeitet: 05.05.2009
    KlausK

    KlausK Jungspund

    Dabei seit:
    05.05.2009
    Beiträge:
    10
    Zustimmungen:
    0
    Bringt mich nur soweit, dass er nach der Tastatur fragt...aber nicht nach Monitor

    EDIT:
    ich versuche es nun mit ENVY. Mal sehen ob das was bringt.


    regards
     
  7. karru

    karru OSX'ler

    Dabei seit:
    02.05.2006
    Beiträge:
    338
    Zustimmungen:
    0
    Uhm...
    nVidia bringt doch das Tool "nvidia-settings" mit, wo du alles einstellen kannst...
    Zumindest bei mir ;P

    Probier mal `sudo nvidia-settings` aus, da der 2. Menupunkt "Display Configuration".

    MfG
     
  8. KlausK

    KlausK Jungspund

    Dabei seit:
    05.05.2009
    Beiträge:
    10
    Zustimmungen:
    0
    Naja...die X-Server Settings, die dieser Befehl aufruft, habe ich schon alle durch. Geht auch nichts.

    regards
     
  9. KlausK

    KlausK Jungspund

    Dabei seit:
    05.05.2009
    Beiträge:
    10
    Zustimmungen:
    0
    Anscheinend habe ich das Problem erkannt, es lag direkt vor meiner Nase als ich die Graphikkarte ausgebaut hatte...

    Laut BIOS meines Rechners hat die anscheinend einen defekt, der die Kommunikation zum Monitor anscheinend unterbricht. Deswegen hat UBUNTU auch nicht gewusst, welcher Monitor da dran hängt.

    BIOS Fehler: 1x lang, 3 mal kurz piepsen.
    Übersetzung: Ab BIOS 4.5 (habe glaube ich eine 9er Version) bedeutet es, die Graka hat nen Schaden.

    Habe eben die Graka zurück gegeben und bekomme die Woche eine neue. Mal sehen was dann ist.


    regards
     
  10. KlausK

    KlausK Jungspund

    Dabei seit:
    05.05.2009
    Beiträge:
    10
    Zustimmungen:
    0
    Folgender Stand:

    habe die neue Graka bekommen. Ubuntu neu installiert, Auflösung ist da (wunder). Treiber installiert, Maschine neu gestartet, wieder gleiches Problem wie vorher...

    X-Server konfigurieren bringt nichts...

    Effekte gehen wunderbar nur kann ich immernoch nicht die verdammte Auflösung einstellen (verzeihung).

    *help*


    regards
     
  11. #10 gropiuskalle, 21.05.2009
    gropiuskalle

    gropiuskalle terra incognita

    Dabei seit:
    01.07.2006
    Beiträge:
    4.857
    Zustimmungen:
    1
    Ort:
    Berlin
    Ubuntu lässt Grafikkarten, Monitore etc. mittlerweile über HAL automatisch (juhu!) erkennen, offenbar geht dabei etwas schief. Versuche es doch mal mit einer "klassischen" xorg.conf, indem Du die Autoerkennung abschaltest.

    Code:
    Option "AutoAddDevices" "false"
    Siehe → hier

    Eine basis-.conf könntest Du aus einem live-System klauen ggf. anpassen.

    Edit:

    Na das muss ja nun nicht sein, oder?
     
  12. KlausK

    KlausK Jungspund

    Dabei seit:
    05.05.2009
    Beiträge:
    10
    Zustimmungen:
    0
    Danke für den Tipp mit HAL. Werde ich heute abend mal ausprobieren.
    Aber wo bekomme ich eine basis-.conf her? Sorry wenn ich so doof frage...

    regards
     
  13. #12 gropiuskalle, 21.05.2009
    gropiuskalle

    gropiuskalle terra incognita

    Dabei seit:
    01.07.2006
    Beiträge:
    4.857
    Zustimmungen:
    1
    Ort:
    Berlin
    Wie gesagt:

    Also: Knoppix oder sowas booten und von dort die xorg.conf kopieren. Eventuell reicht Dir auch schon → das hier.
     
  14. doc

    doc Kaffeetrinker

    Dabei seit:
    26.08.2006
    Beiträge:
    586
    Zustimmungen:
    0
    Ort:
    bremen
    Code:
    Section "Device"
        Identifier     "Device0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        [B]Option         "MetaModes"     "1280x1024;1152x864;1024x768;800x600;640x480"[/B]
        ...
        ...
    EndSection
    die fett gedruckte zeile sorg dafür, das du in deinem windowmanager diese auflösungen zur verfügung hast. bin mir nicht sicher ob es reicht nur die grösste gewünschte auflösung anzugeben.

    wenn der monitor nicht richtig erkannt wird, dann einfach deine monitordaten eingeben.

    Code:
    Section "Monitor"
        Identifier     "Monitor0"
        VendorName     "Unknown"
        ModelName      "Unknown"
        [B]HorizSync       30.0 - 110.0
        VertRefresh     50.0 - 150.0[/B]
        Option         "DPMS"
    EndSection
    und das graka und moni über hal konfiguriert werden halt ich noch fürn gerücht.
     
  15. #14 gropiuskalle, 21.05.2009
    gropiuskalle

    gropiuskalle terra incognita

    Dabei seit:
    01.07.2006
    Beiträge:
    4.857
    Zustimmungen:
    1
    Ort:
    Berlin
    Ich mittlerweile auch.

    Tut mir wirklich leid, da hätte ich mal genauer hinlesen sollen.
     
  16. #15 KlausK, 22.05.2009
    Zuletzt bearbeitet: 22.05.2009
    KlausK

    KlausK Jungspund

    Dabei seit:
    05.05.2009
    Beiträge:
    10
    Zustimmungen:
    0
    Was mich ja wirklich gewundert hat, ist die Tatsache, dass, bevor ich den nVidia Treiber installiert hatte, die Auflösung korrekt war und auch der Monitor mit Name in den Einstellungen genannt wurde. Danach erschien nur "Unbekannter Monitor".

    Aber wenn ich den Treiber nicht installiere, habe ich eben auch keine 3D unterstützung. Ich versuche das mal manuell zu installieren (nachdem ich ein frisches UBUNTU installiert habe) und melde mich dann nochmal.

    regards

    P.S.: Danke für eure Hilfe und Geduld.
    .
    .
    .
    EDIT (autom. Beitragszusammenführung) :
    .

    nach etlichen Versuchen gebe ich schlicht und ergreifend auf. Mir gelingt es einfach nicht den X-Server korrekt einzustellen, warum auch immer...

    Ich bedanke mich nochmal für die geleistete Hilfestellung.


    MfG

    Klaus
     
  17. doc

    doc Kaffeetrinker

    Dabei seit:
    26.08.2006
    Beiträge:
    586
    Zustimmungen:
    0
    Ort:
    bremen
    öhmm wieso ? das einzige was du machen musst, ist:

    Option "MetaModes" "1440x900"

    in deine oben gepostete, von nvidia-xconfig erstellte config zu packen, und ich würde noch

    Modes "nvidia-auto-select"

    daraus entfernen, und dann würde ich mich schwer wundern, wenn du dann nicht in der grafischen oberfläche deiner wahl diese auflösung auswählen kannst.

    Code:
    Section "ServerLayout"
        Identifier     "Default Layout"
        Screen         "Default Screen" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Mouse0" "CorePointer"
    EndSection
    
    Section "Module"
        Load           "glx"
    EndSection
    
    Section "InputDevice"
    
        # generated from default
        Identifier     "Keyboard0"
        Driver         "keyboard"
    EndSection
    
    Section "InputDevice"
    
        # generated from default
        Identifier     "Mouse0"
        Driver         "mouse"
        Option         "Protocol" "auto"
        Option         "Device" "/dev/psaux"
        Option         "Emulate3Buttons" "no"
        Option         "ZAxisMapping" "4 5"
    EndSection
    
    Section "Monitor"
        Identifier     "Configured Monitor"
    EndSection
    
    Section "Device"
        Identifier     "Configured Video Device"
        Driver         "nvidia"
        Option         "MetaModes"     "1440x900"
    EndSection
    
    Section "Screen"
        Identifier     "Default Screen"
        Device         "Configured Video Device"
        Monitor        "Configured Monitor"
        DefaultDepth    24
        Option         "NoLogo" "True"
        SubSection     "Display"
            Depth       24
             EndSubSection
    EndSection
     
  18. KlausK

    KlausK Jungspund

    Dabei seit:
    05.05.2009
    Beiträge:
    10
    Zustimmungen:
    0
    Ich weiß nicht, ob du es mitbekommen hast...ich HABE das alles so eingestellt, wie von euch bescrhieben. hab zig mal die Xorg.conf umgeschrieben und verändert und es hat keinen Erfolg gebracht.

    Sei mir nicht böse ich hab mit diesem Problem allein 12 Stunden am Rechner verbracht, ich hab einfach die Schn*** voll. Ist nichts gegen dich/euch persönlich. Vllt bin ich auch zu blöd für oder es hängt wirklich an meiner Hardware.


    regards
     
Thema: UBUNTU 9.04 Aufloesungsproblem
Besucher kamen mit folgenden Suchen
  1. monitordaten bei knoppix 7 6 ermitteln

Die Seite wird geladen...

UBUNTU 9.04 Aufloesungsproblem - Ähnliche Themen

  1. Xubuntu wechselt zu GitHub

    Xubuntu wechselt zu GitHub: Der freie Ubuntu-Ableger Xubuntu zieht von Launchpad zu Github. Die Entwickler erhoffen sich von diesem Schritt eine größere Beteiligung der...
  2. Ubuntu 20.04.1 LTS erscheint im Juli

    Ubuntu 20.04.1 LTS erscheint im Juli: Die erste Aktualisierung für Ubuntu 20.04.1 LTS »Focal Fossa« erscheint am 23. Juli und behebt hauptsächlich Fehler der stabilen Veröffentlichung...
  3. Ubuntu 20.10 heißt »Groovy Gorilla«

    Ubuntu 20.10 heißt »Groovy Gorilla«: Das für den 22. Oktober zur Veröffentlichung vorgesehene Ubuntu 20.10 trägt den Beinamen »Groovy Gorilla«. Weiterlesen...
  4. Ubuntu 20.04 LTS freigegeben

    Ubuntu 20.04 LTS freigegeben: Die Ubuntu-Gemeinschaft hat die Linux-Distribution Ubuntu 20.04 LTS »Focal Fossa« wie geplant mit zahlreichen Neuerungen veröffentlicht....
  5. Ubuntu 20.04 LTS als Beta freigegeben

    Ubuntu 20.04 LTS als Beta freigegeben: Canonical hat die Betaversion zu Ubuntu 20.04 LTS »Focal Fossa« zum Testen freigegeben. Die stabile Version soll am 23. April erscheinen....
  1. Diese Seite verwendet Cookies um Inhalte zu personalisieren. Außerdem werden auch Cookies von Diensten Dritter gesetzt. Mit dem weiteren Aufenthalt akzeptierst du diesen Einsatz von Cookies.
    Information ausblenden