transcode läßt sich nicht installieren

thobit

Routinier
Beiträge
265
Moin!
Ich versuche gerade transcode unter Mandriva Free 64-bit zu installieren. Bekomme bei rpmdrake als Fehlermeldung:

Code:
Das folgende Paket kann nicht ausgewählt werden:

- transcode-1.0.3-3plf2008.0.x86_64 (wegen nicht erfüllter Abhängigkeit von libWand-10.7.0.so.0()(64bit) )

Ich kann libWand allerdings nicht finden. Ich habe schon versucht andere rpm's direkt aus dem Netz zu installieren, bin aber immer wieder gescheitert. Habe mit easyurpmi alle Repos freigeschaltet und komme nicht weiter.

mfg
thobit
 

thobit

Routinier
Beiträge
265
Die Installation der lib64magick10.7.0 hilft mir leider auch nicht weiter transcode verlangt weiterhin die libwand. Verusuche ich die libWand zu installieren (auch wenn sie für Suse gedacht sind) wird nach libmagick verlangt, welches er auch nicht finden kann.
Gibt es denn Alternativen zu transcode die mit k3b zusammenarbeiten?

mfg
thobit

EDIT: Ok, bin einen Schritt weiter. Wollte transcode von Hand compilieren und habe in der Anleitung gelesen, dass ffmpeg benötigt wird. Also das aus den Repos installiert und jetzt will er libdvdread, die eigentlich installiert ist. Werde mal weiterforschen.
 
Zuletzt bearbeitet:
G

Gast1

Gast
Die Installation der lib64magick10.7.0 hilft mir leider auch nicht weiter transcode verlangt weiterhin die libwand.

Code:
rpm -qp --provides lib64magick10.7.0-6.3.2.9-10.2mdv2008.0.x86_64.rpm |grep -i wand
Warnung: lib64magick10.7.0-6.3.2.9-10.2mdv2008.0.x86_64.rpm: Header V3 
[B]libWand-10.7.0.so.0()(64bit)[/B]

rpm -qp --requires transcode-1.0.3-3plf2008.0.x86_64.rpm |grep -i wand
Warnung: transcode-1.0.3-3plf2008.0.x86_64.rpm: Header V3 DSA-Signatur: NOKEY, key ID caba22ae
[B]libWand-10.7.0.so.0()(64bit)[/B]
Passt doch alles.

Irgendwas ist hier mit den Repositorien oder den Paketen faul, aber da ja die genaue Version der installierten Distribution geheim ist, ist das Rätselraten.
 
S

sepulchrat

Gast
Moin,
ich hab das gleiche Problem. Benutze auch Mandriva Free 64-bit 2009.
 

thobit

Routinier
Beiträge
265
Eine Suche welches Packet die libWand-10.7.0.so.0 zur Verfügung stellt blieb erfolglos.

Code:
[root@localhost ~]# rpm -q --whatprovides libWand-10.7.0.so.0
Kein Paket bietet libWand-10.7.0.so.0

Gibt es außer den plf und mdv Repos von easyurpmi noch andere Quellen um vielleicht an Packete zu kommen?
 

TeaAge

Routinier
Beiträge
465
Keine sinnvollen.
Höchstens nur mud.de (deutsche Comm), mncl (niederländische Comm) und vielleicht noch MIB (italienische Comm). Die werden dir hier aber auch nicht helfen, schätze ich.

Wenn du gucken willst welche Pakete eine bestimmte Datei beinhalten, dann nutzt du am besten rpmdrake. Klicke einfach auf die Lupe in dem Suchfeld und wähle "In Dateinamen".

Oder auf der Konsole mit urpmf
Code:
urpmf libdvdread
bringt zum Beispiel folgende Pakete als Ergebniss
Code:
libdvdread-devel:/usr/lib/libdvdread.la
libdvdread-devel:/usr/lib/libdvdread.so
libdvdread4:/usr/lib/libdvdread.so.4
libdvdread4:/usr/lib/libdvdread.so.4.1.2

Allerdings gilt das gerade für die 32bit Version.
Fehlende Abhängigkeiten bitte dem Paketbauer melden (auf englisch). Wenn ihr bei dem jeweiligen Paket in rpmdrake auf "Changelog" klickt, seht ihr auch immer die E-Mail des letzten Paketbauers.
 
G

Gast1

Gast
Ich benutze Mandriva Free 64-bit 2009.

Und dann wunderst Du Dich, daß es mit einem Paket für 2008.0 nicht funktioniert?

Code:
- transcode-1.0.3-3plf[B]2008.0.[/B]x86_64 (wegen nicht erfüllter Abhängigkeit von libWand-10.7.0.so.0()(64bit) )─
 

thobit

Routinier
Beiträge
265
Jepp, habe es auch gestern Nacht bemerkt. Habe jetzt die repos von 2009.1 reingezogen. Da ist offenbar die Abhängigkeit aufgelöst und alles läuft wunderbar. Mal sehen wie stabil das System bleibt. Sonst verzichte ich noch etwas auf transcode und warte auf das Erscheinen der 2009.1

mfg
thobit
 

Ähnliche Themen

VLC auf suse 10.1 64 bit installieren

Mein Leiden mit Linux

Oben