Suse 9.0 auf Omnibook 4150

Forester

Grünschnabel
Beiträge
4
Hallo zusammen,
vorab, ich habe zwar schon mehrere Linux Distributionen getestet und mich ein wenig eingearbeitet, bin aber dennoch der totale noob in der linux-area!
zum problem:
habe mir vorgenommen, linux auf mein hp omnibook 4150 (500Mhz / 128MB RAM / ATI Radeon Mobility 2xAGP / 6GB HDD) aufzuspielen. habe mehrere distributionen zur auswahl (kubuntu 6.06 / ubuntu 6.06 / suse 9.0 / suse 10.0 / suse 10.1....) und habe mich für suse 9.0 entschieden, da das notebook ja nicht mehr zu den jüngsten gehört...
->installation lief einwandfrei, auch booten tut er einwandfrei, nur sobald die kde umgebung geladen wird habe ich einen schwarzen bildschirm..., wenn ich einen externen monitor anschließe, ist der desktop für mich sichtbar.
in yast2 ist ein standard lcd mit 1024x768@70hz konfiguriert, habe auch schon eine niedrigere auflösung bzw hz-wert eingestellt, jedoch ohne erfolg...
habe auch bereits den failsafe modus gestartet...ohne probleme konnte ich mich einloggen usw aber nun fehlen mir die kenntnisse um auf diese weise fortzufahren.
habe auch schon mit dem gedanken gespielt eine neuere version zu installieren, bin aber der meinung, dass dies nicht der richtige weg bei dieser "alten krücke" ist.
freue mich über jeden tipp oder idee!
thx im vorraus
best regards
kerry
 

theton

Bitmuncher
Beiträge
4.820
Zuerstmal würde ich von SuSE 9.0 abraten, da du dafür keine Updates mehr bekommst. Ausserdem dürfte dir Ubuntu die weitaus bessere Performance bieten. Weiterhin solltest du bei 128MB RAM auf KDE verzichten und stattdessen zu Gnome oder einem noch kleineren Fenstermanager greifen (XFCE, WindowMaker, IceWM o.ä.).
Wenn du allerdings auf SuSE 9.0 bestehst, poste mal bitte dein X-Konfiguration. (Bei SuSE 9.0 dürfte das noch XFree sein, also /etc/X11/XF86Config o.ä.)
 

Forester

Grünschnabel
Beiträge
4
im prinzip könnte ich mich damit anfreunden eine andere distribution bzw. fenstermanager zu benutzen, zweck dieses notebooks ist es nur, dass ich mit einem c++ compiler und html editor arbeiten kann.

welche benutzeroberfläche habe ich bei ubuntu 6.06, und kann ich überhaupt diese version auf das notebook aufspielen(wegen der schwachen leistung...)?

hoffe dies ist die datei die du meintest:
Code:
# /.../
# SaX generated XFree86 config file
# Created on: 2006-12-27T13:45:39+0100.
#
# Version: 4.7
# Contact: Marcus Schaefer <sax@suse.de>, 2002
#
# Automatically generated by [ISaX] (4.7)
# PLEASE DO NOT EDIT THIS FILE!
#
Section "Files"
  FontPath     "/usr/X11R6/lib/X11/fonts/misc:unscaled"
  FontPath     "/usr/X11R6/lib/X11/fonts/local"
  FontPath     "/usr/X11R6/lib/X11/fonts/75dpi:unscaled"
  FontPath     "/usr/X11R6/lib/X11/fonts/100dpi:unscaled"
  FontPath     "/usr/X11R6/lib/X11/fonts/Type1"
  FontPath     "/usr/X11R6/lib/X11/fonts/URW"
  FontPath     "/usr/X11R6/lib/X11/fonts/Speedo"
  FontPath     "/usr/X11R6/lib/X11/fonts/PEX"
  FontPath     "/usr/X11R6/lib/X11/fonts/cyrillic"
  FontPath     "/usr/X11R6/lib/X11/fonts/latin2/misc:unscaled"
  FontPath     "/usr/X11R6/lib/X11/fonts/latin2/75dpi:unscaled"
  FontPath     "/usr/X11R6/lib/X11/fonts/latin2/100dpi:unscaled"
  FontPath     "/usr/X11R6/lib/X11/fonts/latin2/Type1"
  FontPath     "/usr/X11R6/lib/X11/fonts/latin7/75dpi:unscaled"
  FontPath     "/usr/X11R6/lib/X11/fonts/baekmuk:unscaled"
  FontPath     "/usr/X11R6/lib/X11/fonts/japanese:unscaled"
  FontPath     "/usr/X11R6/lib/X11/fonts/kwintv"
  FontPath     "/usr/X11R6/lib/X11/fonts/truetype"
  FontPath     "/usr/X11R6/lib/X11/fonts/uni:unscaled"
  FontPath     "/usr/X11R6/lib/X11/fonts/CID"
  FontPath     "/usr/X11R6/lib/X11/fonts/ucs/misc:unscaled"
  FontPath     "/usr/X11R6/lib/X11/fonts/ucs/75dpi:unscaled"
  FontPath     "/usr/X11R6/lib/X11/fonts/ucs/100dpi:unscaled"
  FontPath     "/usr/X11R6/lib/X11/fonts/hellas/misc:unscaled"
  FontPath     "/usr/X11R6/lib/X11/fonts/hellas/75dpi:unscaled"
  FontPath     "/usr/X11R6/lib/X11/fonts/hellas/100dpi:unscaled"
  FontPath     "/usr/X11R6/lib/X11/fonts/hellas/Type1"
  FontPath     "/usr/X11R6/lib/X11/fonts/misc/sgi:unscaled"
  FontPath     "/usr/X11R6/lib/X11/fonts/xtest"
  InputDevices "/dev/ttyS0"
  InputDevices "/dev/ttyS1"
  InputDevices "/dev/ttyS2"
  InputDevices "/dev/ttyS3"
  InputDevices "/dev/ttyS4"
  InputDevices "/dev/ttyS5"
  InputDevices "/dev/ttyS6"
  InputDevices "/dev/ttyS7"
  InputDevices "/dev/ttyS8"
  InputDevices "/dev/psaux"
  InputDevices "/dev/logibm"
  InputDevices "/dev/sunmouse"
  InputDevices "/dev/atibm"
  InputDevices "/dev/amigamouse"
  InputDevices "/dev/atarimouse"
  InputDevices "/dev/inportbm"
  InputDevices "/dev/gpmdata"
  InputDevices "/dev/mouse"
  InputDevices "/dev/usbmouse"
  InputDevices "/dev/adbmouse"
  InputDevices "/dev/input/mice"
  InputDevices "/dev/input/event0"
  InputDevices "/dev/pointer0"
  InputDevices "/dev/pointer1"
  InputDevices "/dev/pointer2"
  InputDevices "/dev/pointer3"
EndSection

Section "ServerFlags"
  Option       "AllowMouseOpenFail"
EndSection

Section "Module"
  Load         "extmod"
  Load         "type1"
  Load         "glx"
  Load         "freetype"
  Load         "v4l"
  Load         "dbe"
  Load         "speedo"
EndSection

Section "InputDevice"
  Driver       "Keyboard"
  Identifier   "Keyboard[0]"
  Option       "Protocol" "Standard"
  Option       "XkbLayout" "de"
  Option       "XkbModel" "pc105"
  Option       "XkbRules" "xfree86"
  Option       "XkbVariant" "nodeadkeys"
EndSection

Section "InputDevice"
  Driver       "mouse"
  Identifier   "Mouse[1]"
  Option       "Device" "/dev/pointer1"
  Option       "Emulate3Buttons" "on"
  Option       "Name" "Autodetection"
  Option       "Protocol" "ps/2"
  Option       "Vendor" "Sysp"
EndSection

Section "InputDevice"
  Driver       "mouse"
  Identifier   "Mouse[3]"
  Option       "Device" "/dev/pointer0"
  Option       "Name" "Autodetection"
  Option       "Protocol" "imps/2"
  Option       "Vendor" "Sysp"
EndSection

Section "Monitor"
  Option       "CalcAlgorithm" "CheckDesktopGeometry"
  HorizSync    32-61
  Identifier   "Monitor[0]"
  ModelName    "1024 LCD FLAT PANEL 14-INCH DISPLAY"
  VendorName   "HP"
  VertRefresh  50-90
  UseModes     "Modes[0]"
EndSection

Section "Modes"
  Identifier   "Modes[0]"
  Modeline 	"1024x768" 61.89 1024 1080 1184 1344 768 769 772 794
  Modeline 	"1024x768" 73.89 1024 1080 1192 1360 768 769 772 799
  Modeline 	"1024x768" 80.71 1024 1080 1192 1360 768 769 772 802
  Modeline 	"800x600" 36.88 800 832 912 1024 600 601 604 621
EndSection

Section "Screen"
  DefaultDepth 16
  SubSection "Display"
    Depth      15
    Modes      "1024x768" 
  EndSubSection
  SubSection "Display"
    Depth      16
    Modes      "800x600" 
  EndSubSection
  SubSection "Display"
    Depth      24
    Modes      "1024x768" 
  EndSubSection
  SubSection "Display"
    Depth      32
    Modes      "1024x768" 
  EndSubSection
  SubSection "Display"
    Depth      8
    Modes      "1024x768" 
  EndSubSection
  Device       "Device[0]"
  Identifier   "Screen[0]"
  Monitor      "Monitor[0]"
EndSection

Section "Device"
  BoardName    "3D Rage P/M Mobility AGP 2x"
  BusID        "1:0:0"
  Driver       "ati"
  Identifier   "Device[0]"
  Screen       0
  VendorName   "ATI"
EndSection

Section "ServerLayout"
  Identifier   "Layout[all]"
  InputDevice  "Keyboard[0]" "CoreKeyboard"
  InputDevice  "Mouse[1]" "CorePointer"
  InputDevice  "Mouse[3]" "SendCoreEvents"
  Option       "Clone" "off"
  Option       "Xinerama" "off"
  Screen       "Screen[0]"
EndSection

Section "DRI"
    Group      "video"
    Mode       0660
EndSection
 
Zuletzt bearbeitet:

theton

Bitmuncher
Beiträge
4.820
Könntest du bitte aus dem Quote-Block einen Code-Block machen? Liest sich dann besser und nimmt weniger Platz weg. Ausserdem würde ich deine Section "Monitor" mal aufräumen (mal ohne die Options versuchen).

Und schau mal in die Logs von X (/var/log/XFree86.0.log o.ä.) ob sich da evtl. Fehler oder Warnungen bezüglich des Screens befinden.

Ubuntu sollte problemlos auch auf deinem alten Rechner laufen. Wenn du RAM sparen willst, würde ich sogar Xubuntu empfehlen, was per Default einen kleinen Fenstermanager nutzt.
 

Forester

Grünschnabel
Beiträge
4
sry, wie mach ich aus dem quote-block ein code-block?

habe die section "monitor" -option weggelassen, das problem besteht weiterhin
welche desktop-umgebung bietet mir ubuntu/xubuntu??

denke ich werden morgen mal suse 9.0 mit gnome installlieren, sollte das nicht funktionieren werde ich auf ubuntu zurückgreifen.

danke schonmal für deine ratschläge!
 

theton

Bitmuncher
Beiträge
4.820
Ubuntu bietet dir Gnome, Xubuntu kommt mit XFCE daher.
http://www.ubuntu.com/
http://www.xubuntu.org/

Um einen Quote-Block zu einem Code-Block zu machen, bearbeitest du einfach den Beitrag und tauscht die Tags entsprechend aus.

In der X-Konfiguration sehe ich soweit keine Fehler und keinen Grund, warum das ganze falsch angesteuert wird. Evtl. ist es einfach ein Problem von XFree86. Mit Xorg (was bei moderneren Linux-Distros XFree86 abgelöst hat) hatte ich mit Laptop-Bildschirmen eigentlich noch nie Probleme.
 

Ähnliche Themen

HP Omnibook mit OpenSuse 10 -Grafikprobleme

ati 9500 pro Treiber macht probleme XD

suse 9.0 und mikrofon mit nforce2

Oben