Spamassassin als user spam starten

Diskutiere Spamassassin als user spam starten im Debian/Ubuntu/Knoppix Forum im Bereich Linux Distributionen; Hi, ich würde gerne spamd über init.d unter user spam und nicht unter root starten, ich habe dazu aber im init-script kein setting gefunden....

  1. #1 Nemesis, 20.11.2010
    Nemesis

    Nemesis N3RD

    Dabei seit:
    28.01.2005
    Beiträge:
    2.168
    Zustimmungen:
    0
    Hi,
    ich würde gerne spamd über init.d unter user spam und nicht unter root starten, ich habe dazu aber im init-script kein setting gefunden. weiss jemand wie man das einrichten kann ?

    thx !
     
  2. NoXqs

    NoXqs Routinier

    Dabei seit:
    07.05.2007
    Beiträge:
    420
    Zustimmungen:
    0
    Ort:
    Bremen
    Im Startscript beim Aufruf des Kommandos einfach ein
    Code:
    su spam -c "${COMMAND}"
    
    davor setzen?
     
  3. #3 Nemesis, 27.11.2010
    Nemesis

    Nemesis N3RD

    Dabei seit:
    28.01.2005
    Beiträge:
    2.168
    Zustimmungen:
    0
    ich hab das init-script abgeändert, im start-stoip-daemon gibts auch den parameter -c.

    aber jetzt habe ich ein anderes problem:
    Code:
    Starting SpamAssassin Mail Filter Daemon: [13995] warn: server socket setup failed, retry 1: spamd: could not create INET socket on 127.0.0.1:783: Keine Berechtigung
    [13995] warn: server socket setup failed, retry 2: spamd: could not create INET socket on 127.0.0.1:783: Keine Berechtigung
    [13995] error: spamd: could not create INET socket on 127.0.0.1:783: Keine Berechtigung
    spamd: could not create INET socket on 127.0.0.1:783: Keine Berechtigung
     
  4. doc

    doc Kaffeetrinker

    Dabei seit:
    26.08.2006
    Beiträge:
    586
    Zustimmungen:
    0
    Ort:
    bremen
  5. Lord_x

    Lord_x Guest

    Ports unter 1024 können nur von Root "geöffnet" werden...
    Lösung wäre den Port auf 10783 zu ändern.
     
  6. #6 Nemesis, 27.11.2010
    Nemesis

    Nemesis N3RD

    Dabei seit:
    28.01.2005
    Beiträge:
    2.168
    Zustimmungen:
    0
    hm ... dumm gefragt, wo ändere ich den port von spamassassin ? ich habe nirgends ein setting finden können.
     
  7. doc

    doc Kaffeetrinker

    Dabei seit:
    26.08.2006
    Beiträge:
    586
    Zustimmungen:
    0
    Ort:
    bremen
    debian:

    z.B. /etc/default/spamassassin

    # Options
    # See man spamd for possible options. The -d option is automatically added.

    # SpamAssassin uses a preforking model, so be careful! You need to
    # make sure --max-children is not set to anything higher than 5,
    # unless you know what you're doing.

    OPTIONS="--create-prefs --max-children 5 --helper-home-dir"


    oder auch einfach im initscript selber
     
  8. #8 Nemesis, 27.11.2010
    Nemesis

    Nemesis N3RD

    Dabei seit:
    28.01.2005
    Beiträge:
    2.168
    Zustimmungen:
    0
    alles klar,läuft wieder, danke :-)
     
Thema:

Spamassassin als user spam starten

Die Seite wird geladen...

Spamassassin als user spam starten - Ähnliche Themen

  1. Spamassassin kennt virtuale User nicht!!!

    Spamassassin kennt virtuale User nicht!!!: Hallo, ich habe hier eine Debian Etch Installation. Für den Mailversand verwende ich Postfix mit Amavis und Spamassassin. Die Mailuser sind in...
  2. SpamAssassin 3.4.0 mit IPv6

    SpamAssassin 3.4.0 mit IPv6: Mit der Freigabe der Version 3.4.0 hat das SpamAssassin-Projekt seinen Spam-Filter weiter verbessert. Er bringt unter anderem eine native...
  3. dovecot.sieve und spamassassin

    dovecot.sieve und spamassassin: Hi, ich hätte gerne, dass dovecot mit dem sieve-plugin mails die von spamassassin gekennzeichnet wurden automatisch in den junk-ordner verschiebt,...
  4. Frage zu Spamassassin

    Frage zu Spamassassin: Hallo, ich habe CentOs mit Postfix und SpamAssassin version 3.2.5 mit Clamav am laufen. Jetzt ist mir im Log folgendes aufgefallen das eine...
  5. spamassassin - Statusmail

    spamassassin - Statusmail: Hallo, denke eigentlich, daß mein Anliegen nicht so unüblich sein sollte. Finde aber über Web- und Forensuche nichts dazu. Ich würde gerne,...