Samba sagt: "Ey, du kommst hier net rein!"

Diskutiere Samba sagt: "Ey, du kommst hier net rein!" im Internet, lokale Netzwerke und Wireless Lan Forum im Bereich Netzwerke & Serverdienste; Hallo zusammen, mein Samba treibt mich zur Verzweiflung. Ich möchte Freigaben festlegen und von Windows darauf zugreifen. Die...

  1. #1 dunkler_Elf, 05.09.2009
    dunkler_Elf

    dunkler_Elf Eroberer

    Dabei seit:
    05.06.2006
    Beiträge:
    67
    Zustimmungen:
    0
    Hallo zusammen,

    mein Samba treibt mich zur Verzweiflung.
    Ich möchte Freigaben festlegen und von Windows darauf zugreifen.
    Die Zugriffsrechte sollen an bestimmte Benutzer gebunden sein.

    Unter Open SuSE bekam ich die Konfiguration hin, unter Fedora 11 geht es nicht.
    Vielleicht bin ich blind, aber ich sehe einfach keinen Fehler. :(

    Die config-Datei findet ihr hier:
    http://www.heterometrus.de/daten/errors/smb.conf

    Mein Windows XP zeigt den freigegeben Ordner zwar an, sagt mir aber folgendes:
    "Mit diesem Konto kann man sich nicht von diesem Computer aus anmelden."

    Der Windowsbenutzer wurde aber als Sambabenutzer angelegt.
    Abgesehen davon wäre es mir am liebsten, wenn er Benutzer und Passwaort abfragt, wenn man auf eine Ressource zugreifen will.

    Kann jemand den Fehler sehen?


    dunkler Elf
     
  2. @->-

    @->- Guest

    Hat der Samba User auch rechte für /Daten/Transferdaten? Sind die workgroup von Samba/Windows gleich (vereifacht es).

    Kannst mal hier schauen http://wiki.archlinux.de/title/Samba ist verständlich erklärt und sollte sich auch auf fedora ohne Probleme übertragen lassen

    In diesem Sinne
     
  3. #3 Gast123, 06.09.2009
    Zuletzt von einem Moderator bearbeitet: 06.09.2009
    Gast123

    Gast123 Guest

    Dann kopiere doch die /etc/samba/smb.conf und /etc/samba/smbpasswd.

    Edit:
    Bei deinen shares ist fast alles auskommentiert!
    Ist das Absicht?

    MfG
     
  4. #4 dunkler_Elf, 06.09.2009
    dunkler_Elf

    dunkler_Elf Eroberer

    Dabei seit:
    05.06.2006
    Beiträge:
    67
    Zustimmungen:
    0
    hallo und danke erst mal für die antworten.

    also:

    ja, die arbeitsgruppen sind gleich.

    die system-user, denen die samba-user zugeordnet sind, müssten zugriffsrechte auf den ordner haben (jeder hat alle rechte).

    die smb.conf hätte ich gerne kopiert, aber ich habe die alte nicht mehr. zudem war es nicht der gleiche pc. ich habe die distribution zum teil auch deswegen gewechselt.

    die shares hab ich dem fall nicht ich auskommentiert. das ist die datei, die entsteht, wenn ich es mit dem tool kofiguriere.

    das mit dem link werd ich jetzt auf jeden fall noch probieren.

    dunkler Elf
     
  5. @->-

    @->- Guest

    Noch mal als kleiner Tipp, nimm eine OpenSuse LiveCD und erstelle dir dort mit Yast eine neue smb.conf, geht auch mit Ubuntu wunderbar mit 2x Klicken :)

    In diesem Sinne
     
  6. #6 dunkler_Elf, 06.09.2009
    dunkler_Elf

    dunkler_Elf Eroberer

    Dabei seit:
    05.06.2006
    Beiträge:
    67
    Zustimmungen:
    0
    so, hat tatsächlich nochmal ne alte konfigurationsdatei gefunden. kann aber nicht mehr mit sicherheit sagen, ob die damals lauffähig war.

    nach meiner anpassung auf das neue system sieht sie so aus:
    http://www.heterometrus.de/daten/errors/smb2.conf

    damit ist der computer im netzwerk sichtbar und man bekommt auch den freigegeben ordner angezeigt. versucht man aber darauf zuzugreifen kommt folgenden nachricht:
    http://www.heterometrus.de/daten/errors/error.jpg


    kann es sein, dass die firewall den zugriff blockiert?
    an sich sollte es nicht der fall sein, da ich die netzwerkschnittstelle als vertrauenswürdig eingestellt habe.
     
  7. #7 kartoffel200, 07.09.2009
    Zuletzt bearbeitet: 07.09.2009
    kartoffel200

    kartoffel200 AMD Fanboy Since 2003

    Dabei seit:
    12.03.2007
    Beiträge:
    938
    Zustimmungen:
    0
    Ort:
    L wie localhost
    Hast du mal testparm ausgeführt?

    Also normal kenn ich das so:
    Freigabe anlegen:
    Freigabe ...(alle möglichen Parameter) und darin valid users.
    Dateibereichtigungen mit chmod & chown.
    smbpasswd um die benutzer für Samba freizuschalten.



    Wenn du eine aktive Firewall auf dem Linux hast mach sie aus und auf Windows musst du glaub ich gar nichts machen, obwohl die Windows Firewall auch scheiße also deaktivieren lohnt sich.


    vllt solltest du mal in Windows mit net use mounten .... da kriegt man dann schöne Meldungen wie Systemfehler XY... "net use X: \\192.168.123.123\XXX /u:Hostname\Benutzer Password"
     
  8. NoXqs

    NoXqs Routinier

    Dabei seit:
    07.05.2007
    Beiträge:
    420
    Zustimmungen:
    0
    Ort:
    Bremen
    Schau einfach mal in die logs auf dem server.
    Da steht bestimmt drin, warum der Zugriff nicht klappt.
    Alles andere kann nur reine Spekulation sein und hilft niemandem weiter.
     
  9. #9 dunkler_Elf, 12.09.2009
    Zuletzt bearbeitet: 14.09.2009
    dunkler_Elf

    dunkler_Elf Eroberer

    Dabei seit:
    05.06.2006
    Beiträge:
    67
    Zustimmungen:
    0
    also...
    ... bisher hat noch nichts funktioniert. hab nun auch noch ein besseres tool zur konfiguration gefunden: gadmin-samba. leider hilft ändert es nichts daran, dass es nicht funktioniert.
    inzwischen denke, ich dass es nicht an samba selbst liegt, sondern dass das problem wo anders liegt.

    die aktuelle konfigurationsdatei ist hier:
    http://www.heterometrus.de/daten/errors/smb3.conf

    die damit entstandene log-datei hier:
    http://www.heterometrus.de/daten/errors/samba.log


    EDIT: --------------------------------------------

    ok, ich denke ich habe die ursache gefunden.
    SELinux hat die zugriffe blockiert.
    wenn ich es ausschalte geht es.
    nun kann ich bei gelegenheit suchen, was genau blockiert wird und wie ich es freigeben kann.

    --------------------------------------------------
     
Thema:

Samba sagt: "Ey, du kommst hier net rein!"

Die Seite wird geladen...

Samba sagt: "Ey, du kommst hier net rein!" - Ähnliche Themen

  1. Samba 4.5.12-Debian Rechtevergabe

    Samba 4.5.12-Debian Rechtevergabe: Hallo zusammen, wir hatten intern einen Dateiserver mit SerNet-Samba 3.5 und einer Authentifizierung am Active Directory. Das ganze habe ich auf...
  2. Samba 4 Schema erweitern per LDIF - Server is unwilling to perform (53)

    Samba 4 Schema erweitern per LDIF - Server is unwilling to perform (53): Hallo zusammen, ich versuche gerade ein Samba 4 mittels LDIF zu erweitern. Die Objekte in dem LDIF stammen von einem Windows AD. Hintergrund ist,...
  3. Keine Zugriff von Windows 10 auf Sambafreigaben

    Keine Zugriff von Windows 10 auf Sambafreigaben: Hallo liebe Forumsmitglieder, Ich habe auf meinem Server (mit fester interner und externer) IP einen VPN und einen Samba Server installiert. Ich...
  4. Zugriff auf Samba Fileserver Freigaben verweigert(Samba 4 Active Directory Domäne)

    Zugriff auf Samba Fileserver Freigaben verweigert(Samba 4 Active Directory Domäne): Hallo, ich möchte eine Active Directory Domäne mit Samba4 erzeugen. Es handelt sich um zwei Server(Domänencontroller und Fileserver) und ca. 10...
  5. SAMBA 4 und Mac Client

    SAMBA 4 und Mac Client: Hallo zusammen, vielleicht kann mir jemand helfen... Ich habe eine Samba Server auf Ubuntu Basis installiert und möchte nun von unterschiedlichen...