Probleme mit Samba-Installation

B

bnice

Grünschnabel
Hi,

ich versuche auf einem CentOS 5 einen Samba 3 Server aufzusetzen.
Installation mittels "yum install samba samba-common samba-client samba-swat" funktioniert soweit auch problemlos.
Ich habe mir erstmal eine Basis Config zum Testen erstellt:

smb.conf:
Code:
[global]
  workgroup = test

Soweit sollte alles gut sein.
Allerdings kann ich den SMB-Dienst nicht starten, bzw. er beendet sich sofort wieder.
Fehlermeldung im Log:
Code:
bind failed on port 445 socket_addr = 0.0.0.0.
Error = Die Adresse wird bereits verwendet

Ein Aufruf des smbclients bringt folgende Meldung:
Code:
smbclient -L localhost
protocol negotiation failed

Ich muss jetzt allerdings auch dazu sagen, dass ich Samba bereits mehrmals deinstalliert und neuinstalliert habe, auch mit löschen der Ordner /var/cache/samba und /etc/samba

Der Server lief erst mit DHCP, ist jetzt aber mit fester IP konfiguriert - Leider scheint das nichts zu ändern...
Wäre klasse, wenn jemand weiss, wo das Problem liegt, ich konnte bisher keine Lösung finden...
 
O

o-n

Jungspund
Hi,
du solltest als erstes mal prüfen ob auf diesem Port bereits ein Dienst läuft - zumindest weist die Fehlermeldung auf einen solchen umstand hin.
Dies tust du z.B. mit "netstat -pl" und schau mal in der /etc/inetd.conf oder /etc/xinetd.conf ob es bereits einen smb service oder anderen Dienst auf dem Port gibt.
 

Ähnliche Themen

Samba 3.6.25 - OpenLDAP Setup

Zugriff auf Samba Fileserver Freigaben verweigert(Samba 4 Active Directory Domäne)

Sambaserver im Netzwerk nicht sichtbar

Samba 4 Gast Zugang unter Ubuntu funktioniert nicht

Windows clients können nicht mehr auf lange laufendes System zugreifen

Oben