Probleme mit *.html als DirectoryIndex

Diskutiere Probleme mit *.html als DirectoryIndex im Web- & File-Services Forum im Bereich Netzwerke & Serverdienste; Hallo zusammen, ich habe einige ebooks auf meinem Rechner und wollte diese mit Hilfe von Apache2 über einen Alias "http://localhost/<Alias>"...

  1. #1 ew_wolf, 18.07.2009
    ew_wolf

    ew_wolf Tripel-As

    Dabei seit:
    02.06.2006
    Beiträge:
    157
    Zustimmungen:
    0
    Hallo zusammen,

    ich habe einige ebooks auf meinem Rechner und wollte diese mit Hilfe von Apache2 über einen Alias "http://localhost/<Alias>" erst mal lokal aufrufbar machen.
    Nun habe ich in der "httpd.conf" folgenden beispielhaften Eintrag vorgenommen.
    Code:
    Alias /java "/var/www/java/"
            <Directory "/var/www/java/">
                    Options Indexes FollowSymLinks
                    DirectoryIndex index.html
            </Directory>
    
    Alias /javainsel7 "/var/www/javainsel7"
            <Directory "/var/www/java/">
                    #Require valid-user
                    Options Indexes FollowSymLinks
                    DirectoryIndex index.htm
            </Directory>
    
    Die Module "mod_dir" und "mod_Autoindex" wurden ebenfalls aktiviert.
    Nun zeigt sich folgendenes Verhalten:
    - Wenn ich "http://localhost/javainsel7" im Browser eingebe wird korrekterweise sofort die "index.htm"-Seite geöffnet
    - Gebe ich hingegen "http://localhost/java" ein, so wird nicht die "index.html"-Seite angezeigt, sondern es wird nur Verzeichnis mit allen darin enthaltenden Dateien im Browser angezeigt.
     
  2. #2 saeckereier, 18.07.2009
    saeckereier

    saeckereier Graue Eminenz

    Dabei seit:
    08.05.2005
    Beiträge:
    1.920
    Zustimmungen:
    0
    Ort:
    Im schönen Norden
    Alias /javainsel7 "/var/www/javainsel7"
    <Directory "/var/www/java/">

    ???
     
  3. #3 karru, 18.07.2009
    Zuletzt bearbeitet: 18.07.2009
    karru

    karru OSX'ler

    Dabei seit:
    02.05.2006
    Beiträge:
    338
    Zustimmungen:
    0
    Widerspricht sich irgendwie der Code-Schnipsel... :)
     
  4. #4 ew_wolf, 18.07.2009
    ew_wolf

    ew_wolf Tripel-As

    Dabei seit:
    02.06.2006
    Beiträge:
    157
    Zustimmungen:
    0
    Habt ja recht!
    Das ist nur ein Schreibfehler hier im Forum.
    Code:
    Alias /java "/var/www/java/"
            <Directory "/var/www/java/">
                    Options Indexes FollowSymLinks
                    DirectoryIndex index.html
            </Directory>
    
    Alias /javainsel7 "/var/www/javainsel7"
            <Directory "/var/www/javainsel7/">
                    Options Indexes FollowSymLinks
                    DirectoryIndex index.htm
            </Directory>
    
    So jetzt ist es korrekter ;-)

    Meine Config-Files hab diesen Fehler nicht!!!
     
  5. daboss

    daboss Kaiser

    Dabei seit:
    05.01.2007
    Beiträge:
    1.297
    Zustimmungen:
    0
    Ort:
    bavaria.germany.europe.world
    ?
     
  6. #6 saeckereier, 19.07.2009
    saeckereier

    saeckereier Graue Eminenz

    Dabei seit:
    08.05.2005
    Beiträge:
    1.920
    Zustimmungen:
    0
    Ort:
    Im schönen Norden
    Bitte die Config einmal kopieren und einfügen, was mit dem Abtippen passiert sehen wir ja.. Ausserdem die Meldungen aus dem error.log.
     
  7. #7 ew_wolf, 20.07.2009
    ew_wolf

    ew_wolf Tripel-As

    Dabei seit:
    02.06.2006
    Beiträge:
    157
    Zustimmungen:
    0
    So hier die Kopie aus 'httpd.conf'
    Code:
    Alias /java "/var/www/java/"
            <Directory "/var/www/java/">
                    #Require valid-user
                    Options Indexes FollowSymLinks
                    DirectoryIndex index.html
            </Directory>
    
    Alias /java2 "/var/www/java2/"
            <Directory "/var/www/2ava2/">
                    #Require valid-user
                    Options Indexes FollowSymLinks
                    DirectoryIndex java2index.htm
            </Directory>
    
    Die einzigen Log-Ausgaben fand ich unter '/var/log/apache2/access.log'.
    Trotz Umstellung des Log-Moduses von Apache auf 'debug' ist das logging nicht sehr ergiebig. Hier die Log-Ausgaben.
    Code:
    127.0.0.1 - - [20/Jul/2009:10:40:59 +0200] "GET /java HTTP/1.1" 301 341 "http://localhost/" "Mozilla/5.0 (X11; U; Linux x86_64; de; rv:1.9.0.11) Gecko/2009061208 Iceweasel/3.0.6 (Debian-3.0.6-1)"
    127.0.0.1 - - [20/Jul/2009:10:40:59 +0200] "GET /java/ HTTP/1.1" 200 828 "http://localhost/" "Mozilla/5.0 (X11; U; Linux x86_64; de; rv:1.9.0.11) Gecko/2009061208 Iceweasel/3.0.6 (Debian-3.0.6-1)"
    
     
  8. marce

    marce Kaiser

    Dabei seit:
    01.08.2007
    Beiträge:
    1.149
    Zustimmungen:
    15
    ist das wirklich Copy-Paste?
    Code:
    <Directory "/var/www/2ava2/">
    
     
  9. #9 saeckereier, 20.07.2009
    saeckereier

    saeckereier Graue Eminenz

    Dabei seit:
    08.05.2005
    Beiträge:
    1.920
    Zustimmungen:
    0
    Ort:
    Im schönen Norden
    Ich hoffe, dann ist das der Fehler :-)
    ew_wolf: Wenn die Datei nicht gefunden wird, gibt es eigentlich immer einen Eintrag im error_log, vielleicht hast du ja keines definiert? Auch inder access_log fehlen die relevanten Zeilen mit dem Aufruf von java2. Aber die access_log hilft da eh nicht.
     
Thema:

Probleme mit *.html als DirectoryIndex

Die Seite wird geladen...

Probleme mit *.html als DirectoryIndex - Ähnliche Themen

  1. Probleme mit WinSCP und Rechten

    Probleme mit WinSCP und Rechten: Hallo. Ich habe vor ein paar Tgen meinen ersten Ubuntu 16.04 vServer bei 1&1 bestellt, gemäß dem sicheren Umgang damit, habe ich erstmal den SSH...
  2. grub-pc Probleme bei upgrade

    grub-pc Probleme bei upgrade: Hallo, ich habe beim dist-upgrade folgendes Problem: ---------- Nach dieser Operation werden 0 B Plattenplatz zusätzlich benutzt. Trigger für...
  3. Probleme mit YUM

    Probleme mit YUM: Hallo, ich habe CentOs 7 als Dualboot mit Windows 7 auf einen Dell Latitude E5510 installiert. Dies hat soweit auch alles geklappt. Leider habe...
  4. Forscher analysieren Durchsatzprobleme im Linux-Scheduler

    Forscher analysieren Durchsatzprobleme im Linux-Scheduler: Eine Gruppe von Forschern hat Fälle identifiziert, in denen der Scheduler im Linux-Kernel falsche Entscheidungen trifft und die CPUs nicht so gut...
  5. München: LiMux als Sündenbock für IT-Probleme?

    München: LiMux als Sündenbock für IT-Probleme?: Im Münchner Stadtrat soll später in diesem Jahr erneut über den Einsatz von Linux in der Stadtverwaltung diskutiert werden. Die Grünen vermuten,...